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Preface 

Finite element is a numerical method that can be employed to solve a complex problem in which 

no classical solutions can be applied. It is based on the usage of matrix and with the aid of computer 

facilities. The finite element was developed half a century ago and has since been used in various 

fields of engineering and applied science. It can also be used to obtain an approximate solution for 

engineering analysis.  

The Abaqus Software is one successful finite element package which developed since 1978 and 

has been used for numerical simulation of complex problems in various fields such as Civil and 

especially Structural Engineering. The Abaqus is a general-purpose finite element simulation 

package used for mainly numerically solving a wide variety of design engineering problems. Many 

of these problems include static/dynamic structural analysis (both linear and non-linear), heat 

transfer and fluid problems, as well as acoustic and electromagnetic problems. Abaqus contains 

many special tools that assist in analyzing various effects such as plasticity, large deformations, 

hyper-plasticity, creep, high deflection, interface contact, the dependence of various properties on 

temperature and pressure, anisotropy and radiance. The possibility of substructures, sub-modeling, 

and optimization are also available by adding subroutines to the application. Therefore, the use of 

computer software such as Abaqus is vital and necessary in order to analyze and solve engineering 

problems. 

Although implementing Abaqus in solving many issues in various fields of Civil Engineering has 

been considered by many experts, however, its application to address complex problems in 

Structural engineering is highly complicated. Therefore, this book aims to present specific 

complicated and puzzling challenges encountered for application of the Finite Element Method 

(FEM) in solving Structural Engineering problems by using Abaqus software, which can fully 

utilize this method in complex simulation and analysis. 

Therefore, an attempt has been to demonstrate the all process for modeling and analysis of 

impenetrable problems through simplified step by step illustration with presenting screenshots 

from software in each part and also showing graphs.  

After reading of this book, the skill and knowledge of readers for modeling and analysis of 

complicated and convoluted problems in Structural Engineering will be incredibly enhanced and 

they will capable to: 

• Solving general and complicated problems in the Structural Engineering field by using 

Abaqus Software in a reasonable time frame and with reasonable effort.  

• Developing of Subroutine for Abaqus software to solve the special problems.  

• The ability to analyze and modeling different types of structures with various conditions. 

• Easily apply the Abaqus Software to simulate irregular-shaped objects composed of several 

different materials with multipart boundary conditions. 

• The ability to complete various tutorials from a broad array of applications such as bridges, 

offshores, dam, seismic resistant systems, and so forth. 

• Implement the available tools in Abaqus software such as scripting mesh and writing 

subroutines. 

• Apply various load effects such as dynamic, explosive loading, seismic excitation, long 

term fluid influx, and impact load to the developed structural models in Abaqus Software. 
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• Implement various types of new materials such as Ultra High-Performance Fiber Concrete 

in special structures such as high-rise or towers by considering damage plasticity models. 

• Simulate the fluids penetration in the porous medium and soil consolidations. 

• Extract the modal and buckling modes to estimate structures tolerance limits. 

• Implement the optimization tools to define design constrains, design objectives and 

restrictions for the best available conditions. 
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Chapter 1: Introduction about Finite Element Method 

 

 

1.1. Introduction 

Analysis of engineering problems through numerical method is result of solving a numerous 

number of coupled and uncoupled equations. These equations are derived based on the principal 

laws of physics and mathematics, including equilibrium forces, energy stability, mass survival, 

thermodynamics laws, Maxwell theory and Newtonian laws of motion. However, the 

mathematical models based on these equations are mostly complex and impossible to solve 

manually, except for very regular geometries such as circles and rectangles, which have quite 

simple boundaries. Therefore, the use of numerical methods to solve of these numerous numbers 

of coupled and uncoupled equations is vital. 

The finite element method (FEM) is a part of numerical solution processes, which is widely used 

in the most fields of engineering such as solid mechanic, structures, fluids, heat transfer, sound, 

etc. Therefore, nowadays the FEM is considered as an essential part of analysis and design in most 

of engineering fields. This method is undoubtedly one of the most powerful and versatile tools for 

solving basic engineering problems. However, due to the purely computational basis and the 

simultaneous analysis procedure, it may be considered as very complicated tools to use for 

researchers, engineers and students.  

As with many scientific phenomena, the exact history of the finite element method is unclear. 

However, the evidences are proving that Richard Courant used this method to analyze complex 

structures in civil and aerospace engineering in 1943. At that time, no specific name was given to 

this method, and the method which Courant used, was break down of continuous medium 

(material) into a series of smaller pieces of material called elements (components). 
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As mentioned nowadays, the finite element method is widely implementing in solving and analysis 

of various engineering problems and it is expected to make a significant progress in the near future. 

Due to the fast advancement of personal computers, supercomputers and other computation 

systems to solve engineering problems, the development of finite element method and its practical 

application has increased significantly in the recent decades.  

 

1.2. Main Process for Finite Element Modeling and Analysis  

The main process for finite element modeling and analysis are summarized in 7 following steps: 

1.2.1. Step 1: Idealization 

In this step, based on considered problem and its geometry and conditions, the problem is idealized 

as one-, two- or three-dimensional problem or axisymmetric, plane stress or plan strain problem. 

The computational volume of the analysis is directly related to the number of degrees of freedom 

of the model. The number of degrees of freedom located on each node can be determined according 

to the problem definition in 2D or 3D and the type of analysis. For example, for stress-strain 

analysis in three-dimensional models, six degrees of freedom (translation in three directions x, y 

and z and rotation around each of these three axes) and in two-dimensional models, three degrees 

of freedom (translation in two directions of x and y and the rotation around the z-axis) is allocated 

for each node.  

 

1.2.2. Step 2: Discretization 

In this step the considered geometry discretizes into discrete components called as elements. The 

elements are connected to each other using points which called as nodes. Dividing and shredding 

the geometric shape is the essential process in the finite element method.  
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Finite elements and nodes form the geometry of analytical models. Elements are small geometric 

shapes of a member, which contain specific and complete properties of an analytical model and 

are connected by nodes. In fact, the number and location of nodes define the shape of the elements. 

The location of the nodes and the connection of elements to each other determine the final 

coordinates and dimensions of the member geometry.  

 

1.2.2.1. Meshing of Model 

The set of all elements and nodes is called mesh. The mesh and the main geometry of the model 

are usually overlapped and compatible. Depend on shape of member the mesh size can be 

determined as fine mech or coarse mesh. Although using fine mesh is lead to have accurate results 

however it is required huge computational process which is time consuming and cost a lot. 

Therefore, the best mesh size is the optimum element size to give accurate results with appropriate 

computational process.  An example of discretization and meshing of various parts for a problem 

regarding soil-structure interaction is showed in  Figure 1-1. 

 

 

 
Figure 1-1:Discretization and Meshing of various parts of considered geometry 
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In addition to nodes and elements, other components such as integration points and also cross-

sections play an important role in meshing the model to obtain the accurate results. Although these 

features are not visible in finite element package, however, the user can define the corresponding 

parameters, which will be further demonstrated in future chapters. 

The higher density of the elements usually enhances the accuracy of the results where they 

converge to a single value; consequently, increases the solving time required by the processor. It 

should be noted that simply increasing the compaction density does not lead to accurate results, 

but the correct modeling considerations and assumptions are required. This point is often 

overlooked by many novice users. 

 

1.2.3. Step 3: Element Characteristics 

In the third step, the characteristics of elements such as material properties, stiffness and damping 

(for dynamic analysis) are needed to be defined. The stiffness of each type elements can be derived 

through constitutive and analytical model of corresponding element which is depend on shape of 

element and degree of freedom for element’s node. Also, the accurate parameters for define the 

material is required which obtaining them may time consuming and require a variety of laboratory 

test. But it should be noted that the validity of the FEM analysis results is directly related to the 

accuracy of material’s parameters. Many special materials (such as special steels, bronze, wood, 

etc.) are not included in predefine library of many finite element packages, and it is required to 

define these material details by the users.  
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1.2.4. Step 4: Assembly of Finite Element Equations 

Once the characteristics of all individual elements are defined in terms of matrix such as stiffness 

matric, mass matrix and damping matric, then the overall characteristic of considered model 

geometry is obtain through assembly of individual characteristic matrix for elements according to 

assigned degree of freedom for nodes of each element. Thereafter, the finite element equations are 

derived for static or dynamic analysis by defining and adding force vector to the assembled 

matrixes.   

 

1.2.5. Step 5: Apply Boundary Condition 

In the further step, the boundary conditions affecting the solution process must be determined. 

These conditions include loading protocol, boundary conditions, initial conditions, interactions, 

constraints and connections. In general, any phenomenon that causes a stimulation is called 

"loading", which can be defined as force (at point, edge, surface or volume), heat flux, electrical 

voltage, and etc. "Boundary condition" is the specific condition in the element which changes 

degrees of freedom in certain parts (or point) of the structure during solution; This means that any 

kind of changes in degrees of freedom (such as displacement, rotation, temperature, mean pressure, 

etc.) are specified in the analysis process, that part is introduced as a boundary condition (whether 

it is within geometric boundaries or not). Introducing more boundary conditions in the considered 

geometry is leading to the easier and faster solving and analysis of considered FEM model. In 

general, in most problems, the boundary conditions are needed to determine and define and some 

problems (such as static problems) cannot be solved without defining the boundary conditions. 

"Basic conditions" are defined at a particular time in a problem. These conditions are generally 

considered at the beginning of the analysis (such as initial velocity and initial temperature).  



27 

 

Moreover, in case of few analysis stages, the conditions at the end of each analysis stage are 

defined as the initial conditions in the next analysis stage.  

The "Interaction" involves conditional interactions between different parts of model geometry. The 

“contact” and “constrains” are the most common interaction between various parts of model. The 

“restrictions” which are define the support condition is considered throughout all analysis steps 

and these boundary conditions are not revoked under any circumstances. The conditional 

interactions are the specific types which occur when the certain conditions met in the model. For 

example, a contact is made when pressure with the value of more than zero occurs between two 

parts. In general, when there are more defined interactions in a FEM model, the solving process 

will be more complicated and time consuming.  

The "connections" is another common type of interaction between different parts of FEM model 

in which the analytical relationship of one node to another node(s) is determined. This relationship 

can be the behavior of a linear or nonlinear spring, spherical joint, hinged joint, spot welding, etc., 

and it can be also used to determine the extent of rupture and the range of changes. 
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Figure 1-2: Mashing of complex solid geometry with consider of interactions and boundary 

conditions 

 

1.2.6. Step 6: Solving the Finite Element Equations 

Once the boundary conditions are defined properly, the type of analysis must be specified include 

of static, dynamic analysis, heat transfer, buckling, natural frequency extraction, etc. The type of 

elements and the materials should be compatible with the type of analysis. Each type of analysis 

lead to its own specific output and results. The specific parameters for analysis are needed to define 

in this step such as considering small or large displacement or the parameters regarding to the 

nonlinear and plasticity analysis.  

Solving of finite element equations which called Finite Element Analysis and conducted after 

completing finite element modeling is lead to determine the nodal displacements resulted of 

applied loads to the considered model under the specified boundary conditions.  

The last step in analysis of finite element models is reviewing the results and obtaining the outputs. 

Variables are extracted in different ways which should be defined during modelling process. Some 

variables are extracted only from nodal results or elements response or both. Furthermore, 

depending on the type of problem, it is necessary to extract some of outputs in the current time 

domain and some through time history results. 

 

1.2.7. Step 7: Additional Calculations 

As mentioned in the previous section, the nodal displacement is the only output from finite element 

analysis. However, many other parameters are required which can be obtained via additional 

calculations. The strain and stress in the elements are the main concern in design of structures 
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which can calculate using nodal displacements. Then it is possible to determine the principal stress 

and strains to evaluate the capacity of considered members to sustain against applied loads. 

The example of implementing various steps of FEM modeling and analysis to simulate an object 

has been showed in Figure 1-3. 

 

 

Figure 1-3: Process of Finite Element Modeling and Analysis 

 

1.3. Summary 

The above demonstrated steps are the main process for finite element modeling and analysis of a 

solid structure. However, great precision and deep consideration are required to define a proper 
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FEM model to obtain the accurate results for complex problems for structures and bridges. The 

examples of following chapters will form cognitive insight for the readers to create accurate FEM 

model for complex structures and reach to realistic results.   
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Chapter 2: Abaqus Scripting for Mesh Convergence 

 

2.1. Introduction 

The basis of solving finite element programs is the discretization of the component and element 

size. However, the main question is to ascertain the numbers needed for these small members to 

have a reliable solution. Although answers are uncertain, the number of choices for element(s) size 

must be determined reasonably. The correct method of establishing mesh convergence requires a 

curve of a critical result parameter (typically some kind of stress) in a specific location, to be 

plotted against some measure of mesh density. At least three convergence runs will be required to 

plot a curve which can then be used to indicate when convergence is achieved or to define the 

optimum convergence constituted by refined mesh. However, if two runs of different mesh density 

give the same result, convergence is already achieved, and no convergence curve is necessary. 

Figure 2-1 shows a typical mesh convergence for displacement variable. 

According to the importance of the object, in this example, mesh convergence will be aided by 

using python scripts. 
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Figure 2-1: Typical mesh convergence  

 

2.2. Problem description 

The problem consists of a simple rectangular beam that is clamped at one end and subjected to 

shear loading at the other end (Figure 2-2). 

The first step is modeling the sample, and then scripts will be created. 

 

 

Figure 2-2: Problem description 

 

2.3. Objectives 

1) To study writing scripts in Abaqus. 

2) To familiarize with Abaqus/PDE. 

3) To investigate mesh independency in Abaqus. 
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2.4. Modeling 

Run Abaqus/CAE from the start menu and then close the Start Session dialog box (Figure 2-3). 

 

 

 

Figure 2-3: Abaqus/CAE 

 

2.4.1. Parts Module 

The first step is to define a rectangular cubic beam. It should be created as a solid extruded.  

Double click on Parts in the Model Tree and open the Create Part dialog box and without changing 

anything, click to Continue to go to the Sketcher (Figure 2-4). 
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Figure 2-4: Create part 

 

Using Create lines: Rectangle tool, draw a rectangle and using the Add Dimension tool to 

determine the dimensions as shown in Figure 2-5. 

 

    

Figure 2-5: Drawing and dimensioning the sketch of the beam 
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Click the middle mouse button twice to exit sketcher and open the Edit Base Extrusion dialog box. 

Consider 50 for the depth and click Ok to apply and close the dialog box (Figure 2-6). 

 

     

Figure 2-6: Extruding the sketch 

 

2.4.1.1. Material Properties 

In the next step, the material data should be defined. In the model, the beam’s material has been 

assumed to be steel in linear elastic. 

Double click on Materials in the Model Tree and select Mechanical → Elasticity → Elastic and 

enter 200e3 for Young’s Modulus and 0.3 for Poisson's Ratio, as shown in Figure 2-7. 
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Figure 2-7: Defining material properties 

 

2.4.1.2. Section Properties 

The beam is assumed homogenous, and the mean material properties are the same in all regions. 

Double click on Sections in the Model Three and select Solid, Homogenous, and click Continue. 

Leave the subsequent dialog box unchanged and click Ok to apply and close the dialog box (Figure 

2-8).  

 

     

Figure 2-8: Defining section 
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2.4.1.3. Section Assignment 

In the next step, the section should be assigned to the beam. 

Double click on Section Assignments underneath of Part-1 in the Model Tree. Then click the beam 

and click the middle mouse button to open the Edit Section Assignment dialog box. Click Ok to 

assign the section to beam and close the dialog box. The beam will be recolored (Figure 2-9).  

 

    

Figure 2-9: Assigning section to the beam 

 

2.4.2. Assembly Module 

At this point, the model should be defined in the computational space defined in the assembly. 

Double click on Instances underneath of Assembly to open the Create Instance dialog box. Click 

Ok to add beam instance in the assembly and close the dialog box (Figure 2-10). 
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Figure 2-10: Defining beam instance in the assembly 

 

2.4.3. Step Module 

In the sample, the static shear load is applied on the beam, while displacements should be 

considered in the analysis. However, there is a nonlinear problem. Nonlinear analysis is presented 

in General analysis in Abaqus 

Double click on Steps in the Model Tree and select Static, General, and click Continue. Toggle on 

Nlgeom (Nonlinear geometry) and leave all other options as defaults and click Ok to apply and 

close the dialog box (Figure 2-11). 
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Figure 2-11: Defining the analysis step 

 

2.4.4. Boundary Conditions (Load Module) 

In the sample, only one boundary condition is considered: One end was clamped. 

Double click on BCs in the Model Tree to open a corresponding dialog box and select 

Symmetry/Antisymmetry/Encastre as the type and click Continue. Then rotate the beam so that 

the end can be selected. Then, click the middle mouse button to open the Edit Boundary Condition 

dialog box. Constraint all DOF by toggling on ENCASTRE and click Ok to apply and close the 

dialog box (Figure 2-12). 
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Figure 2-12: Defining the clamped boundary condition 

 

2.4.5. Load Module 

In the sample, a 100 MPa distributed shear was applied, and its direction is from top to bottom. 

Double click on Loads and select Surface Traction as a load type and click Continue. Then choose 

the free end of the beam and click the middle mouse button to open the Edit Load dialog box. Then 

select edit in the Direction box, and, the box will close. Then choose vertex labeled by 1, then 

vertex labeled by 2 to define shear load direction. The Edit Load dialog box will open again, enter 

100 as the load magnitude and click Ok to close the dialog box (Figure 2-13). 
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Figure 2-13: Defining shear load 

 

2.4.6. Mesh Module 

The most challenging part of this problem is the mesh size. The question presented here is what 

element size is suitable for the problem. The question will be answered with scripting. So, at this 

point, a simple mesh could be defined; it will be changed with just the script running. 

Double click on Mesh(empty) underneath of Part-1 in the Model Tree to enter the Mesh module.  
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To specify the element size, select Seed → Part to open the Global Seeds dialog box. Enter 5 as 

the approximate global size and enter Apply to see the locations of the nodes. Click Ok to close 

the dialog box (Figure 2-14). 
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Figure 2-14: Seeding 

 

Select Mesh → Element Type and choose beam, then click the middle mouse button to open the 

Element Type box. Change Use Default to Enhanced Strain in the Hourglass control formulation. 

This is more suitable for calculating bending due to eliminating twist instabilities caused by one 

integration point. To assign the element type, click Ok, and close the dialog box (Figure 2-15). 
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Figure 2-15: Assigning the element type 
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Select Mesh → Part and click Yes at the bottom of the page to generate the mesh (Figure 2-16). 

 

    

   

Figure 2-16: Generating the mesh 
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2.5. Analysis: Job Module 

In the next step, a job should be defined to solve the problem in the solver. Before that, the 

assembly should be regenerated again. 

Right click on Instances underneath of Assembly and select Regenerate (Figure 2-17). 

 

 

Figure 2-17: Assembly regeneration 

 

Double click on Jobs in the Model Tree and then name the job, click Continue to open the Edit Job 

dialog box. Then click Ok to create the job and close the dialog box (Figure 2-18). 
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Figure 2-18: Creating a job 

 

Finally, save the model as Beam.cae and close Abaqus/CAE. 

Using the Abaqus/CAE user interface to create a geometric model and view results, the commands 

to be executed will be created and stored in the form of code following each operation. These 

commands contain information on how to create a geometric model and change the settings in all 

windows that are used in each module. The GUI or Abaqus interface will create all the commands 

in a language-oriented programming language, called Python. All commands created by the central 

kernel or the Abaqus kernel are translated and based on the settings created. The user is able to 

view the visual representation of the issued command. In fact, Kernel is the mastermind behind 

the Abaqus/CAE and GUI interface between the user and the Kernel. 

The user can modify python codes to define new capabilities and advantages by Abaqus. For 

example, one of these advantages is resolving a problem with varying mesh density to evaluate 
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mesh convergence. This sample shows how to write a script that solves the problem with mesh 

size: 5,4,3,2, and 1 to evaluate mesh convergence. 

From the start menu, open Abaqus/CAE and then open the last model database: Beam.cae. Then 

mesh seeds should be changed to another size, for example, 4, before that Abaqus shows a dialog 

box that asks if you wish to delete the current mesh. By selecting delete mesh, the dialog is closed, 

and a mesh part should be created again containing 117 elements (Figure 2-19). 

 

     

 

Figure 2-19: Remeshing with a new element size 

 

As meshing has changed the assembly, instances should be regenerated by right-clicking on them. 

After that, a Job should be created and submitted (Figure 2-20). 
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Figure 2-20: Submitting the job including the new mesh 

 

After the analysis is completed, close Abaqus/CAE without saving anything.  

Since Abaqus/CAE is starting until it closes, all items are recorded as python scripts by 

Abaqus/PDE and can be edited for another analysis. All changes are stored in the Abaqus.rpy file 

which is normally located in c:/temp directory. 
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Open Abaqus.rpy in the notepad.exe editor, as shown in Figure 2-21. 

 

 

Figure 2-21: Opening *.rpy file contains python scripts 

 

Save the file as mesh.py and close it. The *.py extension is used for python scripts. 

Run Abaqus/CAE and select, File. Abaqus manages and modifies all python commands. The 

recent python file – mesh.py– should be opened in Abaqus/PDE, as shown in Figure 2-22. 

 



51 
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Figure 2-22: Opening the mesh.py file, a script that is included to modify mesh and in submitting 

a job. 

 

Modify the script as described below: 

Remove all commands that started with “#” which mention all analysis details such as time, date, 

and 201 (Figure 2-23). 

 
1 Note that upper and lowercase and spaces are very important in scripting 
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Figure 2-23:Eliminating anything that starts with “#” 

 

Remove all “session.viewports” commands, which mention all orientations of the viewport and 

zoom in/zoom out done by the user which does not affect the script (Figure 2-24). 
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Figure 2-24: Eliminating states that start with “session.viewports” 

 

Remove all commands that contain “driverUtils” and “caeModules” that mention Abaqus/CAE as 

they are not necessary for the script (Figure 2-25). 
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Figure 2-25: Eliminating commands that contain “driverUtils” and “caeModules” 

 

Remove all duplicated statements that start with “p.”, “a.”, “p=” or “a=”as the final script does 

every task just once (Figure 2-26). 
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Figure 2-26: Eliminating duplicate states 

 

Define the new statement as “MeshSizes” after “p=mdb.models…” statement. By doing so, an 

integer can be defined, and the meshing operator in Abaqus/CAE will refer to it in every execution 

[run]. The statement should be written using a unique interface, as shown below and, as illustrated 

in Figure 24. 

“MeshSizes= [5.0, 4.0, 3.0, 2.0, 1.0]” 

“forMeshSizein MeshSizes:”   

Then in the line that defines mesh“p.seedPart”, rewrite “MeshSize” instead of “4.0” these changes 

are shown in Figure 2-27. 
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Figure 2-27: Adding the “Meshsize” statement in the script 

 

Define a new statement as “JobName” before “mdb.Job”. This statement is used for defining job 

names that contain “mesh” adding“str” and “int” operators for extracting a number that refers to 

the mesh size to generate new jobs. All following statements that refer to “Job-1” should be 

changed according to the statement (“JobName”). All changes required for the statement interface 

are shown in Figure 2-28. 
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Figure 2-28: Adding the “JobName” statement 

 

Define the waiting command: This command keeps the analysis running and prevents new analysis 

from starting before the completion of the current one. Its interface has been mentioned below. 

Note that the command should be the last line in Abaqus PDE (Figure 2-29). 

“mdb.jobs[JobName].waitForCompletion()” 

 

 

Figure 2-29:Adding the “waiting” command 

 

Finally, the script should be saved in the mesh.py file. Then, run it using the Play button at the top 

of the Abaqus/PDE (Figure 2-30). When the script is running, there are activities in Abaqus/CAE, 
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including defining models with different mesh size and solving the problem according to the size. 

After finishing the analysis, a new mesh density will be generated and analyzed. 

 

 

Figure 2-30: Play script 

 

After all jobs have been completed, the result is displayed. For example, a comparison of maximum 

displacement in 5 models, as shown in Figure 2-31. 
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Figure 2-31: Result for different mesh sizes 

 

The results summary and mesh evaluation are shown in Table 2-1. The values show the refining 

mesh size, where the difference between the results is less. It also shows the likely the minimum 

mesh size that is qualified for mesh independency. 

 

Table 2-1 Maximum displacement for each mesh size 

Mesh size Maximum displacement (mm) 

5 2.532 

4 2.542 

3 2.550 

2 2.559 

1 2.567 
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Chapter 3: Analysis of Steel Rectangular Plate with Circular Hole 

 

3.1. Introduction 

In this example, a rectangular plate with a circular hole is subjected to horizontal force, the effect 

of stretching of a rectangular plate with a circular hole on the stress and distributions around the 

hole caused by the loadings, is analyzed using the finite element method (FEM). A solid undergoes 

stress expansion due to the application of two equal loads along with principal X direction. This 

geometry of the plate can be considered to have geometrical irregularities that could result in non-

uniform stress distribution. Therefore, the FEM called Abaqus/Standard, version 6.9 is utilized 

given the software is capable of investigating the stresses and deformations in structures of any 

given geometry.  

Researcher: Ramin Vaghei 

 

3.2. Problem Description 

A rectangular plate with a circular hole at its center is subjected to uniform horizontal stress of 10 

kN/m2 along both sides. You should notice that the plate has no boundary condition, and it is a 

free moving body as it is not fixed in position. However, in finite element analysis, it should have 

introduced at least one boundary condition, or else it will hinder the analysis. When it is possible 

to create the symmetry condition in the model, it should be considered in the model to reduce the 

computational time in the analysis. Therefore, the plate is modeled as a quarter model where its 

symmetry condition will play the role of boundary conditions in this example. The cut edge will 

be designed fully constrained, and having a uniform distributed load on the other end, as shown in 

Figure 3-1. In this case, due to the symmetric in geometry concerning the equal applied loads, a 

quarter of the model can be modeled. The analysis is performed on a simply supported beam with 
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end moments. The beam is modeled using shell elements. Therefore, analysis of plate in a state of 

plane stress has been carried out, and the stress distribution and deformation of a plate are 

investigated. 

 

Modulus of elasticity = 20,000 kN/cm2 

Poisson's ratio = 0.3 

 

 

Figure 3-1: Plate with Hole 

 

3.3. Objectives 

1) To determine the effect of load applied to the plate on the deformation behaviour of the hole. 

2) To investigate the stress distribution of a rectangular plate with a circular hole. 

 

3.4. Modeling 
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3.4.1.1. Part Module 

This module allows for creating the geometry required for the problem. To create a 3-D geometry, 

a 2-D profile should be created first and then manipulating it to obtain the solid geometry. 

  

3.4.1.2.  Create a new model database 

Start Abaqus/CAE from programs in the Start menu.  

Select Create Model Database from the Start Session dialog box that appears. (see Figure 3-2) 

When the Part module has finished loading, it displays the Part module toolbox in the left side of 

the Abaqus/CAE main window. Each module displays its own set of tools in the module toolbox 

(Figure 3-2). 
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Figure 3-2: Getting Started 

 

3.4.1.3. Create a new model database and a new part 

From the main menu bar, select Part→Create to create a new part.  

The Create Part dialog box appears. Use the Create Part dialog box to name the part and to select 

its modeling space, type, and base feature and to set the approximate size. The name of the part 

may be edited once it has been created, but the modeling space, type, or base feature cannot be 

changed. 

Name the part “plateWithHole”. Choose a two-dimensional planar, deformable body type, and 

Shell as the base feature. (see Figure 3-3) 

Enter an approximate size of 50. The value entered in the approximate size text field at the bottom 

of the dialog box sets the approximate size of the new part. 

Click [Continue] to exit the Create Part dialog box.  
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Figure 3-3: Create a new model database and create a new part 

 

3.4.1.4. Define rectangle with dimensions 

Use the Create Lines: The rectangular tool located in the upper left corner of the Sketcher toolbox 

to begin drawing the geometry of the plate. The user can select a starting corner for the rectangle 

at the viewport or enter the X and Y coordinates. Create a line with the following coordinates: (0.0, 

0.0), and (10.0, 5.0) as shown in Figure 3-4. Alternatively, the user can define the dimension of 

the geometry by clicking on the add dimension tool. Once finished sketching the section for the 

dimension, click on Done at the prompt area to exit the sketcher, turning and it will turn out as 

shown in Figure 3-4.  
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Figure 3-4: Define the rectangle and dimensions 
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3.4.1.5. Draw circle to define cut and dimension radius 

Finally, use the Create Circle: Center and Perimeter tool. Selecta center point for the circle or enter 

the X and Y coordinates with a center at (0.0, 0.0) and one point at (2.5, 0.0). The following 

geometry should be drawn, as shown in Figure 3-5. 

 

 

Figure 3-5: Extrude cut to create a hole 

 

3.4.1.6. Quarter plate with a hole 

Click Done at the prompt area to exit the Sketcher (see Figure 3-6) 
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Figure 3-6: Draw circle to define cut and dimension radius 

 

Save the model in a model database file: From the main menu bar, select File→Save. The Save 

Model Database as a dialog box appears.  

Type a name for the new model database in the File Name field and click OK. 

 

3.4.2. Property Module 

In this module, the material properties for the analysis should be defined by assigning those 

properties to the available parts. 

Note: If the Done button in the prompt area does not appear, right click on the viewport until it 

appears.  

 

3.4.2.1. Material Properties 

The Property module is used to create a material and to define its properties. In this problem, all 

the members of the frame are made of steel and are assumed to be linear elastic with Young's 
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modulus of 20,000 kN/cm2and Poisson's ratio of 0.3. Thus, a single linear elastic material is created 

with these properties. To define a material: 

Under the model tree, select Property, to enter the Property module. The cursor changes to an 

hourglass while the Property module loads.  

The Edit Material dialog box appears.  

Name the material “Steel”.  

From the material editor's menu bar, click Mechanical→Elasticity→Elastic. Abaqus/CAE displays 

the Elastic data form (see Figure 3-7). 

Enter the value of 20,000for Young's modulus and 0.3 for Poisson's ratio in the respective cells 

(see Figure 3-8). 

Click OK to exit the material editor.  

Keep the changes by clicking on the Save button. 
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Figure 3-7: Material Definition 

 

 

Figure 3-8: Material properties 

 

3.4.2.2. Section Properties 

The section properties of a model are defined by creating sections in the Property module. Once 

the section has been created, use one of the following two methods to assign the section to the part 

to be used: 

Select the region from the part and assign the section to the selected region, or use the Set toolset 

to create a homogeneous set containing the region and assign the section to the set.  

To define a plate section as shown in Figure 3-9 the following process should be fulfilled. 

From the main menu bar, select Section→Create and the Create Section dialog box appears.  

In the Create Section dialog box:  

Name the section “plateSection”. 

In the Category list, select Solid.  

In the Type list, select Homogeneous.  
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Click Continue. The Edit Section dialog box appears.  

In the Edit Section dialog box:  

Accept the default selection of Steel for the Material associated with the section. If other materials 

have previously been defined, click the arrow next to the Material text box and scroll through the 

Material to view a list of available materials and assign it to the section.  

In the Plane stress/strain thickness field, enter a value of 0.5.  

Click OK. 

 

 

Figure 3-9: Section Properties 

 

3.4.2.3. Assign "plate Section" to the Part 

Next, assign the defined section to the corresponding part. The Assign menu is used in the Property 

module to assign the section “plateSection” to the plate. To assign the section to the plate, as shown 

in Figure 3-10  
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From the main menu bar, select Assign→Section. Abaqus/CAE displays prompts in the prompt 

area to guide the user through the procedure.  

Alternatively, expand the menu under the “plateWithHole” and double click on the Section 

Assignments. 

 

 

Figure 3-10: Plate Section 

 

Select the entire part as the region to which the section will be applied.  

Click and hold the left button of the mouse at the upper left corner of the viewport.  

Drag the mouse to create a box around the plate.  

Release the left mouse button. Abaqus/CAE highlights the entire plate.  

Right Click on the viewport or click Done in the prompt area to accept the selected geometry. The 

Assign Section dialog box appears. 

In Section, scroll to the plate section and click OK. The part changes color to green once the section 

is assigned, as shown in Figure 3-11 
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Figure 3-11: plate Section assignment 

 

3.4.3. Mesh Module 

The finite element mesh is generated in this module. Abaqus/CAE uses a number of different 

meshing techniques. The default meshing technique assigned to the model is indicated by the color 

of the model which is displayed when the Mesh module is entered. If Abaqus/CAE displays the 

model in orange, it cannot be meshed without the assistance of the user. This command is used to 

mesh the whole structure to small and equal parts and elements. 

 

3.4.3.1. Mesh: Seed the part (1cm elements) 

The mesh module is used to generate the finite element mesh. The meshing technique used to 

create the mesh, the element shape, and the element type, should be chosen. In this section, a 

particular Abaqus element type is assigned to the model. The element type assignment can also be 

postponed until the mesh is created. The Plane stress elements will be used to model the plate. To 

assign an Abaqus element type:  
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In the Part Module list, expand the menu under the “plateWithHole” and double click on the Mesh 

to enter the Mesh module.  

At the context bar, click Part, to unclick the assembly. 

From the main menu bar, select Mesh→Element Type.  

In the viewport, select the entire frame as the region to be assigned with an element type. In the 

prompt area, click Done. The Element Type dialog box appears, as shown in Figure 3-12. 

In the dialog box, select the following:  

- Standard as the Element Library selection (the default).  

- Linear as the Geometric Order (the default).  

- Plane stress as the Family of elements.  

- Unclick the reduced integration box (NEVER use “reduced integration”).  

In the lower portion of the dialog box, examine the element shape options. A brief description of 

the default element selection is available at the bottom of each tabbed page.  

Click OK to assign the element type and to close the dialog box (see Figure 3-12). 
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Figure 3-12: Selecting the Element Type 

 

Then the mesh can be created. Meshing is basically a two-stage operation by first seeding the edges 

of the part instance, followed by mesh in the part instance. Select the number of seeds based on 

the desired element size or on the number of elements that are required along an edge, and 

Abaqus/CAE places the nodes of the mesh at the seeds whenever possible. For manual meshing, 

click on Seed Edges. Then, select the edges that the user wants to mesh. Next, click Mesh Part 

Instance. 

 

3.4.3.2. Seed and mesh the model 

From the main menu bar, select Seed→Part to seed the part instance.  

Alternatively, select the Seed Part on the upper left corner of the meshing toolbox. The Global 

Seeds dialog box will appear. 
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Type the appropriate value for the approximate global size of the mesh elements. Specify an 

element size of 1.0 for this example. 

Click OK to accept the seeding. (see Figure 3-13) 

Note: more control of the resulting mesh can be gained by seeding each edge of the part instance 

individually. However, it is not necessary for this example. The prompt area displays the default 

element size that Abaqus/CAE will use to seed the part instance. This default element size is based 

on the size of the part instance. A relatively large seed value will be used so that only one element 

will be created per region.  

 

  

Figure 3-13: Assign the approximate global size for the mesh elements 

 

Abaqus/CAE offers a variety of meshing techniques to mesh models with different topologies. 

Various meshing techniques provide different levels of automation and user control. There are 

three (3) types of mesh generation techniques available in Abaqus/CAE as follows: 

Structured meshing applies pre-established mesh patterns to particular model topologies. Complex 

models, however, must generally be partitioned into simpler regions in order to use this technique.  
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Swept meshing extrudes an internally generated mesh along a sweep path or revolves it around an 

axis of revolution. Like structured meshing, swept meshing is limited to models with specific 

topologies and geometries.  

Free meshing is the most flexible meshing technique as it uses no pre-established mesh patterns 

and can be applied to almost all model shapes. 

Select the Assign Mesh Controls tool at the meshing toolbox, and the Mesh Controls dialog box 

appears. 

Choose Quad as the element shape. 

Choose Structured meshing technique, as shown in Figure 3-14. 

 

    

Figure 3-14: Choose element shape and the meshing technique option 

 

From the main menu bar, select Mesh→Instance to mesh the part instance or select the Mesh Part 

Instance at the upper left corner of the meshing toolbox. 

Select the part instances to be meshed. Once finished selecting, click Yes in the prompt area to 

confirm the mesh of the part instance. Once meshed, the plate changes color to blue, and the 

meshed geometry is shown in Figure 3-15. 



82 

 

 

Figure 3-15: Choose mesh algorithm options 

 

3.4.4. Assembly Module 

Each part is oriented in its own coordinate system and is independent of the other parts in the 

model. Although a model may contain many parts, it contains only one assembly. Define the 

geometry of the assembly by creating instances of a part and then positioning the instances relative 

to each other in a global coordinate system. An instance may be independent or dependent. 

Independent part instances are meshed individually, while the mesh of a dependent part instance 

is associated with the mesh of the original part. 

 

3.4.4.1. Assemble part instances into the model 

In the Module list located under the toolbar, click Assembly to enter the Assembly module.  

From the main menu bar, select Instance→Create or select the Create Instance at the upper left of 

the assembling toolbox. The Create Instance dialog box appears, as shown in Figure 3-16.  
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Note: In Abaqus, the user can create many parts and assemble them to form a model. The user can 

also create many instances from one part. For example, in a composite structure, the user does not 

need to draw all the bolted shear connectors. If they are similar, drawing one is sufficient. The 

others can be created using the linear pattern from the first one by defining the number of instances 

and the offset from one to another. 

In the dialog box, choose Dependent (mesh on the part) as the instance type. 

In our case, we only have one part: “plateWithHole”, select it, and click OK.  

 

 

Figure 3-16: Assemble part instances into a model 

 

3.4.5. Step Module 

After the assembly is completed, then the configuration of the analysis should be defined. In this 

simulation analysis, we are interested in identifying the static response of the plate to a 10 kN/m2 

load applied at the adjacent sides. 
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Abaqus/CAE generates the initial step automatically. However, the rest of the analysis step should 

be defined by the user as well as the requested output for any steps in the analysis. There are two 

kinds of analysis steps in Abaqus: general analysis steps, which can be used to analyze the linear 

or nonlinear response, and linear perturbation steps, which can be used only to analyze linear 

problems. However, only general analysis steps are available in Abaqus/Explicit. Next, create a 

static, linear, perturbation step that follows the initial step of the analysis. 

 

3.4.5.1. Create an analysis step: "apply load" 

In the next step, that the assembly of the model has been created move to the Step module to 

configure the required analysis. In this simulation analysis, the aim is to evaluate the static response 

of the plate to a 10 kN/m2 pressure applied at the end of the plate, with the left end fully 

constrained. This is a single event, so only a single analysis step is needed for the simulation. Thus, 

the analysis will consist of two steps:  

- The initial step in which boundary conditions that constrain the end of the plate are applied. 

- Analysis step, in which a distributed load at the other end of the plate is applied. 

Abaqus/CAE generates the initial step automatically, but the Step module needs to be operated by 

the user to create the analysis step. The Step module also allows the user to request output (field 

output & history output) for each step in the analysis.  

In the Module list located under the toolbar, click Step to enter the Step module. 

From the main menu bar, select Step→Create to create a step. The Create Step dialog box appears 

with a list of all general procedures and a default step namedStep-1 (see Figure 3-17).  
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Change the step name to “applyLoad”. 

Select general as the Procedure type.  

Scroll through the available list, select Static,General, and click on Continue.  

 

 

Figure 3-17: Analysis step 

 

Next, the Edit Step dialog box appears.  

The Basic tab is selected by default. In the Description field, type “This is a load step where we 

apply the 10kN force at the end” (see Figure 3-18). 

Click the Incrementation tab and the Other tab to see its contents and accept the default values 

provided for the step.  

Click OK to create the step and to exit the Edit Step dialog box. 
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Figure 3-18. Time options, Nlgeom, and Incrementation 

 

3.4.6. Load/Boundary Condition Module 

The prescribed conditions, such as loads and boundary conditions, are step dependent, which 

means that the user needs to specify the steps in which they become active. As the steps in the 

analysis have been defined, the Load module can be used to define the prescribed conditions. In 

this model, the left edge of the plate is fully constrained and cannot move in any direction. 

However, due to the symmetry about the x and y axis’s, one-fourth of the plate is modeled, with 

the boundary conditions shown in Figure 3-19.  
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To apply boundary conditions to the plate, follow the steps as shown below: 

In the Module list located under the toolbar, click Load to enter the Load module.  

From the main menu bar, select BC→Create. The Create Boundary Condition dialog box appears.  

In the Create Boundary Condition dialog box:  

Name the boundary condition “leftBC”. 

From the list of steps, select Initial as the step in which the boundary condition will be activated. 

All the mechanical boundary conditions specified in the Initial step must have zero magnitude. 

This condition is enforced automatically by Abaqus/CAE.  

In the Category list, accept Mechanical as the default category selection.  

In the Types for the Selected Step list, select Symmetry/Antisymmetry/Encastre, and then click 

Continue. Abaqus/CAE displays prompts in the prompt area to guide the user through the 

procedure. For example, select the region to which the boundary condition will be applied as 

illustrated in Figure 3-19 

To apply a prescribed condition to a region, the user can either select the region directly in the 

viewport or apply the condition to an existing set (a set is a named region of a model). Sets are a 

convenient tool that can be used to manage large and complicated models. It is unnecessary to 

have more sets in this simple model. 

In the viewport, select the edge at the bottom of the plate. This is the region to which the boundary 

condition will be applied, as shown in Figure 3-20  
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Right-click on the viewport or click Done in the prompt area to indicate the end of selecting the 

regions. The Edit Boundary Condition dialog box then appears. When the boundary condition is 

being defined in the initial step, all available degrees of freedom are unconstrained by default.  

 In the dialog box:  

Select XSYMM (U1=UR2=UR3=0) since all translational degrees of freedom need to be 

constrained.  

Click on OK to create the boundary condition and to close the dialog box.  

Abaqus/CAE displays arrowheads at the vertex to indicate the constrained degrees of freedom (see 

Figure 3-21). 

 

 

Figure 3-19: Left symmetric Boundary condition 



89 

 

 

Figure 3-20: Edit the Boundary condition dialog box for fixed support. 

 

 

Figure 3-21: Select edge and BC options 

 

Repeat the steps for the lower edge of the plate with the name “lowerBC,” as shown in Figure 

3-22. 

In the Edit Boundary Condition dialog box, select YSYMM (U2=UR1=UR3=0) and click on OK 

to close the dialog box. (see Figure 3-23) 

The boundary conditions applied all appear, as shown in Figure 3-24 
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Figure 3-22: Lower symmetric BC 

 

 

Figure 3-23: Select edge and BC options 

 

Figure 3-24: All boundary conditions shown (applied in "Initial" step) 
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In the next step, that the plate is constrained, the load can be applied to the other end of the plate. 

In this simulation analysis, a distributed force of 10 kN/m2 is applied in the negative direction of 

the axis. 

To apply the distributed force to the plate, as shown in Figure 3-25 perform the following steps:  

From the main menu bar, select Load→Manager. 

At the bottom of the Load Manager, click Create. The Create Load dialog box appears.  

In the Create Load dialog box: 

Name the load as “axialTension”.  

From the list of steps, select applyLoad as the step in which the load will be exerted.  

In the Category list, select Mechanical as the default category selection.  

In the Types for the Selected Step list, select Pressure.  

Then, click on Continue.  
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Figure 3-25: Create a load in the "apply load" step 

 

Abaqus/CAE displays prompts in the prompt area to guide the user through the procedure. The 

user is asked to select a region or point to which the load will be applied. As with the boundary 

conditions, the region to which the load will be applied can be selected either directly in the 

viewport or from a list of existing sets. Select the region directly in the viewport.  

In the viewport, select the right edge of the plate as the region where the load will be applied.  

Click on the viewport or click Done in the prompt area to finish selecting the regions. The Edit 

Load dialog box appears.  

In the dialog box (see Figure 3-26):  

Enter a magnitude of -2. P = 5kN/(5cmx0.5cm) = 2 kN/cm2 

Click on OK to create the load and to close the dialog box.  
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Figure 3-26:Create load in the "apply load" step 

 

3.5. Analysis: Job Module 

In the Module list located under the toolbar, click Job to enter the Job module.  

 

3.5.1. Create an analysis job:"Job-1" 

From the main menu bar, select Job→Manager and the Job Manager window appears.  

In the Job Manager, click Create. The Create Job dialog box appears with a list of models in the 

model database.  

Name the job and click Continue. The Edit Job dialog box then appears.  
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Enter a description for the job, type “two-dimensional plane stress problem”. 

Check Full analysis and choose to run the job in the background and check to start it immediately, 

as shown in Figure 3-27. (Note: Job Type is set to Full analysis to combine the data check and 

analysis phases of the simulation). 

Click OK to accept all other default job settings in the job editor and to close the dialog box.  

Expand the tree under Jobs, right click on Job-1. Then, click on Submit. (see Figure 3-28) 

 

 

Figure 3-27: Create a job for analysis 
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Figure 3-28: Submit Job-1 for analysis 

 

When the model simulation is completed, the analysis can then be executed. Since errors in the 

model originating from incorrect or missing data cannot be identified initially, therefore, the user 

should perform a data check analysis before running the analysis. To run a data check analysis:  

First, make sure that the Job Type is set to Data check. From the buttons on the right edge of the 

Job Manager, click Submit to submit the job for analysis or the user can click on the Data Check 

at the right edge of the job manager for checking purposes. The model will then be on Check 

Running status.  

Once the Abaqus/CAE has updated that the model is in Check Completed status, the user can click 

on Continue having completed the analysis. The user can also indicate the job's status after job 

submission. The Status column for the overhead hoist problem shows one of the following: 

None while the analysis input file is being generated.  

- Submitted while the job is being submitted for analysis. 

- Running while Abaqus/CAE is analysing the model. 
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- Completed when the analysis is completed, and the output has been written to the output 

database, and the user can click on Results to proceed to the visualization module. Aborted 

if Abaqus/CAE detects a problem with the input file or the analysis, and consequently, the 

analysis is aborted. In addition, Abaqus/CAE reports the problem in the message area. 

 

3.5.2. Monitor solution in progress 

From the buttons shown on the right edge of the Job Manager, click on Monitor to open the job 

monitor dialog box once the job is submitted.  

The top half of the dialog box displays the information available in the status (*.sta) file that 

Abaqus creates for the analysis.  

If the status on top of the Job Monitor window is shown as Completed, then this job is free of 

errors and was executed properly. Then the analysis results can be checked. 

3.6. Visualization Module 

Graphical post-processing is important given the vast volume of data created during a simulation. 

For any realistic model, it is impractical to interpret the results in the tabular form of the data file. 

Abaqus/Viewer allows the user to view the results graphically using a variety of methods, 

including deformed shape plots, contour plots, vector plots, animations, and X–Y plots. 

 

3.6.1. View the results of the analysis 

Once the job is completed, the user can then view the results of the analysis at the Visualization 

module. From the buttons shown on the right edge of the Job Manager, click Results. Abaqus/CAE 

loads the Visualization module, opens the output database created by the job, and displays a fast 
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plot of the model, as shown in Figure 3-29. A fast plot is a basic representation of the undeformed 

shape of the model. Alternatively, the visualization option can be clicked in the Module list located 

under the toolbar; select File→Open and select Plate.odb from the list of available output database 

files, and then click on OK.  

 

 

Figure 3-29: View results of the analysis 

3.6.2. Visualization/Results Module 

Abaqus/CAE allows the user to write data to a text file (*.rpt) in a tabular format. This feature is 

very convenient in writing tabular output to the data (*.dat) file. It is also very useful, especially 

in writing a report. In this problem, the user will generate a report containing the element stress 

S11 and the element strain energies. To generate field data reports:  

From the main menu bar, select Report→Field Output. 

To create a text file containing the values of S11, click on Report in the main menu bar and then 

click on Field output. In the Report Field Output dialog box, for Position, select Unique nodal, and 

then check S11 under the expanded list of S: Stress components. (see Figure 3-30)  
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In the Setup tabbed page, name the report as “Plate.rpt”. This file can also be saved in the user’s 

working directory by clicking on the Select button. In the Data region at the bottom of the page, 

toggle off the Column totals (the column total is useful when the user wants to compute, for 

example, the total strain energy of the entire model). 

Click Apply. (see Figure 3-31) 

The stress values S11 are appended to the report file. (see Figure 3-32) 

 

Figure 3-30: Select the desired results to print to a report 
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Figure 3-31: Choosing a directory and the file name to which to write the report 
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Figure 3-32: Field Output Report for S11 

 

Abaqus/CAE allows the user to plot the graph of each output. 

Select the Create XY Data tool in the visualization toolbox to plot the S11 graph. The Create XY 

Data dialog box appears. (see Figure 3-33) 

Check the ODB field output in the list of sources. 

Then click on Continue. 

XY Data from the ODB Field Output dialog box appears. 

In the Variables tabbed page, scroll through the list of positions and select the Unique Nodal. 
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Expand the S: Stress Components and check S11. (see Figure 3-34) 

In the Elements/Nodes tabbed page, click Pick from the viewport and then click Edit Selection. 

(see Figure 3-35) 

In the next step, the user is allowed to pick any element available in the viewport. Once the element 

is selected, click on Done and it shows that one element is selected. 

Click on Plot. The graph of Stress vs. Time at that selected element is plotted in the viewport. (see 

Figure 3-36) 

 

 

Figure 3-33: Create/operate on XYdata 
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Figure 3-34: Select the desired results for graph plotting 

 

 

Figure 3-35: Selecting the element from the viewport 
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Figure 3-36: Stress vs. Time plot 

 

The S11 stress contour can be observed by clicking on the icon Plot Contours, on the Deformed 

Shape. (see Error! Reference source not found.) 

Perform the same procedure for deformation, as seen in Figure 3-37. 

Note: If the user cannot read the S11 values in the legend block on the main menu, click on 

Viewport Annotation Options. Under Legend, click on Set font and enter a larger font. (see Figure 

3-38) 

The red shaded contour appears on the plate, indicating that it has experienced the highest stress 

when the load is applied. The stress is in a positive value if the region experiences tension. On the 

other hand, when the region experiences compression, it shows a negative value of stress.  

The stress increases as it comes nearer and nearer to the predefined constraint. 
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Figure 3-37: View the deformed shape of the plate 

 

 

Figure 3-38: Viewport annotations options 
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Chapter 4: Evaluate the Capacity of the Steel Beam-Column Connection through Pushover 

Analysis 

 

4.1. Introduction 

This document contains an example for performing a nonlinear static pushover analysis using the 

finite element program called Abaqus/Standard. The analysis is performed on the three-

dimensional model to study the efficiency of the configuration used in conventional steel beam-

column connections. In this example, the beam was subjected to two different applied loads, which 

are the concentrated load and the uniform distributed load. Two case scenarios have also been used 

in studying and checking the stability of the connections while the distributed load increased by a 

factor of 2. The beam is connected to the column by a full penetration weld. 

Numerous correlations have also been investigated, such as base shear vs. displacement, 

displacement vs. time, and base shear vs. time. The numerical result indicated that joint capacity 

for both cases showed the same behavior in the elastic range, whereas, its behavior changed in the 

plastic range. Although, the results showed that with increasing (doubled) applied load on the 

beam-column connection, the base shear and peak displacement do not change.  

 

4.2. Problem Description 

The model consists of a beam and a column which is connected by full penetration weld connection 

as illustrated in Figure 4-1. 
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Figure 4-1: 3D Model 

 

4.2.1. Geometric Properties 

The beam and the column are universal British section. The beam and the column section are UB 

254x102x25 and UB 356x127x33, respectively. Table 4-1 shows the section properties of the beam 

and column. The joint has been strengthened by a plate of 3mm thickness, which is used in two 

positions, as illustrated in Figure 4-2. 

 

Table 4-126 Geometric properties 
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Side view 

 

Top View 

Figure 4-2: Cross Section of the beam-column connection 

 

4.2.2. Material Properties 

Table 4-2 shows the material properties of the steel section for both the beam and column. 

Table 4-2 Material Properties 

Properties Quantity 

Density 7.85 E9 kg/m3 

Young Modulus 210,000 MPa 

Poisson ratio 0.3  

Yield Stress 370 MPa 

Failure Stress 460 MPa 

Plastic strain at yield 0 

Plastic strain at Failure 0.25 

 

4.3. Objectives 

1) To investigate the efficiency of the configuration used in conventional steel beam-column 

connections. 
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2) To investigate the joint capacity of the column-beam connections, which are linked together 

by weld connections. 

3) To study the stability of steel beam-column connections under two types of loadings applied. 

 

4.4. Modeling 

4.4.1. Part Module 

The part module is used to create various parts of the model. In this case, the model is divided into 

six parts: Column, Beam, Segment left-top, Segment right-top, segment left-middle, and segment 

right-middle. To create a 3-D geometry, first, a 2-D profile should be created and then 

manipulating it to obtain the solid geometry. The following subsections show a step-by-step 

procedure on creating each of these parts. 

 

4.4.1.1. Create a new model database 

Start Abaqus/CAE from programs in the Start menu. 

Select Create Model Database from the Start Session dialog box that appears.  

Click on With Standard/Explicit Model. This step allows the user to start modeling whereby the 

user can create a new file and save it under any name in a new folder. 

When the Part module has finished loading, it displays the Part module toolbox in the left side of 

the Abaqus/CAE main window. Each module displays its own set of tools in the module toolbox. 

 

Column 
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Figure 4-3 shows the dimension of the column in Abaqus. 

 

Figure 4-3: Column Cross-section 

 

4.4.1.2. Create a new model database and a new part 

From the menu bar, select Part→Create in order to create a new part. 

The Create Part dialog box appears. Use the Create Part dialog box to name the part and to choose 

its modeling space, type, and base feature and to set the approximate size. The name of the part 

may be edited once it has been created, but the modeling space, type, or base feature cannot be 

changed. 

Name the part “Column”. Next, choose three-dimensional, deformable body type and Solid and 

Extrusion as the base feature. (see Figure 4-4) 

Enter an approximate size of 2000. The value entered in the approximate size text field at the 

bottom of the dialog box sets the approximate size of the new part. 
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Click Continue to exit the Create Part dialog box.  

 

 

Figure 4-4: Create Column 

 

4.4.1.3. Section of the column with dimension 

Use the Create Lines: connected tool located in the upper right corner of the Sketcher toolbox to 

begin drawing the geometry of the column. The user can choose a starting corner for the column 

at the viewport or enter the X and Y coordinates. Next, create a line with known coordinates, or 

alternatively, the user can define the dimension of the geometry by clicking on the add dimension 
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tool. Once finished sketching the section for the dimension, right click and click on Cancel 

Procedure to exit the sketcher as shown in Figure 4-5.  

Click on Done at the prompt area once finished, and it will be displayed, as shown in Figure 4-6. 

The user needs to define the depth for the extrusion of the column. Once the depth of the column 

has been defined, it will be displayed, as shown in Figure 4-7. 

 

 

Figure 4-5: Draw column section 
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Figure 4-6: Edit Base Extrusion 

 

 

Figure 4-7: Column 

 



113 

 

4.4.1.4. Create a chamber 

Create a chamber by selecting the Create Round or Fillet from the Sketcher toolbox. The user 

needs to select the edges to round/fillet, as shown in Figure 8 and to then define the chamber radius, 

as shown in Figure 4-8 and Figure 4-9. 

 

 

Figure 4-8: Chamfer Creation 
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Figure 4-9: Chamfer Done 

 

4.4.1.5. Beam 

The steps for the beam formation are similar to that for the column, but it should be drawn with 

different dimensions, as shown in Figure 4-10. 
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Figure 4-10: Beam Section Details 

 

4.4.1.6. Segments 

The segments are used for covering the top of the column on both sides. The steps for creating the 

segments are the same as for the previous part instances. Figure 4-11 shows the dimension of the 

segments. The plate should be fit inside the column, as shown in Figure 4-12. 
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Figure 4-11: Segments Dimensions 

 

Figure 4-12: 3D view of Segments 

 

4.4.2. Property Module 

In this module, the material properties for the analysis should be defined by assigning those 

properties to the available parts. 

 

4.4.2.1. Material Properties 

The Property module is used to define the properties of various materials used in the model. 

Sections are then created, and materials assigned to each section. The property of this model is 

made of steel as discussed earlier and assumed to be linear elastic with Young's modulus of 

210,000 N/mm2 and Poisson's ratio of 0.3. Thus, a single linear elastic material is created with 

these properties. To define a material, follow the steps below: 
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In the Module list located under the toolbar, select Property to enter the Property module. The 

cursor changes to an hourglass while the Property module loads.  

From the menu bar, select Material→Create, to create a new material. 

The Edit Material dialog box appears.  

Name the material “Steel”.  

From the material editor's menu bar, click on Mechanical→Elasticity→Elastic. Abaqus/CAE 

displays the Elastic data form. 

Enter the value of 210,000 MPa for Young's Modulus and 0.3 for Poisson's Ratio in the respective 

cells. Use the [Tab] button or move the cursor to a new cell and click to move between cells. 

Next, click on Mechanical → Plasticity → Plastic. 

Enter the values for yield stress and plastic strain, as shown in Figure 4-13. 

Click General → Density. Next, enter the value 7.85E-009. 

Click OK to exit the material editor.  
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Figure 4-13: Elasticity properties for steel 

 

4.4.2.2. Section properties 

The section properties of a model are defined by creating sections in the Property module. After 

the section is created, one of the following two methods to assign the section to the part can be 

used. 
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Select the region from the part and assign the section to the selected region, or use the Set toolset 

to create a homogeneous set containing the region and assign the section to the set.  

To define a beam section: 

From the main menu bar, select Section→Create. The Create Section dialog box appears.  

In the Create Section dialog box:  

Name the section “Beam”. 

In the Category list, select Solid.  

In the Type list, select Homogeneous. (see Figure 4-14) 

Click Continue. The Edit Section dialog box appears.  

In the Edit Section dialog box:  

Click the arrow next to the Material text box and scroll through the Materials to see a list of 

available materials and to select the required material. To define each material, it is necessary to 

do the same process of “Create Section” and then to determine the material by clicking on the 

“Continue” button. 

In the Plane stress/strain thickness field, accept default.  

Then, Click OK. 
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4.4.2.3. Section Assignment 

Next, assign the defined section to the corresponding part. The Assign menu is used in the Property 

module to assign the section “Beam” to the beam. To assign the section to the beam: 

From the main menu bar, select Assign→Section. Abaqus/CAE displays prompts in the prompt 

area to guide the user through the procedure.  

Alternatively, expand the menu under the Beam and double click on the Section Assignments. 

Select the entire part as the region to which the section will be applied.  

Click and hold down the left mouse button and at the upper left corner of the viewport: 

Drag the mouse pointer to create a box around the beam. 

Release the left mouse button. Abaqus/CAE highlights the entire beam. 

Right-Click on the viewport or click Done in the prompt area to accept the selected geometry. The 

Assign Section dialog box appears. 

In Section, scroll to Beam and click OK as shown in Figure 15. The Part changes color to green 

once the section is assigned, as shown in Figure 4-15 and Figure 4-16. 
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Figure 4-14: Create section property 

 

 

Figure 4-15: Select property 
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Figure 4-16: Assigned section 

 

Different Assigned color 

While the section has a different color, it means that different cases exist to identify the status of 

the section. When the section is red in color, it means that the section was deleted or has no 

properties, as shown in Figure 4-17. In other words, the green color represents the assigned section, 

as shown in Figure 4-18, and the yellow color shows that the section has been assigned two times, 

as shown in Figure 4-19. 

 

 

Figure 4-17: No assigned section 
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Figure 4-18: Assigned Section 

 

 

Figure 4-19: Duplicated assigned section 

 

4.4.3. Assembly Module 

In this module, all the parts created earlier can be put together (assembly) to achieve the required 

model. The constraints and loads can be applied to the model once all the individual part instances 

are assembled. 

 

4.4.3.1. Assemble part instances into the model 

In the Module list located under the toolbar, click Assembly to enter the Assembly module. The 

cursor changes to an hourglass while the Assembly module loads. From the main menu bar, select 

Instance→Create. The Create Instance dialog box appears. 
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In the opened window under the Instance Type box, choose Dependent (mesh on the part).  

The first step, the instance part, is to bring all parts together which have been previously created. 

In the dialog box, select Beam and click OK. 

In the dialog box, select Column and click OK. 

Click on Translate Instance to move the elements to the required position. 

Select one node from the top node of the column. 

Select the center of the top flange of the beam, so that they fit together, as shown in Figure 4-20. 

Sometimes the translation cannot be performed correctly given the parts need to rotate. For this 

reason, one of the parts either the column or the beam must rotate until it fits the other part. 

Click on Rotate Instance to rotate any part about any axis to suit the right direction. 

Repeat the above steps for Segment Top Left and select the proper point on the segment that can 

be fitted to the column to complete the model by using the Translate Instance tool as shown in 

Figure 4-21.  
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Figure 4-20: Assembly of Beam and Column 
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Figure 4-21: Segment assembling 

 

4.4.4. Step Module 

After finishing the assembly section, the configuration of the analysis should next be defined. In 

this simulation analysis, we are interested in identifying the static response of the beam-column 

connection structure. Abaqus/CAE generates the initial step automatically. However, the rest of 

the analysis step should be carried out by the user as well as the requested output for any steps in 

the analysis. There are two kinds of analysis steps in Abaqus: general analysis steps, which can be 

used to analyze the linear or nonlinear response, and the linear perturbation steps, which can be 

used only to analyze linear problems. Only general analysis steps are available in Abaqus/Explicit. 

Next, create a dynamic, nonlinear perturbation step that follows the initial step of the analysis. 

This module is used to perform many tasks, mainly to create analysis steps and to specify output 

requests. 

 

4.4.4.1. Create an analysis step: "Pushover" 

After completing the assembly of model, the Step module needed to done to configure the required 

analysis. In this simulation analysis, the aim is to evaluate the static response of the structure under 

loads. This is a single event, so only a single analysis step is needed for the simulation. Thus, the 

analysis will consist of two steps: 

- The initial step, in which boundary conditions that constrain the end of the plate are applied 

- The analysis step, in which a distributed load is at the top surface of the beam element. 
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Abaqus/CAE generates the initial step automatically, but a Step module has to be operated by the 

user to create the analysis step. The Step module also allows the user to request output (field output 

and history output) for each step in the analysis.  

In the Module list located under the toolbar, click Step to enter the Step module. 

From the main menu bar, select Step→Create, to create a step. The Create Step dialog box appears 

with a list of all general procedures and a default step namedStep-1. 

Change the step name to “Pushover”. 

Select general as the Procedure type.  

Scroll through the available list, select Static,General, and click on Continue. (see Figure 4-22) 

 

 

Figure 4-22: Create Step 
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Then, the Edit Step dialog box appears.  

In the Basic tab, enter the time period with a value of 10 seconds, and the rest is selected by default.  

Click the Incrementation tab and change the increment size, as shown in Figure 4-23. 

Click the Other tab to see its contents; accept the default values provided for the step.  

Click OK to create the step and to exit the Edit Step dialog box. 

 

 

Figure 4-23: Incrementation value 

 

At the amplitude field, a tabular form of amplitude-time step is defined as shown in Figure 4-24. 

This option allows arbitrary time variations of load, displacement, and other prescribed variable 

magnitudes to be given throughout a step. 

Create amplitude 

Under the model tree, double-click on the Amplitude.  

The Create Amplitude dialog box appears.  
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Name the amplitude “Pushover”. 

Select the Tabular type of amplitude and click Continue. 

 Input the incremental of the amplitude data, as shown in Figure 4-24. 

Click OK to exit from the dialog box. 

 

 

Figure 4-24: Amplitude creation 

 

To create a homogeneous set, use the Set toolset.  

From the main menu bar, select Tool→Set→Create, and the Create Set dialog box appears.  

In the Create Set dialog box:  

Name the set “Displacement”. (see Figure 4-25) 

Select Node as the type of set and click Continue. 
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At the viewport, select one node on the edge of the cantilever. (see Figure 4-26) 

Click Done to complete the node assignation to the set. 

Repeat the same procedure repeat by selecting the nodes at the end column. (see Figure 4-27) 

To obtain the required outputs at the visualization module, it is necessary to request the history 

outputs in Step Module. The steps are as follow: 

Click on History Output Requests Manager to create History Output Requests. 

The Create History dialog box appears. 

Name the history output “Displacement” and click Continue. (see Figure 4-28) 

The Edit History Output Request dialog box appears. 

At the domain, select Set. 

Click the field next to the domain and scroll through the Set to see a list of the available sets and 

to select the required set as shown in Figure 4-29. 

Expand the Displacement/Velocity/Acceleration and toggle on U2 under U, Translations, and 

rotations. (see Figure 4-29) 

Click OK to exit from the dialog box. 

Repeat the same procedure for the Base Shear at the end column nodes as a reference surface for 

the base shear result by requesting the reaction force at X-direction, RF1 under the 

Forces/Reactions. 
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Note: The Software provides initial analyses, which are Stress, Strain, Reactions, and 

displacements for the whole structure. This result is considered primary as given by the software. 

The user can still specify the stress and strain and other parameters by clicking on the create field 

output icon. 

 

 

Figure 4-25: Create Set 

 

Figure 4-26: Select tip nodes 
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Figure 4-27: Select base nodes 

 

 

Figure 4-28: Create history output 

 

Figure 4-29: Edit History Output Request 
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4.4.5. Interactions Module 

This module is used to define various interactions within the model or interactions between regions 

of the model and its surroundings. The interactions can be mechanical or/and thermal. Analysis 

constraints can also be applied between two similar and different materials such as Tie connection, 

Rigid, embedded region, shell to solid coupling, etc. The interaction used in this example is a weld 

connection between the beam and column and also between the column and segments. To 

demonstrate the condition of the weld connection, the tie constraints in Abaqus will be 

implemented in this model. 

 

4.4.5.1. Tie Constraint 

Structural welding is a heating/fusing process in which enables the parts to be connected [joined], 

with supplementary molten metal at the joint. A relatively small depth of material will become 

molten, and upon cooling, the structural steel and weld metal will act as one continuous part where 

they are joined as displayed in Figure 4-30. 

 

 

Figure 4-30: 3D Weld connection 
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In Abaqus, fully constrained contact behavior can be defined using tie constraints. A tie constraint 

provides a simple way to bond surfaces together permanently and ties two separate surfaces 

together so that there is no relative motion between them. Moreover, it is a surface-based constraint 

using a master-slave formulation in which the constraint prevents slave nodes from separating or 

sliding relative to the master surface. This type of constraint allows two regions to fuse together 

even though the meshes created on the surfaces of the regions may be dissimilar. In this example, 

the tie connection is used to link the beam and column together. Tie rotational degree of freedoms 

are also used, if applicable, to allow the connection to have a possibility of rotation in a default 

value. 

 

4.4.5.2. Tie the surfaces 

In the Module list located under the toolbar, click Interaction to enter the Interaction module. 

From the main menu bar, select Constraint→Create to create a constraint. The Create Constraint 

dialog box appears with a list of all types of constraints and a default constraint named Constraint-

1. 

Name the constraint: 

Select Tie as the type of constraint and click on Continue. (see Figure 4-31) 

In the prompt area, choose the master type: Surface. 

Select regions for the master surface and then click Done. There are two ways to select the surface: 



135 

 

The user can use the existing surface to define the region. On the right side of the prompt area, 

click Surfaces and select an existing surface name from the Region Selection dialog box that 

appears and click Continue.  

The user can use the mouse to select a region in the viewport. The main surface of the column is 

selected as the master surface. (see Figure 4-32) 

In the prompt area, choose the slave type: Surface. The left edge surface of the beam is selected. 

(see Figure 4-33) 

Select regions for the slave surface and click Done. 

The Switch Surfaces option allows the user to interchange the master and slave surface selections 

without having to start over. However, it is available only when both master and slave regions are 

from the same type; both surfaces and both node-based regions. (see Figure 4-34) 

Accept the default. 

Click OK to save the constraint definition and to exit from the editor. 
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Figure 4-31: Create interaction type 

 

 

Figure 4-32: Select the main surface 
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Figure 4-33: Select the slave surface 

 

 

Figure 4-34: Create interaction 

 



138 

 

4.4.6. Boundary Condition 

Using this command, the user can create the loading that needs to be assigned to the elements or 

parts of the structure. The prescribed conditions, such as loads and boundary conditions, are step 

dependent, which means that the user needs to specify the steps in which they become active. In 

the next step, that the steps in the analysis have been defined, the Load module can be used to 

define the prescribed conditions. 

 

Apply boundary conditions to the plate; 

Follow the steps below: 

In the Module list located under the toolbar, click Load to enter the Load module. 

 From the main menu bar, select BC→Create. The Create Boundary Condition dialog box appears. 

In the Create Boundary Condition dialog box: 

Name the boundary condition “Fix End”. 

From the list of steps, select Static Load as the step in which the boundary condition will be 

activated. All the mechanical boundary conditions specified in the Initial step must have zero 

magnitudes. This condition is enforced automatically by Abaqus/CAE. 

In the Category list, accept Mechanical as the default category selection. 

In the Types for Selected Step list, select Symmetry/Axisymmetry/Encastre, and click Continue. 

Abaqus/CAE displays prompts in the prompt area to guide the user through the procedure. (see 

Figure 4-35) 
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There are several boundary conditions identified by the software such as pinned, fixed, etc.  

In the viewport, select the base of the column. This is the region to which the boundary condition 

will be applied. (see Figure 4-36) 

Right-click on the viewport or click Done in the prompt area to indicate the end of selecting the 

regions. The Edit Boundary Condition dialog box appears.  

In the dialog box:  

Fill the dialog box, as demonstrated in Figure 4-37.  

Select ENCASTRE, since all the horizontal and vertical degree of freedoms needed to be 

constrained as a fixed support. 

Click OK to create the boundary condition and to close the dialog box.  

The boundary conditions at the column base will be illustrated, as shown in Figure 4-38 
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Figure 4-35: Create a boundary condition 
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Figure 4-36: Select Boundary region 

 

 

Figure 37: Edit boundary condition 
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Figure 4-37: Fix End Boundary Condition 

 

4.4.7. Loading Module 

The concentrated load has been applied on the beam edge, and distributed load has also been 

applied on the whole top beam surface (see Figure 39). The quantity and type of applied loads can 

be seen in Table 4-3. 

 

Table 4-3 Applied Loads 

Case Case 1 Case 2 

Concentrated load 20,000 N 20,000 N 

Distributed load 50 N/mm² 100 N/mm² 
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The concentrated load and distributed load are both applied to the model at the same location in 

order to indicate the effect of both point load and concentrated load.  

 

 

(a) Concentrated Load    (b) Distributed Load 

Figure 4-38: Load Configurations 

 

After generating a boundary condition, it is possible to define loads for the model. In this example, 

two types of loading will be used to indicate the effect of push over loading. The concentrated load 

is applied in the initial step, which was created in the Step module. To apply the concentrated load 

to the model, carry out the following steps: 

From the menu bar, select Load→Manager. 

At the bottom of the Load Manager, click Create. The Create Load dialog box appears. 

In the Create Load dialog box: 

Name the load “Concentrated”. 
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Scroll through the available list of steps, select Static Load as the step in which the load will be 

exerted. 

In the Category list, accept Mechanical as the default category selection.  

In the Types for Selected Step list, select Concentrated Force. (see Figure 4-39) 

Click Continue.  

Abaqus/CAE displays prompts in the prompt area to guide the user through the procedure. The 

user is asked to select a region to which the load will be applied. As with the boundary conditions, 

the region to which the load will be applied can be selected either directly in the viewport or from 

a list of existing sets. As before, select the region directly in the viewport.  

In the viewport, select the points on the cantilever edge of the beam. (see Figure 4-40) 

Click on the viewport or click Done in the prompt area to finish selecting the regions. The Edit 

Load dialog box appears.  

In the dialog box: 

Enter a magnitude of -20,000 N as a vertical concentrated load. The negative sign in front of the 

value indicates the load applied is a downward force as gravitational force is acting downwards. 

(see Figure 4-41) 

Click OK to create the load and to close the dialog box.  

The concentrated load will appear on the cantilever edge of the beam, as shown in Figure 4-42. 

For uniform distributed loading follow the procedure below: 
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From the menu bar, select Load→Manager. 

At the bottom of the Load Manager, click Create.  

The Create Load dialog box appears. 

Name the load. 

Scroll through the available list of steps, select Static Load as the step in which the load will be 

exerted. 

In the Category list, accept Mechanical as the default category selection.  

In the Types for Selected Step list, select Pressure. 

Click Continue. 

In the viewport, select the top surface cantilever edge of the beam where the load will be applied.  

Click on the viewport or click Done in the prompt area to finish selecting the regions. The Edit 

Load dialog box appears.  

In the dialog box:  

Enter a magnitude of 50N/m2 as a distributed load. 

Click OK to create the load and to close the dialog box.  

The uniform distributed load will appear on the top surface cantilever edge of the beam, as shown 

in Figure 4-39. 
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Figure 4-39: Create Loading 

 

Figure 4-40: Select points 
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Figure 4-41: Input the load Value 

 

 

Figure 4-42: The Concentrated Load 
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Figure 4-43: The Distributed Load Case 1 

 

4.4.8. Mesh Module 

This is one of the most important modules given the accuracy of the results will rely on the number 

of mesh elements and mesh element size. This module can be used to generate meshes as well as 

to verify them. The larger the number of mesh elements, the smaller the mesh element size, and 

thus, the results will be more accurate. The finite element mesh should be generated in this module. 

Abaqus/CAE uses a number of different meshing techniques. The default meshing technique 

assigned to the model is indicated by the color of the model that is displayed when the Mesh 

module is entered. If Abaqus/CAE displays the model with the color orange, it cannot be meshed 

without the assistance of the user. This command is used to mesh the whole structure to small and 

equal parts and elements. 
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4.4.8.1. Mesh: Seed the part 

Mesh module is used to generate the finite element mesh. The meshing technique is used by 

Abaqus/CAE to create the mesh, element shape, and element type.  

To assign an Abaqus element type: 

 In the Module list located under the toolbar, click Mesh to enter the Mesh module. 

At the context bar, click on Part, to unclick the assembly 

From the main menu bar, select Mesh→Element Type. 

In the viewport, select the entire frame as the region to be assigned an element type. 

In the prompt area, click Done. The Element Type dialog box appears, as shown in Figure 4-44 

In the dialog box, select the following: 

- Standard as the Element Library selection (the default). 

- Linear as the Geometric Order (the default). 

- 3D stress as the Family of elements. 
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Figure 4-44: Selecting the Element Type 

 

The mesh can be created in this step. Meshing is basically a two-stage operation. First, seeding the 

edges of the part instance, followed secondly by meshing the part instance. Select the number of 

seeds based on the desired element size or on the number of elements that are required along an 

edge, and Abaqus/CAE places the nodes of the mesh at the seeds whenever possible. For manual 

meshing, click on Seed Edges. Then, select the edges that the user wants to mesh. Next, click Mesh 

Part Instance. 

 

Seed and mesh the model: 

From the main menu bar, select Seed→Part to seed the part instance.  
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Alternatively, select the Seed Part on the upper left corner of the meshing toolbox. The Global 

Seeds dialog box will appear, as shown in Figure 4-45. 

Type the appropriate value for the approximate global size of the mesh elements.  

Click OK to accept the seeding.  

 

 

Figure 4-45: Assign the approximate global size for mesh elements 

 

Select the Assign Mesh Controls tool at the meshing toolbox, and the Mesh Controls dialog box 

appears, as shown in Figure 4-46.  
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Figure 4-46: Choose the element shape and meshing technique option 

 

From the main menu bar, select Mesh→Instance to mesh the part instance or select the Mesh Part 

Instance at the upper left corner of the meshing toolbox. 

Select the part instances to be meshed. Once finished selecting, click Yes in the prompt area to 

confirm the mesh of the part instance. Once meshed, the plate changes color to blue. The meshed 

geometry is shown in Figure 4-47. 
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Figure 4-47: Meshing Done 

 

Abaqus/CAE highlights any elements that fail the mesh quality tests and displays the number of 

elements tested along with the number of errors and warnings in the message area. 

The user can verify the model meshing by clicking on the Verify Mesh icon, as shown in Figure 

4-48, and a message will appear in the text messages at the bottom of the screen. (see Figure 4-49) 

 

 

Figure 4-48: Verify Mesh 

 

 

Figure 4-49: Meshing Verify 
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The segment has an irregular shape at both edges, which might cause some meshing errors, as 

shown in Figure 4-50. Therefore, in order to avoid meshing errors, a datum plane is used. A datum 

plane is a plane that is used to separate the irregular shape from the main body and doing meshing 

for the parts separately, as shown in Figure 4-51. 

 

 

Figure 4-50: Errors given after verifying 

 

 

Figure 4-51: Rearranging meshing by the datum plane 
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4.5. Analysis: Job Module 

A job module can be used to create and manage analysis jobs and submit them for analysis. 

4.5.1. Create an analysis job: "Job-1" 

From the main menu bar, select Job→Manager and the Job Manager window appears. When 

finished defining the job, the Job Manager will display a list of jobs, the model associated with 

each job, the type of analysis, and the status of the job. 

In the Job Manager, click Create. The Create Job dialog box appears with a list of models in the 

model database. 

Name the job “Pushover-1” and click Continue. (see Figure 4-52) 

The Edit Job dialog box appears. 

In the Description field, type “Pushover”. In the Submission tabbed page, select Full Analysis as 

the Job Type. (see Figure 4-53) 

Click OK to accept all other default job settings in the job editor and to close the dialog box. 

Click on Submit to start checking the input file and running the analysis. (see Figure 4-54) 
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Figure 4-52: Create job 

 

Figure 4-53: Create job by default 

 



157 

 

 

Figure 4-54: Job submission 

 

When the model simulation is finished, analysis can then be executed. Since errors in the model 

originating from incorrect or missing data cannot be identified initially, the user should perform a 

data check analysis before running the analysis. To run a data check analysis:  

Make sure that the Job Type is set to Data check. From the buttons on the right edge of the Job 

Manager, click Submit to submit the job for analysis or the user can click on the Data Check at the 

right edge of the job manager for checking purposes. The model will then be on Check Running 

status. 

After job submission, the information in the Status column is updated to indicate the job's status. 

The Status column for the overhead hoist problem shows one of the following: 

None while the analysis input file is being generated. 

- Submitted while the job is being submitted for analysis. 

- Running while Abaqus analyses the model. (see Figure 4-55) 
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- Completed when the analysis is done, and the output has been written to the output database, 

and the user can click on the Results to proceed to the visualization module. 

- Aborted if Abaqus/CAE finds a problem with the input file or the analysis and aborts the 

analysis. In addition, Abaqus/CAE reports the problem in the message area. 

-  

 

Figure 4-55: Running the job analysis 

 

4.5.2. Monitor solution in progress 

Click "Monitor" to observe errors/warnings. 

From the buttons on the right edge of the Job Manager, click Monitor to open the job monitor 

dialog box once the job is submitted.  

The top half of the dialog box displays the information available in the status (*.sta) file that 

Abaqus creates for the analysis. 

If the status on top of the Job Monitor window is shown as Completed, then this job is free of 

errors and was executed properly. In the next step, the results can be observed.  
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4.6. Visualization Module 

Graphical post-processing is important given the vast volume of data created during a simulation. 

For any realistic model, it is impractical to try and interpret the results in the tabular form of the 

data file. Abaqus/Viewer allows the user to view the results graphically using a variety of methods, 

including deformed shape plots, contour plots, vector plots, animations, and X–Y plots. Here, the 

model can be viewed, and various plots generated. The result of stress and displacement in the 

main menu bar is requested.  

 

4.6.1. View the results of the analysis 

When the job is completed, the user can view the results of the analysis with the Visualization 

module. Abaqus/CAE loads the Visualization module, opens the output database created by the 

job, and displays a fast plot of the model. A fast plot is a basic representation of the undeformed 

shape. The visualization option can be clicked in the Module list located under the toolbar; select 

File→Open and select Pushover-1.odb from the list of available output database files and click 

OK.  

To obtain the displacement outputs of the model, 

From the main menu bar, select Result→History output.  

The History Output dialog box appears. 

Select all the base shear results at the end column nodes, and the graphs are plotted in the viewport, 

as shown in Figure 4-56. 
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Select only the displacement result, and the graph is plotted in the viewport, as shown in Figure 

4-57. 

All the results will be extracted from this module, and further explained in the next section. 

 

 

Figure 4-56: Graphs of Base shear vs. Time 
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Figure 4-57: Graph of Displacement vs. Time 

 

4.7. Results and Discussion 

The requirement to plot the pushover curve should be taken. 

 

4.7.1. Case 1 

Base VonMises stress S (Case1) – Figure 4-58. 

Displacement U (Case1) – Figure 4-59. 

Base Shear Force vs. Time (Case1) – Figure 4-60. 

Base Shear Force vs. Time-Resultant (Case1) – Figure 4-61. 

Displacement vs. Time (Case1) – Figure 4-62. 

Displacement vs. Base shear force (Pushover Curve) (Case1) – Figure 4-63. 
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Figure 4-58: Stress Result 

 

 

Figure 4-59: Displacement Result 
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Figure 4-60: base shear force graph 

 

 

Figure 4-61: Resultant Base Shear force 
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Figure 4-62: Displacement vs. Time 

 

Figure 4-63: Shear Force vs. Displacement 
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Figure 4-64: Displacement VS Base shear force (Pushover Curve) 

 

4.7.2. Case 2 

Base Von Mises stress S (Case2) – Figure 4-65. 

Displacement U (Case2) – Figure 4-66. 

Base Shear Force vs. Time (Case2) – Figure 4-67. 

Base Shear Force vs. Time-Resultant (Case2) – Figure 4-68. 

Displacement vs. Time (Case2) – Figure 4-69. 
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Figure 4-65: Stress Result 

 

 

Figure 4-66: Displacement Result 
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Figure 4-67: Shear force results 

 

Figure 4-68: Shear force resultant 
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Figure 4-69: Displacement vs. Time 

 

In both cases, it can be seen that the most critical area subjected to large stress is the column-beam 

connection. Therefore, this should be taken into consideration (see Figure 59 and Figure 66). It is 

also obvious that the peak displacement occurs at the cantilever beam. (see Figure 60 and Figure 

67) 

 

4.8. Conclusion 

The model has been analyzed by the pushover method to indicate the capacity of the connection 

between the beam and column and to find the amount of displacement and check the base stress 

and shear to plot the pushover curve. The results show that the distributed load is more effective 

over the beam, while less contribution to the concentrated load has been obtained. The study 

further shows that the increase of distributed load from 50 N to 100 N has caused only a 25 % 

increase in displacement and the length is increased from 45 mm to 60 mm. On the other hand, 

increasing the uniform distributed load, the base shear has increased by 1.4% in total base shear 

where it induced at the column fixed end base. Table 4-4 illustrates the displacement of both Case 
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1 and Case 2 at a particular time, while Table 4-5 illustrates the base shear force of both Case 1 

and Case 2 at a particular time. 

 

Table 4-4 Displacement 

 Displacement 

Time Case 1 Case 2 

0 0 0 

0.1 3.97082 7.94284 

0.125 7.94301 9.948 

0.1625 27.018 15.8467 

0.176563 39.6789 30.0132 

0.180078 44.1828 41.0157 

0.183594 1.1 59.074 

 

Table 4-5 Base Shear 

 Base Shear Force 

Time Case 1 Case 2 

0 0 0 

0.1 102237 102337 

0.125 127806 127932 

0.1625 166159 166322 

0.176563 180495 180669 

0.180078 184029 184201 

0.183594 1.2 187639 
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Chapter 5: Strengthening of the R.C Beam using CFRP Rods and Concrete Jacketing 

Instructor: Mahmood Alkhateeb 

 

5.1. Introduction 

In this chapter, the tutorial presents the procedure of modeling the reinforced concrete (RC) beam, 

which will be strengthened or retrofitted using CFRP rods with concrete jacketing. One of the 

popular finite element software programs used in this tutorial is ABAQUS. Previously, many 

techniques have been employed in strengthening different components of existing structures. Over 

the last three decades, the FRP system has proven to be the most effective alternative mechanism. 

Even though the system is effective and efficient, there are some weak points which encourage 

more research to be undertaken and a new system proposed. 

This tutorial describes one of these new proposed systems. A normal RC beam with dimensions 

150*250 mm with 2T12 as tensile steel at the bottom, 2T10 at the top and8mm links at each 

200mm is used. The beam will be strengthened by using CFRP rods and concrete jacketing at the 

bottom side of the beam to increase the loading capacity of the beam. Modeling will be used to 

verify the experimental results which will be conducted according to ASTM D6272 – 02 (Standard 

Test Method for Flexural Properties of Unreinforced and Reinforced Plastics and Electrical 

Insulating Materials by Four-Point Bending). 

The aim of this module is to measure how the FRP will increase the loading capacity of the RC 

beam. Here a different parameter will be investigated to determine the effect of CFRP Area, 1 

CFRP, 2 CFRP, and Spacing of Bolting; 0mm, 250mm L/8, 500mm L/4. The results will be shown 

in terms of displacement vs. time, load vs. time, displacement vs. loading curve, and others. 
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5.2. Problem Description 

This tutorial will explain the steps to module a 3D finite element of simply supported reinforced 

beams and the ways in which to instill the strengthening system in the beam. The steps will involve 

the loading and investigating the effect of parameters on the behavior of the strengthened beam, 

as shown in Figure 5-1. 

 

 

Figure 5-1: 3D Modeling. 

 

5.2.1. Geometric Properties 

The dimensions and details of the RC beam, under strengthening, are shown in 
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Figure 5-2. The beam before the strengthening system is a simply supported beam having a total 

length of 2,200 mm. The effective length will be 2,000 mm. The cross-section A-A explains the 

reinforced details. The width of the beam is 150 mm, and the height is 250 mm. The main 

reinforcement will be 2T12 mm at the bottom and 2T8 at the top to hang the strips. The links are 

placed at each 100 mm (closed strips) with a diameter of 8 mm. The concrete cover in the 

horizontal direction is 15 mm and 30 mm in the vertical direction. 

 

Figure 5-2: Details of the Beam 

 

The strengthening system used will be CFRP Rods with concrete jacketing. The CFRP rods will 

be fixed to the bottom of the beam using anchorage bolts. Then, 30 mm concrete jacketing will be 

cast at the bottom, covering the bolts and rods, as illustrated in Figure 5-3. 
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Figure 5-3: Details of the Beam and Strengthening System 

 

5.2.2. Material Properties 

The RC concrete beam is made from composite materials containing concrete and reinforced steel, 

and the concrete consists of cement, fine aggregate, coarse aggregate, water, in addition to some 

additives and admixture. The properties of the concrete rely on the properties of its initial material 

and its proportion in the mixture. In this modeling, concrete with compressive strength equal to 40 

MPa was selected. Table 1 provides all the necessary information to define the concrete material. 



174 

 

Regarding the steel, Table 5-1 displays the properties of the steel. Two types of steel are identified; 

high strength steel of 500 MPa is used for the reinforcement bars and other main steel components, 

and for the links and secondary components 250 MPa steel will be used. 

 

 Table 5-1 Concrete Properties 

 

 

The most important material to define is the material that will be used in the strengthening system, 

which are CFRP rods, anchorage bolts, jacketing concrete, and epoxy as adhesive materials. All 

properties in Table 5-2 , Table 5-3, Table 5-4, Table 5-5 and Table 5-6 define the characteristics 

of these materials taken from the latest papers based on their availability. 

 

Table 5-2 Tensile properties of CFRP rods with fiber volumes of between 50 and 70% 

 

 

Table 5-3 Steel Properties 
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Table 5-4 Epoxy adhesive properties 

 

 

Table 5-5 Jacketing concrete properties 

 

 

Table 5-6: Anchor bolt mechanical properties 
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5.3. Objectives 

1) To create 3D finite element modelling for RC concrete beam strengthening using CFRP rods 

with anchorage bolts and jacketing concrete. 

2) To measure how much strengthening will develop the behaviour of the beam. 

3) To Investigate the effects of different parameters on the behaviour of the strengthening beam. 

 

5.4. Modeling 

Creating 3D finite element modeling in almost all F.L programs will follow similar procedures. 

ABAQUS, like other programs involve a series of steps. These steps are summarized into three 

phases, as shown in Figure 5-4. 

 

 

Figure 5-4: The Main Phases in 3D Modeling 
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Figure 5-5 shows the steps of modeling the RC Beam strengthened with CFRP Rods and concrete 

jacketing using ABAQUS. Each step depicted in the diagram will be further clarified. 

 

 

Figure 5-5: 3D Finite Element Modeling Steps (ABAQUS). 
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5.4.1. Part Module 

Any real structure can be converted into 3D Modeling. This structure is initially divided into a 

number of elements or parts. The assembly of these parts will produce the structures. The modeling 

will consist of five parts. Three parts will formulate the RC Beam, and two parts will produce the 

strengthening system. The first three parts will consist of the body of the RC Beam, Rebar 

reinforcement and the stripes. The other two parts will comprise the CFRP Rods and Concrete 

jacketing. 

The following section will explain step-by-step how to create the modeling files and different parts. 

 

5.4.1.1. Create modeling file 

Open ABAQUS/CAE by double-clicking on the icon on the desktop. 

When the program starts to execute, from the Start Session dialog box choose, With Standard 

/Explicit Model from the Create Model Database as shown in Figure 5-6. 
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Figure 5-6: Create the Modeling File. 

 

Once the main screen of the program appears, create a new file, and locate a location to save the 

file. Before beginning to create the model, notice at the left of the window, there is a dialog box 

including all the steps in a tree form which can be used to create the model. At the top, there is a 

menu bar which can also be used. 

 

5.4.1.2. Create the parts 

 

i) Concrete Beam 

Click in the lift trees Create Part/or from the top menu bar click on Part → create. 

A Create Part dialog box will open. This dialog box needs to completed with the name, modeling 

space, type, base feature (shape and type), and approximate size. 
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Here, the dialog box will be completed using the following information. Name: R-C-Beam, 

Modeling Space: 3D, Shape: Solid, Type: Extrusion, and Approximate Size: 10000, as shown in 

Figure 5-7. Once completed click Continue to proceed to the next step 

 

 

Figure 5-7: Create RC Beam 

 

A new space will be opened to define or draw the shape of the cross-section. 

Start to sketch the section by extrusion solid with dimensions for the beam’s cross-section. 
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In this space, the program provides numerous drawing tools, as shown in Figure 5-8 to sketch and 

modify the drawing. 

By using Create lines: Rectangular (4 lines) draw a rectangular shape. 

Take X, Y plan for the cross-section, (0,0) to Pick the starting point for the rectangular shape or 

enter X, Y, and (150,200) and Pick the opposite corner for the rectangular or enter X, Y. By using 

the Add Dimension, identify the cross-section size as horizontal 150 mm and vertical 200 mm. 

Then, click Done in order to define the other axis length. Edit base extrusion will open. Enter the 

length of the beam in the Z-axis as 2200 mm and then click Ok. Figure 5-9 shows the steps to 

create the part for the beam. 

 

 

Figure 5-8: Sketch Tools 
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Before moving to create another part, it is necessary to define the datum plane for the length of the 

beam. The purpose of this datum will be clarified later when the boundary conditions and loading 

are defined. Figure 5-10 shows the comparison between the R-C-Beam part in 3-dimensions before 

creating the datum and then after. 

By using Create Datum Plane: Offset from principle plan→ choose XY Plan→ and make an offset 

of 100,600,1100,1600, and 2100. Then use Partition Plan: Use Datum Plane to create a partition 

in all previous datum planes. 

Creating a partition is not necessary to do in the next step, and it is advised to make it later, 

especially in the load step. The Load Step, as discussed later in Step load, the program will ask the 

user to select to Set or the surface which the loads or even the support will assign on it. 
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Figure 5-9: Steps to Create the RC Beam 

 

It is recommended to create the partition while at the same time, create the set to apply the load, 

and the support as creating the partition later will create a new part. This new part will be needed 

again to define its materials, and the constraints which include the beams already involved which 

will need to be modified again in creating meshing for the beam. 
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Figure 5-10:Comparison between the RC Beam in 3-Dimensions before and after the Datum and 

Partition 

 

ii) Bar Reinforcement 

The main reinforcement is at the bottom of the 2T12. At the top, there is also 2T8 to fix the link in 

its proper position. To create the bar reinforcement, similar steps need to be followed with minor 

changes that reflect the natural behavior of the steel. 

The create part dialog box need to include the following information: Name: steel -bar, Modeling 

Space: 3D, Shape: Wire, Type: Planar, and Approximate Size: 10000. Next, use create a line to 

sketch the steel bar, as shown in Figure 5-11. 
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Figure 5-11: Create Steel-bar steps 

 

iii) Stirrups 

In this beam, close T8 stirrups will be used as links and to gather the steel reinforcement bars. As 

long as the beam does not fail from shear stress and according to the numerical calculation, the 

distance between each link will be 200 mm along the entire length of the beam.  

The same approach will be used to create the Steel-link part, as shown in Figure 5-12. 
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Figure 5-12: Create Steel-Link steps 

 

By creating the previous three parts, the produce or form the classical RC Beam can be done. The 

next parts needed to be created will be used to form the strengthening system. The proposed system 

applied in this example will be from the CFRP part embedded inside the concrete jacketing, which 

is attached to the bottom of the beam. 

 

iv) CFRP Rods 

In this strengthened system, the main components to be used in providing extra strength and 

increase the loading capacity of the beam are the CFRP rods which will provide additional tensile 

strength in the bottom edge of the beam. As discussed earlier these CFRP Rods will be fixed to 

the original beam by anchorage bolts to ensure good bonding. Later after fixing them, a new layer 
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or jacketing will cover and protect the rod from any external effects. Another issue to be considered 

will be the good connection between the old and new concrete. Good preparation for the bottom 

side of the beam will help to achieve acceptable bonding. Good bonding will also enable the system 

to be more functional and to avoid any immature disbanding problems from occurring. In this case, 

the stress to be generated by the loading will be resisted by the CFRP rods. 

The steps to create the CFRP rods part are illustrated in Figure 5-13. 

 

 

Figure 5-13: Create CFRP-Rod steps 

 

v) Concrete Jacketing 

The steps to create the concrete jacketing are similar to the steps used to create the RC part. Figure 

5-14 will explain the steps and dimensions that will be used. 
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Figure 5-14: Create C-Jacket steps 

 

After creating all the parts that are needed to form the modeling and before moving to the second 

step, it is useful to learn how to transfer between the different model steps and different parts in 

the model. 

For the model steps, as shown in Figure 5-15, there are two easy ways to transfer between steps. 

The first one is from the Module Database window in the left of the picture (inside the blue 

rectangular), and the second way is from the bar directly above the working area in the Module by 

clicking next and then scroll among the different steps, (highlighted in the red rectangular box).The 

parts can also be transferred from among them through accessing the top toolbar from Part, or from 

the same window, or even from Part in the bar above the working area as shown in Figure 5-15. 

 



189 

 

 

Figure 5-15: Moving among the steps and parts 

 

5.4.2. Property Module 

The Property module defines the materials for each specific part, which will be used in the 3D 

modeling. In this program to achieve this target, there are three steps. These steps are Create 

Material, Create Section, and Assign Section, in the same order. 

At the beginning, one of the above methods will be employed to transfer or move from the part 

step to the property step. Once the Property step is active, a window will appear to the left (see 

Figure 5-16). 
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. 

Figure 5-16: Property main steps 

 

The material of the part will be defined according to the tables as discussed in the previous section. 

Five materials need to be created: steel G500, G250, Concrete G30, G40, and CFRP rods. The 

material will be created using the time and date of the program 

5.4.2.1. Material Properties 

 

i) Steel G500, G250 

As mentioned, there are three steel parts used in this model. The main reinforcement (2T12) is 

steel G500 and the top reinforcement (2T8), consisting of 8 mm links is G250. In both types, linear 

elastic steel material is defined. According to Table 2 for steel G500, the modules of elasticity will 

be 200,000MPa (200GPa), but for G250, it will be 185,000 MPa (185GPa). For the passion ratio, 

it will be 0.3 in both types. 



191 

 

In the properties window, the first option is to Create Material. Click on this option. 

The Edit Material dialog box will appear. Begin to enter information into this box. Name: 

SteelG500. 

In the material, the Editor begins to define the material parameters. Steel density, mechanical 

elasticity, and mechanical plasticity need to be defined by the user. 

Click General → move down choose Density → in the Data, Mass Density type 7.85E-009. 

Click Mechanical → Elasticity → Elastic from the material editor bar. In the data area, enter 

Young’s Modulus as 200,000 MPa, and Poisson’s Ratio 0.3. 

To define the elasticity, again Click Mechanical → Plasticity → Plastic from the material editor 

bar. In the data, area create two rows and enter in the Yield Stress column as 400 and 500 MPa up 

to dawn, and in the Plastic Strain column enter 0, 0.25 (Figure 5-17). 
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    … 

Figure 5-17: Create Material Steel G500 MPa. 

 

Finally, click on OK to finish editing the material box. 
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For Steel G250: Repeat the same steps, except there will be a minor change to some values which 

will be entered in the data area, as shown in Figure 5-18. 

 

  

Figure 5-18: Create Material Steel G250 MPa 

 

ii) Concrete G30 

Concrete G30 MPa will be used for both the concrete for the main beam prior to strengthening and 

in the retrofitting system as the grade for the concrete which will provide jacketing cover.  Table 

5-1 identifies the essential material properties to be used in defining or creating the concrete 

material. 

The procedures to create the concrete material will be similar as the steps used in creating the steel 

material. 

After clicking Create Material define the name as Concrete-G30. 

To define density: General → Density→ 2,4E-009. 
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To define mechanical elasticity: Mechanical → Elastic→ Young’s Modulus as 25,190 MPa, and 

Poisson’s Ratio 0.15. 

To define mechanical plasticity: 

Mechanical→ Concrete Damaged Plasticity→ complete the table by entering 35, 1,1067,0,667, 

and 0, respectively, from left to right, as shown in Figure 5-19. 

Mechanical→ Concrete Damaged Plasticity Compressive behavior→ Yield Stress as 24 and 

Inelastic Strain as0. 

Mechanical→ Concrete Damaged Plasticity →Tensile behavior→ Yield Stress as 2.46 and 

Cracking Strain as 0. 

As can be seen in defining the material, there are many parameters and alternate options in defining 

the expected behavior of the materials. However, it is necessary to use them all, as only a few 

parameters are selected to define all the material properties. 
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   .. 

Figure 5-19: Create Material Concrete G30 MPa 

 

iv) CFRP Rods 

The determination of the exact behavior of CFRP Rods under different loading conditions is not 

easy. Researchers continue to try to formulate and generalize the properties of CFRP. In this 
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tutorial, the mechanical properties of CFRP Rods will rely on recent research papers and coding. 

Table 3 displays the CFRP properties. 

The CFRP material will be created using the same steps as used for creating other materials. Figure 

20 expresses the parameters and values to be used. 

Enter the Name CFRP-Rods for the material in selecting Create Material. 

For elasticity behavior select Mechanical → Elastic→ Young’s Modulus and enter 165000 MPa, 

and Poisson’s Ratio 0.3.  

For plasticity behavior select Mechanical → Plastic and for Yield Stress enter 1,860 MPa and 

Plastic Strain as 0 (Figure 5-20). 

 

    … 

Figure 5-20: Create Material Concrete G30 MPa 
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5.4.2.2. Section Properties 

The Create section is an important step in defining the properties of the module’s parts. The Create 

section consists of two main dialog boxes, the create section and the edit section. In the first box, 

the create section will define the Name of the section. Here, select the Category among Solid, 

Shell, Beam Fluid and Other, and next determine the Type of section according to the category 

been selected. For example, for the solid category, following types are: Homogeneous, 

Generalized Plan Strain, Eulerian, or Composite. For the Beam category, there are two types: 

Beam and Truss, and so forth for all the other categories. 

When completed, create the Section box and click Continue. An Edit Section dialog box will 

appear. The parameters in this window will be dissimilar depending on what has been chosen in 

the previous box. Error! Reference source not found. shows the two create section boxes. In this 

modeling, there are six sections which are Main-Bar, Top-Bar, Link, C-Beam, CFRP Rods, and 

C-Jacketing. 

 

i) Main-Bar 

The diameter of the main bar is 12 mm (cross-section area 123 mm2), and the grade of steel is 

G500 MPa. In creating the bar, reinforcement is noted as the Wire bar. From the vertical module 

property toolbar, click Create Section. The Create Section dialog box appears. 

In the empty space next to the Name write Main-Bar. 

In the Category check the beam. 
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Then from the Type selection, choose Truss and then click Continue to move to the edit section 

dialog box. 

In the Edit Section dialog box, from the narrow beside the Materials scroll down the list to select 

the material. In this case, it will be SteelG500. 

In the same dialog box enter 123 mm2in the space inside the Cross-Sectional Area. Finally, click 

Ok to begin creating a new section. 

 

ii) Top-Bar 

The top reinforcement bar, as illustrated earlier consists of two bars, each having a diameter of 8 

mm (cross-section area 55 mm2). This will be similar as for the Main-Bar; (SteelG500 MPa), and 

in creating the Wire part. 

The same steps will be applied to create the cross-section for the Top-Bar except for the Cross-

Sectional Area, which will require a space of 55 mm2instead of 123 mm2. 

 

iii) Links 

The stirrups or the links in this module are created as close link parts. The cross-sectional area will 

be 55 mm2and material as Steel grade G250 MPa. To define the section for this link, a similar step 

will be followed as applied for the Main-Bar and Top-Bar with a minor change in the material as 

SteelG250 and the cross-sectional area as 55 mm2. Figure 5-21 shows the different selections for 

entering the values for the steel material parts. 
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Figure 5-21: Steel Material Sections 

 

iv) Concrete Beam 

The main section is the Concrete-beam section. After defining all the sections related to steel, the 

procedure to create the concrete section will begin. The Concrete beam as earlier created is a solid 

part, and the material used was concrete of grade30 MPa. By using this data, follow the same steps 

to create the section but applying a different method. 
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From the Main Toolbar select Section, and from the sub-tree dialog box click Create. 

The same Create Section box will appear. Complete the dialog box as Name: Concrete-beam. From 

Category note as solid and the Type choose homogenous. Then click on Continue. 

In the Edit Section dialog box, in the Material space, choose Concrete-G30. Then click Ok. 

 

v) Concrete-Jacket 

In the concrete jacketing section, the same steps as in the Concrete-Beam section are used as long 

as both are sold parts and concrete material. In this case, the Name of the section will be Concrete-

Jacket. 

The Create Section and Edit Section dialog box for both the concrete-beam and concrete-jacket 

are illustrated in Figure 5-22. 
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  …  

Figure 5-22: Concrete Material Sections 

 

vi) CFRP Rods 

The last section to be created is the CFRP rods section. The CFRP rods are created as the Wire 

part, and the material created as CFRP rods. In this module, the dimensions of the CFRP Rods 

have a length of 1900 mm, a diameter of 6 mm, and a cross-sectional area of 123 mm2. 

The same steps are applied from the Create Section dialog box and in the edit section box enter: 

Name: CFRP rods, Category: Solid, and Type: Truss. 

In the Edit Section dialog box, choose CFRP rods for Material, and in the Cross-Sectional Area 

enter 123 mm2 (see Figure 5-23). 
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Figure 5-23: CFRP-Rods Material Section 

 

5.4.2.3. Assign Section 

The Assign section is the third and final step in defining the modulus properties. In this step, after 

creating the different materials, and creating all the required sections, allocate the creating sections 

to the different modulus regions. Assign each defined section into its corresponding part(s) or as a 

partial region of these parts. ABAQUS provides an option to create a set for the region of all or 

partial region of the parts. To assign the section for different parts, the following steps are applied: 

In starting the assign procedure, there are many ways to start the Assign Section. The prompt area 

will also help the user. 

From the main Menu select Assign and then click Section. 

From the property vertical toolbar choose Assign Section. 

From the left window, select Part to select the specific part. To expand the Menu →select Section 

Assignment. 

The prompt area will ask the user to Select the Region to be Assigned a Section and provide an 

option to Create A New Set for this region and request a Name.  

By using the mouse pointer, select all parts or a certain region of the parts. Select the part or the 

region either by clicking on the region or creating a window around the part using the mouse. 

After selecting the part or all the regions click on Done. A new dialog box will appear under the 

name Edit Section Assignment. In the prompt area, it will ask the user to complete the dialog box. 
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The edit section assignment will create a section to be assigned for the selected region. This list 

appears when clicking on the small arrow next to the Section. Then, from this list, select the section 

which corresponds to each region. 

Once clicking on the selected section, in the same box, Material and Type will appear. Check them 

both and click Ok to confirm selected section. 

The dialog box will then disappear, and the selected region will convert to a green color, where 

the prompt will then ask the user to start perform another assign for a new region. 

Repeat the same steps for all parts and the region required in the 3D modeling, 

Figure 5-24 displays a summary for all created Parts, Materials, and all created Sections. In 

addition, ABAQUS provides the ability to modify, copy, rename, and even delete all created parts, 

material, and sections. This can be easily performed using the Part Manager, Material Manager, 

and Section Manager, respectively (Figure 5-24). 
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Figure 5-24:Part, Material, and Section Manager 

 

RC-Beam: 

The part is created under the name R-C-Beam and the section assigned to this part is created under 

the name Concrete-Beam. The same procedures are applied to Create Assign for the R-C-Beam. 

Figure 5-25 shows a number from 1-5 explaining each step. 
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Figure 5-25: Assign Section for R-C-Beam 
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For assign, all the other parts will follow the same steps, as shown in Figure 5-26. 
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Figure 5-26:Assign for all Parts 
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5.4.3. Assembly Module 

Assembly in the model means collecting all the parts which have already been created and were 

previously defined as material having a certain configuration in establishing the 3D model. The 

number of parts which will contribute to the assembly procedure, however, is different between 

models. Many processes will apply to these different parts in ensuring the 3D modeling is correctly 

reflecting the actual sample in reality. 

In this tutorial, as previously mentioned, it will present the ordinary reinforcement beam and 

strengthening system. Three parts are involved in creating the ordinary RC beam: R-C-Beam, Steel 

bar, and Links. Whereas, only two parts are involved in the strengthened system: CFRP-Rods and 

C-Jacketing. 

 

5.4.3.1. Assemble part instances into the modeling 

In the module toolbar, above the working area, change the list to Module Assembly. Similar to 

other steps, the vertical toolbar and the main toolbar at the top will immediately change, as shown 

in Figure 5-27. 
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Figure 5-27: Module Assembly 

 

In the assembly toolbar, there are numerous supporting tools. These tools will help to create 

accurate modeling like a Linear Pattern, Translate Instance, Move Instance, Edit Feature, and so 

forth. To start from the module track, the following steps are performed: 

Insert all the parts or instances that are required to build the module. This is achieved in several 

ways, as shown in Figure 5-28. 

From the main top toolbar click on Instance, and then select Create. Or from the vertical toolbar, 

click the first icon, which is Create Instance. 
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… 

Figure 5-28: Create Instances 

 

A Create Instance dialog box will appear. The displayed prompt will request the user to Select the 

parts/modules to Instance from the dialog box. 

From the dialog box, choose the parts below the Create instances from. 

From the Part which is listed below the Parts, select one of the parts, for example, the R-C-Beam. 

The selected part will appear in the working window behind the dialog box as the selected part. 

In the Instances Type option chooses Dependent (mesh on the part). 

Then click Ok to finish or Apply to move to create an instance for another part. 

Be sure to create an instance for all parts, as shown in Figure 5-29. 

Start to use the supporting tool in the vertical assembly toolbar to move and locate each part in its 

proper position and direction. 
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Figure 5-29: Create Instances for All Parts 
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Starting with the R-C-beam, its position and direction are ok. This includes the right bottom edge 

in the coordinator (0,0,0) and its cross-section in the XY plane, and the longitudinal section on the 

Z axis. 

For the second part, C-Jacketing, its direction is ok, but the location needs to move to the position 

between the support directly under the bottom surface of the C-R-Beam.  

To perform this step, use translate instance tools→ select C-Jacket when asked and Select instance 

to translate. Then select from the top right edge when asked to Select start point for translation 

vector---or enter (X, Y, Z) → by entering (0,0,100). When asked to Select the end point for 

translation vector---or enter (X,Y,Z)→click on ok when asked about the Position of instance if it 

is ok to translate or type X to delete the translate and move back if there is a need to modify or 

change. When it is ok, the C-Jacket will move to its accurate position and appear in the new 

position. Figure 5-30 shows the treatment for the C-Jacket. 
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Figure 5-30: Treatment of Jacketing 

 

At this point, the Steel bar instance is not correct, even in the location or direction. Besides that, 

the number of bars is supposed to be depicted as four bars. Two at the top (8 mm), and two at the 

bottom (12 mm) at each corner. Many procedures will be used to resolve this issue. Starting from 

rotate instance and then translate instance and finally, linear pattern. All these tools are found in 

the vertical assembly support bar or can extend from the main top bar from Instance. 

To Rotate instance: Select the steel-bar instance when prompted by Selecting the instances to rotate 

after clicking on the rotated instance. After selecting the steel bar, click Done. The same 

conversation will begin in performing the operation. When asked about Select a start point for the 

axis of rotation—enter X,Y,Z  by inserting (0.0,0.0,0.0)→choose the right top corner of the R-C 

beam (
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Figure 5-31). 
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Figure 5-31: Rotated Steel-Bar 

 

Or alternatively, enter (0.0,250.0,0.0) as the axis for rotation when prompted to Select an end point 

for the axis of rotation—or X, Y,Z. Then the program will ask the user about the angle of rotation 

and show the new position. In this case the angle will be -90ofor rotation. Enter (- 90o) and click 

on enter. Again, the instance will appear in its new position. Click Ok when asked if the Instance 

Position is correct or X to return to make any changes. 
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Figure 5-31 displays this rotation. 

Translate instance: Moving the steel bar from its new position after completing the rotation process 

is finished is the second procedure for the steel bar. From Figure 31, it showsNo:6, the steel-bar in 

its new position is almost inside the body of the R-C-Beam and cannot be seen or selected easily. 

So, before moving to translate the steel bar, some treatment needs to be performed. From the main 

Menu, bar go to View extend it and select and click on Assembly Display Option. The Assembly 

Display Options dialog box will appear. Click on Instance from the various tabbed pages on the 

top of this box. From here, the user can control which instance is visible in the window and which 

one is hidden by clicking in the Visible Box beside each instance. In this case, as illustrated in 

Figure 5-32, R-C-Beam-1 and C-Jacket will be hidden. Then click Apply to show the change or 

click Ok to close the dialog box. 
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.. 

Figure 5-32:Assembly Display Option 

 

The steel-bar becomes visible using the same procedure. The steps for Translate C-Jacket will be 

repeated here except when asked about Select end point for translation vector---or enter (X, Y, 

Z)in which it will be(15.0,30.0,30.0), as shown in Figure 5-33. 
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Figure 5-33:Translated Steel Bar 

 

Linear Pattern: After checking the steel-bar in the correct position and direction, next create the 

linear pattern for the steel reinforcement. As long as there are four bars, and the distance between 

them horizontally is 120 mm and vertically 190 mm the same distance will be used. From the 

vertical assembly supporting bar, the linear pattern will be chosen by clicking on it. Then click on 

the steel bar when the prompt appears asking to Select the instance to pattern and then click Done. 

A linear pattern dialog box will appear and ask the user to determine the Number of Offsets on 

Direction1 and Direction2 and the distance between both. As mentioned early, the number of 
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patterns will be 2 in both directions and 120 mm and 190 mm in the horizontal and vertical 

directions, respectively. The new creating patterns dialog box will appear in the window→ click 

Ok if it is acceptable or return to the dialog box to carry out any changes, as shown in Figure 5-34. 

 

 

Figure 5-34: Create a Linear Pattern for the Steel-Bar 
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The steel link is in the correct direction located at the XY plane but in the incorrect position. Figure 

5-35 shows the treatment to be performed for the steel links. As shown, the links need to be 

translated into their correct position using Translate Instance, and using Linear Pattern to create 

the required number of links. Also, to identify the distance between both along the longitudinal 

axis of the beam as shown in the figure below. 

Click on Translate Instance from the vertical bar→ select the steel link→ keep (0,0,0) as the 

starting point to pick up the instance→ then enter (15,30,30) as the new position for the steel link. 

Click on Linear Pattern from the vertical bar → select the steel link→ fill up the box as 22 for the 

number of offsets with a distance equal to 100 mm to change the direction of offset along the Z 

axis. 
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Figure 5-35:Translate and Linear Pattern for the Steel-link 

 

The CFRP Bar is the last instance needing treatment to place in its correct direction and position. 

As the steel bar, the CFRP Bar will need to progress through three processes, namely rotated 

instance, translate instance and finally, linear pattern. 
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Click on rotate instance →select the CFRP bar to identify the two points in the vertical edge of the 

R-C-Beam as the axis of rotate → enter (-90o) as the angle of rotation. 

Click on translate instance →select the CFRP bar →keep (0,0,0) as the starting point for transfer 

and enter (15, -15,180) as the new point for the CFRP. 

Click on linear pattern → select CFRP bar →complete the dialog box by entering 2 as the number 

of offsets with 120 mm in the X direction (Figure 5-36).  
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Figure 5-36: Rotate, Translate, and Linear Pattern for the CFRP Bar 

 

After assembling and gathering all the instance in their correct direction and position, the finite 

element is ready and almost reflects the real structure. ABAQUS provides a variety of views for 

modeling and for different cutting sections. Furthermore, many alternate options for coloring codes 
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are available, as shown in Figure 5-37. All these options can be found on the main menu bars 

above the working area. 
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Figure 5-37: Different color Codes for 3D Assembly Modeling 

 



226 

 

5.4.4. Step Module 

The Step module is considered as one of the essential steps in 3D simulation modeling. The main 

parameters which are needed are found in the step toolbar, namely, Create Step, Create Field 

Output, and History Output. In each, there are many parameters which need to be determined. 

These parameters are different for every model, depending on the types of analysis required, and 

results or output required. To begin, from the top bar above the working area, scroll to Module and 

then select Step. 

 

5.4.4.1. Create step 

The program automatically creates the first step in the analysis under the name Initial Step and the 

procedure (Initial) can be used by clicking on the step manager dialog box, as shown in Figure 

5-38. To create another step, the user can click on Create Step→ then the create step dialog box 

will appear. The user will need to complete the box according to the modeling requirement. The 

program with this addition provides Procedure Type General and Linear Perturbation. Each will 

provide a list of loading cases which can then be selected through scrolling. In this module, the 

aim is to investigate the behavior of the strengthening system under static loading by entering 

information into the dialog box, as shown in Figure 5-38. 
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Figure 5-38: Initial Step 

 

In the Name enter Displacement instead of the default Step -1. Select General from the Procedure 

Type→ and select Static, General → and then click Continue. 

The Edit Step dialog box will appear after clicking on continues. In the edit step box, the name 

Displacement and type Static, General will be generated automatically. In addition, three gates 

will appear in this box, namely Basic, Incrementation and other. For each gate, the values will be 

different from one model to the next. In this tutorial for the basic gate, the value for the Time 

period is entered as equal to 10 and NIgeom will be the mode. The rest should be left as the defaults 

(Figure 5-39). 
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Figure 5-39: Creating Step 

 

The Incrementation gate is the most significant setting in this step, which controls the analysis 

being performed. The incrementation gate will request the user to identify the Maximum Number 

of Increments and Initial, Minimum, and Maximum increment size. In the beginning, the user can 

enter a value and later can change the values in case there are any problems in the analysis. For 

more advanced settings in the step, Other gates can be used, although in most cases it should be 

left without any change. The three gates and their values are shown in Figure 5-40. 

 

5.4.4.2. Create Field Output 

The Create Field Output or Field Output Manager will manage and control the results or outputs 

which are expected from the analysis. ABAQUS provides an option to show the results and select 

exactly what results are required, suggesting the points to obtain the results. 
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Figure 5-40: Edit Step 

 

The program will create F-Output-1 for the Displacement step. When clicking Edit in the Field -

Output Request Manager dialog box, the program will ask the user to identify the following: 

Select the Domain among the many choices as the whole model set (default is the Whole Model). 
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Select the Frequency among the Last increment: Every ‘n’ increment (default is every n increment, 

with n =1). 

Identify the Output Variable and select from the list that is presented: Preselected defaults, All, 

and Edit variables (default Preselected defaults). The program categorizes the output variables into 

certain categories: Stresses, Strains, Displacement/Velocity/Acceleration, Forces/Reactions, 

contact, Energy, Failure/Fracture, Thermal, Electrical /Magnetic, and Porous media/fluids, 

Volume/Thickness/Coordinates, Error indicators and State /Field/User/Time all of the variable 

output categories.  

Activate the Output for rebar (default = not active). 

Activate Including Local Coordinate Directions When Available (default = active). 

From the above output alternate options, the power of ABAQUS can be demonstrated. Also, the 

more complicated the output that is requested, the more time and complex analysis are required, 

and vice versa. From view point, it is advisable to only request the output variable that is required 

(see Figure 5-41). 
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Figure 5-41:Edit Field Output Request 

 

5.4.4.3. Create Field Output 

As previously mentioned, field output and history output follow the same concept and procedures. 

Figure 5-42shows the History Output Manager dialog box and the default Edit Field Output 

Request. In the preselected default for the Output Variables, the only active box shown is the 

energy indicator. This is because the history output is more concerned about the user selecting the 

results more than the default analysis results. After finishing all simulation requirement steps, the 

user returns here to confirm the required result. 
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Figure 5-42: Edit History Output Request 

 

5.4.5. Interaction Module 

To begin defining the different interaction between the instance from the Model Steps, move from 

Step to the Interaction step. A new vertical supporting bar will appear showing new icons related 

to the instruction. 

 

Reinforced Steel Bars + Steel Links with the Concrete Beam: 

From the interaction bar, click on Create Constrain→ a create constraint dialog box appears.  

Enter Steel +Concrete in the Name empty box → then select Embedded region by holding the 

mouse on the Type window → click on Continue. 
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The prompt box will ask the user to Select the Embedded Region (Create Set) →by using 

Assembly Display Option close all the instances except for the steel bars and links, as shown in 

Figure 5-43.Select the steel reinforcement and type Steel Reinforcement as the set name→ when 

finished click Done. 

When asked about the Selection Method for the Host Region choose Select Region. 

Again, in the prompt, it will ask the user to Select the Host Region (Create Set) →which now 

displays the R-C-beam only in the window. Select it → type R-C-Beam as the set name → click 

Done. 

The Edit Constraint dialog box will appear to review the previous choices. To modify the constraint 

parameter uses the default and click on Ok to confirm and finish. 
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Figure 5-43: Create Steel Concrete Constraint 

 

CFRP Racketing Concrete 

The interaction between the CFRP rods and Jacketing concrete is fully embedded. Thus, the same 

procedure is repeated except instead of steel, it will be the CFRP rods, and instead of the concrete 

beam, it will be jacketing concrete, as shown in Figure 5-44. 
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Figure 5-44: Create CFRP jacket Constraint 
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Concrete Beam with the Jacketing Concrete: 

As mentioned, the relation or interaction between the old concrete beam and the new jacketing 

concrete is complicated. The reasons which create this complicated reaction is that the interaction 

between the two concrete surfaces depends on many factors. The type and strength of the original 

concrete beam and the new jacketing concrete will affect this relation. For example, the conditions 

of the bottom concrete surface as void existing and whether the surrounding beam is even at the 

time of casting the jacketing or even after. 

The surface between the original and new jacketing concrete is also important. The debonding 

phenomenon is mostly accrued at this surface, which causes an effective strengthening system. 

Industry practice as it applies to a strengthening the system is when they begin to make pre-

treatment to the tensile side of the reinforced concrete beam. This treatment aims to ensure that a 

completely tied interaction is produced between these two surfaces. From this point in the 

simulation work, the assumption of a full tide surface will be acceptable. To define this interaction, 

follow the subsequent steps below: 

Again, create a new constraint with C-Beam + C-Jacket as the Name and select the Type of 

interaction as Tide. 

In the prompt, the program will ask the user to Choose the master type and provide two options 

Surface and Node Region. Click on Surface. 

The prompt will then ask the user to Select regions for the master surface (create surface...). By 

using Assembly Display Options and View and View Manipulation Bar, the user can select the 
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bottom surface of the original beam as the master surface and give it (the bottom surface) a name, 

then click Done. 

Again, the prompt will ask the user to Choose the slave type either Surface or Node Region. Click 

on Surface type as the previous master surface. 

Use the same tools Assembly Display Options and View and View manipulation Bar to select the 

top surface of the jacketing concrete as the slave surface when the program asks the user to Select 

regions for the slave surface (create surface…).Here in the create surface empty box enter top 

surface and then click Done.  

The Edit Constraint dialog box will appear in the window. Review the Name of the constraint, its 

Type, and the selected surface as the Master and Slave surface. This box also provides the option 

to select among the Discretization method and Position Tolerance. Review and modify or keep as 

the default and click Ok to confirm creating the constraint. 

At any time, the user can review and edit or even create a new constraint by clicking on the 

Constrain Manager icon and from constrain manager dialog box, as shown in Figure 5-45. 
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Figure 5-45:Create C-BEAM and C-Jacket Constraint 

 

5.4.6. Load/Boundary Condition Module 

Up until the previous steps, all concerns have been on defining and identifying the general section 

geometry and its materials and how to define the interaction between the components of the 
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modeling. In this step, the main purpose of the modeling is accomplished in this section. What 

exact output result is needed for each loading configuration, the condition of the assembly, and its 

relationship with other external members will be defined. 

This step is divided into two main sub-steps. The first sub-step is identified as the boundary 

condition of the modeling. The boundary condition reflects the position, direction, and type of 

surrounding support. ABAQUS provides a vast range for the different types of boundary 

conditions to represent the real situation. The value of the boundary condition follows the same 

unit system as defined at the beginning. The second sub-step is defined as the load configuration. 

Different kinds and type of load are applied in order to study the behavior of the system under 

different conditions and to investigate the effect of different variables in this behavior. The 

majority of load kinds and conditions are provided in this program. 

Before starting to assign the boundary condition and load configuration, first locate their position 

by a certain Set, Surface, or even Nodes that are required to be described and to extract the required 

results. This explains the reason for creating many datum planes in a different distance during the 

R-C-Beam part creating process. 
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5.4.6.1. Define the boundary condition 

 From 

 

Figure 5-2, each support is located at a distance 100 mm from the edge of the beam. Five datum 

planes have been previously created along the beam. The pinned support will be located at the 

bottom side of the beam at the first and final datum planes. 

To assign the pinned support and their place, follow the steps below as described below. 

Transfer or move from the interaction step into the Load Step from the scrolling list in the model 

steps. When the load model shows the vertical toolbar, a number of icons will appear. 

From the top bar or vertical toolbar click on the Create Boundary Condition icon → a create 

boundary condition dialog box will appear. In the prompt, it will ask the user to complete the box 

by requesting the name, step, and type of boundary, as shown in 
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Figure 5-46. 

For the Name, enter Support. 

In the Step, by scrolling in the narrow, it will display two steps Initial and Displacement, which 

are already created in the Step Model stage. The boundary starts from the initial step, keep it as 

Initial. 

The program (ABAQUS) will provide different boundary condition Categories. The program 

divides these into four categories, namely Mechanical, Fluid, Electrical and Magnetic, and Other. 

Here select Mechanical. 

After selecting mechanical from the boundary category, several types will be shown. Under Types 

for the Selected Step, many types will be listed. From this list, choose Displacement/Rotation → 

and then click Continue. 
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Figure 5-46:Create Boundary Condition 

 

The program will then ask the user to determine the region to assign the boundary condition. The 

prompt will ask to Select regions for the boundary condition (Create set...). Use the Views 

Manipulation bar to select the bottom edge of the first and the final datum planes, as shown in 

Figure 5-47. Then Create a set for them under the name Support and then click Done. 

The Edit Boundary Condition Dialog box will appear. From this box, review the Name, Type, 

Step, and Region. The control of freedom and release of rotation and displacement of the support 

can be modified from this dialog box. Where U1, U2, and U3are displacement in the X, Y, and Z 

global axis respectively, and UR1, UR2, and UR3 are the rotations of X, Y, and Z respectively. 

For pinned support, there is no constraint for the rotation. Therefore, click on the displacement as 

shown and then click OK. 
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Figure 5-47:Assign and Edit Boundary Condition 

 

5.4.6.2. Define the Loading Configuration 

The loading configuration is in accordance with the ASTM standard, ASTM D6272 - 02 (Standard 

Test Method for Flexural Properties of Unreinforced and Reinforced Plastics and Electrical 

Insulating Materials by Four-Point Bending). 

As shown in 

 

P/2 P/2 

P/2 P/2 

L/4 L/4 Load Span 

L 
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Figure 5-48, one half of the support span will be used to conduct the tests. The clear distance 

between the support will be divided into quarters where each quarter will be equal to 500 mm. The 

loading is according to the ASTM standard and applied at a distance of 500 mm from each support. 

Accordingly, 1,000 mm will be the length of the fix moment value. 

 

 

Figure 5-48: Loading Diagram (one half of the support span) 

 

The loading will apply a distance to the beam at a certain location. The value of this displacement 

is 50 mm. In the Step Module, the displacement step has already been created. To meet the STAM 

Standard, four-point bending, and the displacement is applied in two locations. Each quarter of the 

span for each support will be exactly in the same location as for the datum plane, which is created 

with the R-C-Beam instance; number two and four from either direction. Assign this displacement 

on the 3D modeling as follows: 

P/2 P/2 

P/2 P/2 

L/4 L/4 Load Span 

L 
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Create a set to assign the displacement. The displacement will be applied in two locations on the 

top surface of the R-C-Beam. In case the user did not create the partition and create the set in the 

Create Part, the user needs to do in this step.  

In this case, return to Part → select R-C-beam part →then from the vertical toolbar click on 

Partition Cell. Then select from the horizontal options the method of partition which is Use Datum 

Plane →and the program will then ask to Select the cells to partition. From the window, select the 

beam, and then click Done. Next, the prompt will ask the user to Selecta datum plane. Choose 

either a datum plane; number two or four. Then the program will inform the user that the Partition 

definition is completed and ask whether to create another partition. 

Repeat the same procedure as in the previous point with another datum plane. Figure 5-49 shows 

the procedure to create the partition. 
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Figure 5-49: Create Partition for the R-C-Beam Part 

 

After creating the partition on the beam, define and apply the load on the beam. 

First, return to the Load Model step and again click on Create Boundary Condition but in the 

boundary condition dialog box the Name will be Displacement, and the Step will also be 

Displacement. The rest will be the same as the previous one. The Category will be Mechanical, 

and Types for the selected step will also be Displacement/Rotational. Click Continue. 

The program will then ask the user to Select regions for the boundary condition (Create set…) → 

click on the two new sets which are created at the top surface of the beam→ then at the Create set 

enter Displacement. 
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Figure 5-50: Create Loading 

 

In the Edit Boundary Condition dialog box, review the previous input data and apply the loading→ 

tick at the box next to U2 (displacement in the Y direction) and enter -50in the active box beside 

it. Then click Ok to confirm. 
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The position and the direction of the load will appear in the model, as shown in Figure 5-50. 

 

5.4.7. Mesh Module 

Meshing means dividing a geometry into smaller elements. As long as ABAQUS considers the 

finite element method (FEM) program and all the finite elements depending on one discrete 

element into the member and nodes, this program will divide the assembly and all parts inside it 

into small regular or irregular elements.  

To apply meshing in ABAQUS, the first stage involves creating the parts. The user can 

immediately follow creating the different parts, start to apply the mesh for each part separated. The 

second stage which is recommended is to follow the same order suggested by the program to create 

the meshing after creating the assembly, interaction, step, and load. 

The program provides some indication that will inform the user of the condition of the parts, as 

shown in Figure 5-51, the Mesh Controls dialog box. This box will provide information about the 

available Element Shape and Technique for a certain part. In general, there will be four Element 

Shapes that the user can select depending on the situation of the modeling. These four shapes are 

Hex, Hex-dominated, Tet, and Wedge. In the Technique part, it includes as is, Free, Structured, 

Sweep Bottom-up and Multiple. 

Some parts are presented as samples and are ready to start applying the mesh step directly. 

However, some other parts consider more complicated shapes and need treatment and a partition 

before meshing. The best kind of meshing is when the element is under the Hex shape using the 

structured technique. 
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Figure 5-51: Mesh Control 

 

Another control for meshing is from the Element Type dialog box. Identifying the parameters in 

this box is very important. First, select the Element Library, Standard or Explicit, then select the 

Family. For example, for the standard library it consists of 3D Stress, Acoustic, Cohesive, 

Continuum shell, and so forth. The same will be for the explicit library. Also, in this dialog box, it 

is required to determine the variable for the Element Control even for Hex, Wedge, and the Tet 

shape, (Figure 5-52). 

To begin applying the meshing for all the elements, from the module scroll down to Module Mesh. 

The main bar gate and the vertical support bar will change instantly to the meshing mode. Besides 

the Module Mesh in the bar above the working space, the program will also identify the Model 

and apply meshing to all the assembly or part of it from Objective by clicking in the circle beside 
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each one. There are two types of elements according to the meshing. The R-C-Beam and C-jacket 

will be the first group. The second group will include Steel-bar, Steel-links, and CFRP-Rods. 

 

 

Figure 5-52: Mesh Element Type 

 

The process to apply the mesh is divided into two sequenced steps. The first step involves creating 

the seed for the elements after identifying the mesh control and the element type. The second step 

is creating the mesh and verifying the mesh. Two examples for each group will be explained. 
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R-C-Beam Meshing: 

From Objective click on the circle beside Parts and scroll on C-R-Beam. The beam will appear in 

the working area with a green color, which indicates it is a structured technique. 

From the top bar, click Mesh→ from the sub-Manu click on Controls. 

The prompt will ask the user to Select the regions to be assigned Mesh Controls. In the working 

area assign the beam by creating a window around it then click Done. 

A Mesh Control dialog box will appear with Hex in the Element Shape and Structured with a green 

color on the technique. Then, it is ready for meshing → click Ok. 

Again, from the top bar, click Mesh→ from the sub-Menu click on Element Type. 

In the prompt space, it will ask the user to Select the regions to be assigned and Element Type. In 

the working assign the beam by creating a window around it→ then click Done. 

An element type dialog box will appear → for this beam. Select standard as Element Library and 

3D Stress from the Family. Select Geometric Order as Linear and for Element Control leave as the 

default → click on Ok. 

Click on the Seed Part icon on the vertical supporting bar. 

A Global Seed dialog box will open, and in the prompt, it will ask about Set the data using the 

Global Seeds dialog. Make the Approximate global size as 30, and the rest leave as is. Then click 

Apply to view the seeds or click Ok to confirm and close the dialog box ( 

Figure 5-53). 
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Click on the Mesh Part icon on the vertical supporting bar. In the prompt, it will ask whether it is 

Ok to mesh the part? Yes or No → select Yes. 

The program will create the mesh for this part as the size of the approximate size of a seed, which 

was defined earlier (Figure 5-55). 

To verify the mesh again, from the vertical supporting bar, click on Verify Mesh. Select the beam 

when in the prompt and Select the regions to verify (here provide the level of regions part, 

geometric and element) → then click Done. 

The Verify Box will appear presenting three options: Shape Matrices, Size Matrices, and Analysis 

Checks. Go to the Analysis Checks with Highlight (with the Color Key: The Errors will be pink 

color, and the Warnings will be a yellow color). Also, from the Message Area at the bottom read 

the number of errors and warnings. Here, as shown in the Figure, there are 0 errors and 0 warnings. 

That means that the mesh is ok → click dismiss to close and move to another part for meshing 

(Figure 5-54). 

 

Jacking concrete: 

Jacketing concrete is a concrete element. The procedures applied in the previous concrete beam 

will be the same for jacketing. As mentioned above, this is to make the density or the size of the 

meshing for all elements the same. The same size of the creating seed will be equal to 30.  

Figure 5-56 shows two tables; the left table will be the Element Type dialog box of jacketing 

concrete, and the other one will be the Creating Seed dialog box. 
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  … 

Figure 5-53: Control, Type of Element and Create Seeds 

 

 

Figure 5-54: Create Mesh 
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Figure 5-55: Verify Mesh 
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Figure 5-56: Meshing of Concrete Jacketing 

 

Steel links: 

All the steel members, Steel-Bar and Steel Links are 2D members as long as they are created as 

Wire in the 2D Planner and they are defined as Truss element material having a certain thickness. 

However, the meshing type for these parts will be marginally different. In the Element Type dialog 

box, as shown in Figure 5-57, the family here will be selected as Truss. 

Again, when creating the Global Seed from the global seed dialog box, the Approximate global 

seed will be taken as 20. Then, creating the meshing and Verifying the meshing using the same 

tools which are used in the Concrete Beams. 

 

Steel-bar & CFRP Rods: 
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The steel-bar part and even the CFRP-Rod part both are the same as the steel-link, which is Wire 

in the 2D Planner Elements. The only difference between them is the material assigned to each. 

So, the same steps will be followed. 

Indeed, it is very important to notice here that in both the beam and jacketing concrete the color of 

the elements at the beginning of creating the meshing is a Green color which indicates that it is 

structured and the meshing can be applied. If the color was yellow or dark brown, the situation 

would be different. In this case, the program cannot create meshing directly without treatment that 

is taken by the user, such as partition the elements into smaller elements and so forth. 

Secondly, for the 2D Planner elements, the color was near to Pink (Magenta); however, in this 

case, the meshing was created immediately. In general, creating the mesh in 2D elements is easier 

than creating it in a solid 3D element. 
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Figure 5-57: Meshing of Steel-Links 

 

5.5. Optimization Module 

Here, the force-displacement curve is essential, and the results will help to explain the effect of the 

strengthening system on the RC beam. So, request the output data which will be necessary to create 

this curve. 
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Click on the Create History Output icon → from the dialog box create and enter the name FORCE-

DIS. Then click Continue. 

The Edit History Output Request dialog box will open showing many options. For the case of this 

tutorial, from the Domain select Set→ from Set select the Displacement which has already been 

created. 

From the Output Variable, click the dialog box. Beside Select from the list below and from the 

drop-down list just click on U2 displacement from the Translation and Total Force as shown in 

Figure 5-58 below. 

 

…… 
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Figure 5-58: Create History Output 

 

5.6. Analysis: Job Module 

Although the Job module is considered to be one of the easiest steps from amongst all the steps in 

the modeling procedures, this step is very important because the modeling will be transferred from 

the pre-processes stage into the process stage in this step. Further, this step is considered as a 

station for checking all previous steps starting from creating the parts until creating the meshing. 

If there are any missing or incorrect data, it will be identified in this step. So, the value of this step 

is in relation to checking and reviewing all previous steps. 

The program divides the mistakes into two categories. The first category under the name, Warnings 

provides information regarding incorrect data or any incompatibility assigned about these 
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mistakes. However, in the other category under name, Errors, the mistakes are serious relating to 

the input data, and as a result, the program will stop further analysis, providing the user the chance 

to modify or correct the input files before the program can continue in analyzing the data again. 

To transfer from the mesh module or optimization module to the Job module, and run the job 

analysis, use the same strategy as follows: 

From the module in the menu bar above the working area, this time scroll through the list until the 

Job Module. The main top menu bar and the vertical supporting tools will change immediately to 

the job step.  

At the top of the vertical supporting bar click on create job → a Create Job dialog box will appear→ 

in this box, it will ask for the Name of the job (for example DIS-50mm) and the Source, either the 

model or input file. Keep it as Model 1 and then click Continue. 

An Edit Job dialog box will open. In the Description dialog box enter Displacement → for the rest 

of the variables do not make any changes but keep them as the default → then click OK and the 

dialog box will close. 

Next, click on the icon beside it, which is Job Manager → a job manager dialog box will open with 

the Name of the creating job and its Resource. Type of analysis is full analysis, and the status is 

none. 

 In this box, there are two categories. The first category at the top will contain Write Input, Data 

Check, Submit, Continue, Monitor, Results, Kill, and finally Dismiss which follow the order in 

performing the job analysis. Next, the bottom category includes Create, Edit, Copy, Rename, and 

Delete; all of them related to the analysis of Creating the Job. 
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Start the analysis with the order from the right [vertical order] from the top → click on Write 

Input→ the program will start to generate the data or give a message regarding incorrect data to 

fix ( 

Figure 5-59). 

 

   

        

Figure 5-59: Create and Manager Job 

 

Here the message concerning the constrain which was created previously in the instruction step 

has some problems either the region is deleted or renamed or suppressed. So that means, check the 
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constrain region. In the message, it will ask to Continue Without Correcting the date or No. Click 

on NO as it is compulsory to continue generating the data. 

Return to the Interaction Step and click on Constrain Manager→ the constrain manager dialog box 

will open →start to correct the problematic constraint. 

As mentioned in the message, the problem comes from two constraints C-Beam + C-Jacket and 

Steel-Concrete. Both are related to the R-C-Beam. This error comes from the region that is already 

defined and both constraints have been deleted already as a result of the partition being applied to 

the R-C-Beam in the load step in applying the loading. 

The Partition deleted the old part R-C-Beam and all its sets and surface. A new element namedC-

R-Beam-1 in the assembly will therefore need to be created. 

From the constrain manager dialog box double click on the C-Beam + C-Jacket→ in the message 

dialog box, Click Yes to continue editing the interaction and redefine the regions for this constraint. 

In the Edit Constraint box click on ‘raw’ beside the Host region and by using the Assembly Display 

Option again select the R-C-Beam-1→and create a new set with the name host beam and click 

Done to confirm. 

Repeat the same step for the second error constraint. From the constrain manager dialog box double 

click on Steel-Concrete →in the message dialog box, click on Yes to continue editing the 

interaction and redefine the regions for this constraint. In the Edit Constraint box click on ‘raw’ 

beside Master surface. Using the Assembly Display Option again and View Manipulation select 

all the surface on the bottom ofR-C-Beam-1andcreatea new set named top-side and click Done to 

confirm, as shown in Figure 5-60. 
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Figure 5-60: Correct the Constraint Error 
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After fixing the constraint missing data, return to the Job Manager dialog box. Again, click on 

Write Data and in the message box click Ok to allow overwriting on DIS-50mm → the status of 

the job will change to Check Submitted. 

Click on Monitor to follow the analysis situation. The Monitor dialog box will be opened. In this 

box, the most important parameters are Status, Warnings, and Errors. 

If the status changed to Aborted, that means there is an error which has caused the analysis to stop. 

Open the Monitor Box to discover what the Errors are. If there is an error of 2920, it means the 

elements have missing property definitions. 

This error is common from neglecting to assign the material to one or more of the parts or mistakes 

in creating the mesh for the different parts. As long as a partition was applied for the R-C-Beam 

part that means the previous section assigned on it has already been deleted. 

Go to the Property Step. Here the user will find the R-C-Beam with a gray color, which means no 

materials defined → reassign the section as a Concrete-beam section as shown in Figure 5-61. 
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Figure 5-61: Redefine the Materials for the RC Beam 

 

Next, click on Write Data on the job manager and the status after some time will change to 

completed. The job input file has been written to "DIS-50mm.inp" in the comment area.  

Then, click on the Data Check. 

Finally, click on submit for analysis. This stage will take time according to numerous factors as 

mentioned previously, such as the size and type of the assembly besides the setting for step, 

meshing, loading, and other factors. 

During the period of analysis, follow the processing status from monitoring the dialog box to check 

for any warning or error messages. 
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If the analysis moves smoothly without showing any errors, the status will change to Completed. 

In this case, the Job Step is already completed, and it is the time for the Visualization Step to 

present the results. 

 

5.7. Visualization Module 

The Visualization step is the step in which the simulation will move from the process phase to the 

post-process phase. As discussed earlier in the Step Module, the request for specific results at a 

certain place even set, point or even surface is controlled in the Create Field Output and Create 

History Output. In case there is no specific request for a certain result, the program will provide 

the user with the default results in the whole model. So, with that in mind, in this tutorial, the 

results will be presented as general defaults. 

To transfer to the Visualization Step, there are two ways of doing this. First, after finishing the 

analysis in the previous step from the job manager dialog box, click on results directly, and the 

program will transfer to the visualization step. Alternatively, another way is by scrolling to the 

visualization step from the list beside the module. When the visualization step becomes active, all 

the other bars in the window, even the left window will completely change from the model face 

into the result face for the first time from the start of the work.  

The Field Output Bar will show the results, which are Primary, Deformed, and Symbol. For each 

result, parameters will appear in the modeling. 

To display the maximum and minimum value for each parameter in the main window, from the 

main bar click Viewport→ from the sub-menu click on the Viewport Annotation Option. 
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Select the Legend gate and from the Viewport Annotation Option → click on the empty dialog 

box beside Show min/max values → click on Apply and OK to confirm and exit (Figure 5-62). 

 

 

Figure 5-62: Viewport Annotation Options 

 

The location of the max/min value in the graphical modeling can be determined by the following: 

From the vertical supporting bar click on the contour option icon → the contour plot option dialog 

box opens (Figure 5-63). 

From this dialog box → go to the Limits gate → click on the empty dialog boxes beside Show 

Location for both the max and min values. → Click on Apply and OK to confirm and move to 

another order. 
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Figure 5-63: Contour Plot Options 

 

5.8. Analysis Result 

The stresses can be shown in the primary model by selecting the Primary Model from the Filed 

Output Bar then select stress from the window beside it. From the list sliding window, the user can 

choose the stresses in a different principle direction X, Y, and Z and also the secondary direction. 

Figure 5-64 shows the contour value of the stress S33 in the whole model. Also, in the small box 

at the top right corner, the stress values will appear in different contour colors. Furthermore, at the 

bottom, the maximum values can be seen and also the location at the top middle of the beam. 

However, the minimum stress value will be shown in the support line. 
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Figure 5-64:Distribution of the Stress in the Whole Model 

 

Figure 5-65 shows the value and distribution of the stress for the different parts individually inside 

the module. 

Energy dissipation is another important output result. The energy will reflect the amount of energy 

needed to deform the modeling. The energy can be an illustration in the graph connected to the 

energy dissipation variable with time. To draw this curve, follow the steps below: 

From the top bar click on Result→ from the sub-menu click on History Output. 
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Figure 5-65:Distribution of Stress for Different Parts 

 

A History Output dialog box will open → this box shows many Variable Output results → scroll 

using the mouse and select Total Energy for the Output set: E Total for the Whole Model→ then 

click Plot to draw it in the main window, as shown in Figure 5-66. 
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Figure 5-66: ETotal in the Whole Model 

 

Also, in the results output the user can show the displacement for the whole model under the 

loading by using U displacement in the History Output. Select the displacement in any direction 

U1, U2, and U3 in X, Y, and Z respectively, as shown in Figure 5-67. 
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Figure 5-67: U2 Displacement in the Y Direction 

 

For all previous variables, the program can provide many ways to show the tendency or how these 

parameters change with increase in time or increment. To apply this, select from the main bar or 

the vertical supporting bar, and then click on the Animate: Scale Factor, the Animate: Time History 

or the Animate: Harmonic icons. The program provides the user the flexibility to control and 

modify these Animates, as shown in Figure 5-68. 

 

 

Figure 5-68:Animation Option 

 

The increase in the strength capacity of the strengthened beam is expressed in terms of the Force-

Displacement Curve. Also, by using the same tool, History Output, the program can easily draw 

the change of the displacement with time and also the force with time. Furthermore, the program 
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can create a new curve with whatever parameters are selected. To create a force-displacement 

curve, apply the following steps: 

From the vertical supporting bar click in the Create XY Date → the create XY Data dialog box 

will appear and ask the user to select the Source for the data → click on ODP History Output. 

Again, the History Output dialog box will open and ask the user to select the Output Variable data 

to plot in the program → , for example, click on Total Force Tf2 P1…→ then click Plot → on the 

screen, the program will draw the curve of the time and displacement in the selected set. 

Click on Save As→ a Save As dialog box will open asking the user to provide a Name to the Save 

Operation→ enter the name FORCE-N and click on avg ((XY, XY…)) → Click the box beside 

the Plot curve →then click OK. The average curve for displacement with time will be drawn in 

the main window, as shown in Figure 5-69. 
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Figure 5-69: Average Force-Time Curve 
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The same step is applied as in the previous step but here, change the selection from special 

displacement to Special displacement U2… the name of the average total force curve will be DIS-

mm, as shown in Figure 5-70. 

 

 

Figure 5-70:Average Displacement-Time Curve 

 

To draw the Force-Displacement Curve, which is the most important curve to express the behavior 

of the strengthened beam, again, click on the Create XY Data icon and then click on Operate on 

XY Data. 

The Operate on XY Data dialog box will open → from the right, select the Operation as Combine 

(X, X) → then click on Save Asunder FORCE-DIS. Finally, click on Plot Expression to display 

the curve. (Figure 5-71). 
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Figure 5-71: Force-Displacement Curve 
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Chapter 6: Explosive Loading on A Sandwich Plate 

 

6.1. Introduction 

One of the kinds of problems in structural analysis is regarding the response of the structures to 

the explosion and loading caused by shock. The occurrence of an air blast causes a compressive 

air face that hits structures. Here, the structures absorb some of this energy and reflect the rest on 

the environment. The energy absorbed by the structure causes tension and mechanical strain. 

Depending on the amount of energy absorbed by the structure, which itself is part of the released 

energy from the explosion, parts of the structure can enter the plastic area or even damage 

themselves. 

 

6.2. Problem description 

This example examines the effects of an explosion on a sandwich plate and its deformation. The 

sandwich plate is said to have walls or ceilings that are composed of layers of structures and bound 

to two layers of the sheet on both sides, with a layer of insulation (which in this case can be air). 

A sandwich plate with an external dimension of 120 x 120 cm and a total thickness of 6 cm is 

considered. Whereas they are 1 cm thicknesses at a distance of 6 cm, and the stiffener thickness is 

1 mm. An explosive mass of 0.5 kg TNT is placed at the height of 10 cm in the center of its upper 

plate. The dimensions and specifications of the panel sandwich are shown in Figure 6-1. 
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Figure 6-1: Sandwich plate dimensions 

 

This is also because the air in the middle part of this sandwich plate is considered an ideal insulator 

for many structures. However, on the other hand, it can be vulnerable given relatively low mid-

range stiffness. Hence, considering its impact on shock and sudden loads such as explosion charges 

provides a proper prediction of its behavior in real-world conditions. The sandwich plate made of 

steel and its plasticity depends on the strain rate. Whereas, in high-velocity events, such as an 

explosion, the material deforms in varying rates. 

 

6.3. Objectives 

1) To study explosion loading 

2) To investigate energy varying 

 

6.4. Modeling 

Run Abaqus/CAE from the start menu and close the Start Session dialog box (Figure 6-2). 
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Figure 6-2:abaqus/CAE 

 

6.4.1. Part Module 

At first, the geometry should be defined. In this problem, the geometry consists of two main sheets 

and a stiffener area that should be individually drawn and placed in the appropriate position. The 

plate will be considered as solid and stiffeners as a shell.  

For the simplicity of work, and due to the geometric symmetry and circumferential condition in 

this problem, it was attempted to model one-quarter of it and generalizes to the whole. 
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Double click on Parts in the Model Tree to open the Create Part dialog box. Name the part as Plate 

and set the Approximate size as 2. Do not change any of the other defaults and click Continue to 

enter Sketcher. 

Select Create Lines: [Rectangle]and draw a rectangle. 

Select Add Dimension and determine the plate dimensions as a 0.6x0.6 square. 

Click the middle mouse button twice to open the Edit Base Extrusion dialog box and enter 0.01 

for the Depth. Click Ok to apply, and the dialog box will close (Figure 6-3). 
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Figure 6-3: Creating the plate 

 

Create stiffener: 

Double click on Parts in the Model Tree to open the Create Part dialog box. Name the part as 

Stiffener, then set the shape as Shell and choose the Extrusion as type. Finally set the Approximate 

size as 2. Then, click Continue to enter Sketcher. 

Select Create Lines: [Connected]and draw a vertical line.  

Select Add Dimension and consider the length 0.6. 
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Select Linear Pattern and select the line and click the middle mouse button to open the Linear 

Pattern dialog box. Consider the pattern just in Direction1 and set the Number and Spacing, 9 and 

0.06, respectively and click Ok to make an array of the line. 

Draw a horizontal line and determine the length as 0.6 and distance to the vertical line as 0.06.  

Define the length as 0.6. 

Repeat the pattern for Direction2 and keep the Number and Spacing as mentioned above. 

Click the middle mouse button twice to open Edit Base Extrusion and enter 0.04 for the Depth. 

Then click Ok to apply and close (Figure 6-4).  
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Figure 6-4: Creating stiffener 
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6.4.2. Material Properties 

The sandwich plate is completely made of steel, and its properties are shown in Table 6-1 and 

Table 6-2. 

One of the complications caused by an explosion on structures is the severe amount of damage 

caused and plastic behavior. Hence, in the material properties of this model, elastic and plastic 

behavior along with damage parameters should be considered. 

For damage modeling in soft metals (such as for steel), the definition of ductile damage should be 

defined, which is one of a number of progressive failures. In this method, damage based on the 

strain of plastic equals will be obtained as given in Equation (1). 

 

𝐷 = 𝜀�̅�
𝑝𝑙(𝜂𝜀�̅�

𝑝𝑙)̇      (1) 

 

Where 𝜂 = −
𝑝

𝑞
 stress triaxiality, and P is the pressure applied to each point, q is the amount of 

Von Mises stress, and𝜀̅̇𝑝 is the rate of equivalent plastic strain. 

It is essential to note this point in impact problems that the material model in these issues for plastic 

areas and damage should certainly be a function of the strain rate. 

Also, for damping, Rayleigh Damping was used. In this definition, the damping matrix is 

determined as a coefficient of the mass matrix and stiffness matrix (Equation 2). 

 

𝐶 = 𝛼𝑀 + 𝛽𝐾     (2) 
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Hence, this property is considered in the properties provided for this issue. 

 

Table 6-1 Elasticity and damping properties 

7800𝑘𝑔/𝑚3 Density 

200 GPa Young’s modulus 

0.3 Poisson’s Ratio 

50 Alpha 
Rayleigh damping 

0 Beta 
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Table 6-2 Plasticity and damage properties 

Ductile damage Plasticity 

Strain 

rate 
Stress 

triaxiality 
Fracture 

Strain 
Strain rate Plastic 

Strain 
Yield Stress Strain rate Plastic 

Strain 
Yield Stress 

0.001 -3.33 2.31 1 0 808000000 0 0 776000000 

0.001 -0.333 2.31 1 0.01 842000000 0 0.01 809000000 

0.001 -0.267 2.18 1 0.02 869000000 0 0.02 829000000 

0.001 -0.2 2.06 1 0.03 893000000 0 0.03 842000000 

0.001 -0.133 1.95 1 0.06 946000000 0 0.06 866000000 

0.001 -0.0667 1.85 1 0.1 998000000 0 0.1 883000000 

0.001 0 1.76 1 0.15 1050000000 0 0.15 895000000 

0.001 0.0667 1.67 1 0.25 1120000000 0 0.25 910000000 

0.001 0.133 1.59 1 0.4 1190000000 0 0.4 922000000 

0.001 0.2 1.52 1 2 1490000000 0 2 953000000 

0.001 0.267 1.46 10 0 810000000 0.001 0 791000000 

0.001 0.333 1.4 10 0.01 846000000 0.001 0.01 824000000 

0.001 0.4 1.35 10 0.02 876000000 0.001 0.02 846000000 

0.001 0.467 1.3 10 0.03 901000000 0.001 0.03 863000000 

0.001 0.533 1.26 10 0.06 960000000 0.001 0.06 899000000 

0.001 0.6 1.23 10 0.1 1020000000 0.001 0.1 931000000 

0.001 0.667 1.2 10 0.15 1070000000 0.001 0.15 958000000 

0.001 0.73 1.15 10 0.25 1150000000 0.001 0.25 995000000 

0.001 0.851 1.06 10 0.4 1240000000 0.001 0.4 1030000000 

0.001 1.02 0.945 10 2 1600000000 0.001 2 1170000000 

0.001 1.24 0.816 100 0 812000000 0.01 0 799000000 

0.001 1.51 0.685 100 0.01 850000000 0.01 0.01 831000000 

0.001 3.33 0.202 100 0.02 882000000 0.01 0.02 855000000 

0.001 -3.33 2.31 100 0.03 909000000 0.01 0.03 874000000 

0.001 -0.333 2.31 100 0.06 974000000 0.01 0.06 916000000 

0.001 -0.267 2.18 100 0.1 1040000000 0.01 0.1 955000000 

0.001 -0.2 2.06 100 0.15 1100000000 0.01 0.15 989000000 

0.001 -0.133 1.95 100 0.25 1190000000 0.01 0.25 1040000000 

0.001 -0.0667 1.85 100 0.4 1280000000 0.01 0.4 1090000000 

0.001 0 1.76 100 2 1700000000 0.01 2 1280000000 

0.001 0.0667 1.67 1000 0 815000000 0.1 0 805000000 

0.001 0.133 1.59 1000 0.01 855000000 0.1 0.01 838000000 

0.001 0.2 1.52 1000 0.02 888000000 0.1 0.02 863000000 

0.001 0.267 1.46 1000 0.03 917000000 0.1 0.03 884000000 

0.001 0.333 1.4 1000 0.06 987000000 0.1 0.06 933000000 

0.001 0.4 1.35 1000 0.1 1060000000 0.1 0.1 978000000 

0.001 0.467 1.3 1000 0.15 1130000000 0.1 0.15 1020000000 

0.001 0.533 1.26 1000 0.25 1230000000 0.1 0.25 1080000000 

0.001 0.6 1.23 1000 0.4 1330000000 0.1 0.4 1140000000 

0.001 0.667 1.2 1000 2 1810000000 0.1 2 1390000000 

0.001 0.73 1.15 

0.001 0.851 1.06 

0.001 1.02 0.945 

0.001 1.24 0.816 

0.001 1.51 0.685 

0.001 3.33 0.202 

 

Double click on Material in the Model Tree and open the Create Material dialog box. Define the 

material properties according to Table 1, as shown in Figure 6-5. 

 



288 
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Figure 6-5: Defining the material model 

 

6.4.3. Sections Properties 

It is necessary to put the material properties in corresponding sections. Here, it should be noted 

that two pieces are defined; one is solid, and the other is a shell type. It is necessary to define the 

two sections. 
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Double click on the Sections in the Model Tree to open the Create Section dialog box and name it 

as Plate. Leave Solid as the Category and Homogenous as the Type and click Continue to open the 

Edit Section dialog box. Leave the box unchanged and click Ok to define the section and close 

(Figure 6-6) 

 

     

Figure 6-6: Defining the plate section 

 

Double click Sections and name it as Stiffener, then select Shell as the Category and Homogenous 

as the Type and click Continue to open the Edit Section dialog box. Consider 0.001 as the 

Thickness value and click Ok to apply and close (Figure 6-7). 
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Figure 6-7:Defining the stiffener section 

 

6.4.4. Section assignment 

At this point, the defined sections containing the material data must be assigned to their associated 

parts. 

Double click on Section Assignments underneath of Plate in Model Tree and select the entire plate 

geometry and click the middle mouse button. Then, select the Plate in the Edit Section 

Assignments dialog box and click Ok. 

The same should be performed for the Stiffener part; Plate and stiffener will be recolored (Figure 

6-8). 
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Figure 6-8:Assigning the section 

 

6.4.5. Assembly Module 

Both the Plate and Stiffener should be assembled to form a sandwich plate. First, an instance of 

Plate and Stiffener will be generated. Then, an instance of the stiffener will be located by defining 

a datum point, and then the plate should be copied. 

Double click on Instances underneath of Assembly in the Model Tree to open the Create Instance 

dialog box and select both the Stiffener and Plate parts, and click Ok to add them in the Assembly. 
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Select Tools → Datum and define a datum Point using Offset from the point, and select the vertex, 

as shown in   

      

Figure 6-9. Then, consider 0.06, 0, 0 for the offset from the point to define a datum. 

Select Instance → Translate and select stiffener and click the middle mouse button. Then move 

the instance from the vertex to the datum and click Ok to apply for the new position. 

Select Instance → Linear Pattern and choose plate, then click the middle mouse button to open the 

Linear Pattern dialog box. In the Direction1 box, the click direction icon, then select the Z axis. 
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Consider 2 and 0.05 for the Number and Offset, respectively. Set Number in Direction 2 to 1, 

where it then makes a pattern. In the direction, disable. Finally, click Ok to apply and close the 

dialog box (Figure 6-9). 
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Figure 6-9: Defining the assembly 

 

6.4.6. Step Module 

This case is an example of dynamic analysis given the fast loading change. Abaqus software 

includes two main methods for solving dynamic problems: 

 

Implicit dynamics: 
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In this method, which is used in Abaqus/Standard solver software, the Newton-Raphson process, 

and simultaneous solving equations in each development are used to analyze the problem. In this 

method, the response in each increment is calculated based on the matrix methods and depends on 

the number of degrees of freedom. The required condition for solving the problem is to satisfy the 

equilibrium equations in each increment. In fact, in this process, due to the nonlinear behavior of 

the structure, the load will be applied in an incremental process, so that in each increment, linear 

behavior of the structure is considered. The equilibrium equation for each increment, and for each 

degree of freedom, is defined as given in Equation (3). 

 

𝐹 − 𝑓 = 𝑚�̈�       (3) 

 

Where F is the external force of a node, f is the internal force, m is the mass of the node and �̈�is 

the acceleration of the node. For example, for a model with 120 degrees of freedom (including 20 

nodes, and 6 degrees of freedom per node), the equation of equilibrium will be formed. It is 

necessary to use matrix methods to solve these equations simultaneously and to calculate the 

variables. Depending on the complexity and smoothness of nonlinear behaviors, the number of 

increments may be either high or low. In complex nonlinear problems, many increments need to 

be formed, and if the problem has a large matrix for analysis, it will result in long and expensive 

computations. The speed of the analysis of these calculations highly depends on the hardware 

resources available, although the exact solving of the equations involves high accuracy. The 

implicit method can also be used for static problems in which the right side of Equation 4 is 

considered to be zero. Linear issues are solved in one increment using this method. Given the 
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approach of the implicit solution method for solving equations simultaneously, this method has 

been introduced as a powerful method for analyzing a wide range of problems. 

 

Explicit Dynamic: 

In this method, which is used in Abaqus/Explicit solver software, the equations are solved 

sequentially based on the central difference method, in which the values of the variables in time 

𝑡 + 𝛥𝑡 are obtained based on the values at time t. In the explicit method, the central difference is 

conditionally stable, and this condition depends on stability time. Equations in this method form a 

diagonal matrix, which due to the cost-effective equations to solve simultaneously, is very fast. In 

this method, the size of elements also affects stability times. Also, because of longitudinal 

decoupled matrix solving problems using the method, it does not rely on hardware resources. 

Nonlinearities as large displacements could be implemented in this method, having no complexity 

in analysis. 

An explosion is a type of problem that can be simulated with explicit dynamics and is included in 

Abaqus/Explicit. An explosion happens in a very short time. So, the loading time period here was 

considered as 0.1 seconds and involved the analysis by large displacements due to a large force 

that is produced by the explosion. Note that large displacements mentioned by Nlgeom are 

Nonlinear Geometry in Abaqus. 

Double click Steps in the Model Tree and select Dynamic,Explicit from the Create Stop dialog 

box and click Continue to open the Edit Step dialog box. 

In the Basic tabbed page, enter 0.1 for the time period and set Nlgeom: On. Do not change the rest 

and click Ok to apply the definition and close the dialog box (Figure 6-10). 
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Figure 6-10: Defining step 

 

6.4.7. Outputs 

To better view the simulation solutions, the results should be printed in appropriate intervals in the 

*.Odb file. In the sample, the results will be recorded in 0.0005 seconds; in other words, 200 

intervals are needed for the solution. 

Double click on the F-Output-1underneath of Field Output Requests and in the Model Tree change 

the Interval to 200, and then click Ok to save the change (Figure 6-11).  
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Figure 6-11: Editing field output request 

 

6.4.8. Constraint 

In the next step, plates should be connected to the Stiffener. As this connection is uniform and 

inseparable, there are several methods in Abaqus to define it. One of these methods is Tie 

constrain. In this method, components are connected by determining two surfaces: Master surface 

and Slave surface, so that the Master type is the connection surface that consists of a stiffened 

material model and Slave type is the connection surface that consists of a smoother material model. 

There are no differences between these two levels when the material is similar. Many welding 

joints (if it is not separating) can be modeled in this way. As the stiffener edges could not be 

selected, plates should be hidden to define the constraint. 

Double click Constraints in Model Tree to open the Define Constraint dialog box. Then select Tie 

and click Continue.  

Select Surface from the prompt area in the bottom of the software type of Master and then select 

both inner surfaces of the Plates as the Master surface and click the middle mouse button. Note 
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that for selecting multiple components alternately, the user needs to hold the Shift key down from 

the keyboard. 

Right click on plates underneath of Instances in the Model Tree and select Hide. Upon doing that, 

the plates are hidden, and Stiffener is just shown in assembly. Click the middle mouse button and 

choose Node Region as a type of Slave and select all edges are near the plates. Do not forget to 

hold the shift key on the keyboard. Finally, click the middle mouse button to open the Edit 

Constraint dialog box and click Ok to apply and close. 

Right click on plates underneath of Instances and select Show to make them visible in assembly 

(Figure 6-12). 
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Figure 6-12: Defining tie constraint 

 

6.4.9. Interaction Module 

In this sample, two interactions must be defined. The first interaction, including the definition of 

explosive load and the second interaction, which involves the definition of contact between the 

levels. 
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Explosion: 

The explosion in Abaqus in performed in many ways. The explosion in the air is called Conwep, 

that should be considered. The air blast loading on Abaqus is defined on a reference point. In fact, 

the explosion will start spherically from the point. As mentioned in the problem description, the 

location of the explosive load is at a distance of 100 mm from the middle of the sandwich plate, 

while because of the symmetry, the plates are defined as one-quarter of the original model. Here, 

the explosive load will be at a distance of 100 mm from the corner of one plate. The point should 

be defined as the explosion reference point and Explosion mass considered as 0.5 kg TNT and to 

explode once the analysis begins. 

Select Tools → Datum and define a datum Point using Offset from the point, and select the vertex, 

as shown in Figure 6-13. Then consider 0, 0, 0.1 for the offset from the point and click the middle 

button mouse to define a datum.  

Select Tools → Reference Point and click the point generated earlier (Figure 6-13). 
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Figure 6-13: Defining the explosion reference point 

 

Double click on Interactions in the Model Tree to open the Create Interaction dialog box and select 

Incident Wave and click Continue. 

Select the reference point labeled RP-1 as the location of the explosion mass and click CONWEP 

in the prompt to determine the type of explosion. 

Select all the surfaces affected by the impact of the explosion by dragging the left mouse button 

on them and then click the middle mouse button. Choose Brown/Purple as a side that the explosion 

impacts on; as they are a shell and solid surface mixing, and there is no difference between them. 
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After, select one side, the Edit Interaction box will be opened. To define the explosion property, 

click the Create Interaction Property icon to open the Create Interaction Property dialog box.  

Name the interaction property as Explosion and select Incident Wave as the interaction property 

type and click Continue to open the Edit Interaction Property dialog box. 

Select Air Blast as the definition of explosion and enter 0.5 for the equivalent mass of TNT. Note 

that all parameters in this box are defined in terms of an SI unit system. As the sample was defined 

in the SI unit system, there is no need to change scale factors. Click Ok to define the property and 

close the dialog box. 

In the Edit Interaction dialog box, select Explosion that was recently defined. Then, consider 0 for 

Time of Denotation; no delay in an explosion after the analysis starts. Consider 1 for the Magnitude 

scale factor, which is the explosion load generated equal to the real load. Note that the scale factor 

could scale it. Click OK to define the interaction and close the dialog box (

     



307 
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Figure 6-14). 
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Figure 6-14: Defining explosion interaction 

 

6.4.10. Contact 

At the beginning of the analysis, no contact occurred but caused to the solution progressing, and 

contact will be established. In this case, it is assumed that the coefficient of friction defining the 

tangential behavior, between the surfaces is 0.35. The most convenient way to define all contacts 

having the same property is to use General Contact. This algorithm identifies the contact areas and 

the defined contact behavior for all surfaces. 

Double click on Interactions in the Model Tree and name the interaction Contact. Then select 

General Contact in the Create Interaction dialog box and click Continue. 

Choose the Create Interaction Property icon and name it as Friction. Then, choose Contact, and 

click Continue to open the corresponding dialog box. 

Select Mechanical → Tangential behavior and consider Penalty as the Friction formulation, by 

entering 0.35 for the friction coefficient. Click Ok to define the property and close the dialog box 

In the Edit Interaction dialog box, select Friction, and click OK to apply this definition to all levels 

(Figure 6-15). 
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Figure 6-15:Defining contact 

 

6.4.11. Meshing Module 

At this point, the meshing parts should be developed. In this example, two types of solid and shell 

geometry are defined, and accordingly, two types of elements must be defined. The explicit method 

needs a mesh refinement in order to generate precise results. Since in the explicit dynamic method, 

at least two layers of the element must be defined in each region, and given the plate thickness is 

1 cm, the element size for the entire model should be 0.005. Moreover, the size is considered 

suitable for the Stiffener, and the reason why 8 elements can model the warping effects produced 

as a result of the explosion. 

Double click on Mesh (Empty) underneath the Plate in Model Tree to activate the Mesh Module. 

Select Seed →Part to open the Global Seeds dialog box and enter 0.005 as the Approximate global 

size and then click Apply to set the size and click Ok to close the dialog box. 

Select Mesh → Part and choose Yes in the prompt area to mesh the part (Figure 6-16). 
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Figure 6-16:Meshing plate 

 

Perform the same procedure for the Stiffener (Figure 6-17). 
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Figure 6-17: Meshing stiffener 

 

6.4.12. Boundary Condition Module 

As mentioned earlier, the original sandwich plate model is entirely built-in across all sides. Since 

only one-quarter of the model is defined, appropriate boundary conditions for the middle surfaces 

must be considered. The symmetric boundary condition must be used for two intermediate sides, 

and the clamped boundary condition should be used in the two circumferential sides. 

Double click on BCs in the Model Tree to open the Create Boundary Condition dialog box. Name 

the boundary condition XSymmetry and select Symmetry/AntiSymmetry/ENCCASTRE as the 

type and click Continue. 

Select the two faces parallel to the YZ plane, as well as the edges in their plane and click the middle 

mouse button to open the Edit Boundary Condition dialog box. Select XSYMM and click Ok to 

apply and close the dialog box. 
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Perform the same procedure for a boundary condition named YSymmetry for the two faces parallel 

to the XZ plane and the edges as YSYMM type. Then, define an ENCASTRE boundary condition 

named Fixed for four faces and corresponding edges that form circumferential sides (Figure 6-18).  
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Figure 6-18: Defining boundary conditions 

 

6.5. Analysis: Job Module 

Finally, a job should be defined to submit the model into the solver. 
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Double click on the Jobs in the Model Tree to open the Create Job dialog box. Name it as Explosion 

and click on Continue to open the Edit Job dialog box. Leave the box unchanged and click Ok to 

define the job and close the dialog box. To start the analysis, right click on Explosion underneath 

Jobs in the Model Tree and select Submit to begin the analysis (Figure 6-19). 
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Figure 6-19: Defining the job 

 

6.6. Analysis Results 

In the sample, deformation of the sheet during and after the explosion should be investigated. 

Plastic strain contours on the plates and stiffener are also important in order to predict how they 

will be deformed. PEEQ, the equivalent plastic strain variable represents the regions that are scalar 

and is a good criterion for ductile metal plasticity as defined in Equation 4. 

 

𝑃𝐸𝐸𝑄 =  √
2

3
(𝜀̇𝑝𝑙: 𝜀̇𝑝𝑙)      (4) 

 

Where 𝜀̇𝑝𝑙represents the plastic strain component. This is very important in order to obtain the 

variable in the plates and stiffener separately, and why their result ranges differ. 

Also, displacement, strain energy, and plastic dissipated energy are very important to describe 

sandwich plate behavior by the explosion. All results are stored in *.Odb file and can be extracted 

using the Visualization module.  
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Right click on Explosion underneath Jobs in the Model Tree and select Results to execute the 

Visualization module. 

Select PEEQ from the top to generate its contour. 

Right click on Stiffener underneath Instance in the Results Tree and select Remove to update the 

contour for presenting the variable only for plates. 

Right click on Stiffener underneath Instance in the Results Tree and select Replace to display the 

contour, only for stiffener (Figure 6-20). 
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Figure 6-20: PEEQ contour 
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Double click on the XYData in the Results Tree and select ODB Field Output from the Create XY 

Data dialog box and click Continue to open XY Data from ODB Field Output. In the Variable 

tabbed page, select Unique Nodal from the Position since the displacements are recorded at nodes. 

Select the U3 option for displacement in the Z direction. 

Select the Elements/Notes tabbed page and click Edit Selection, and then choose the node and 

click Done in the prompt area to accept the selection.  

To draw a plot, click the Plot button. As shown in Figure 6-21, the maximum displacement is 7.5 

cm. 
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Figure 6-21:Time history plot of vibration in the sandwich plate center point 
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To extract plastic dissipated energy, double click on the XYData in the Results Tree and select 

ODB History Output from the Create XY Data dialog box and click Continue to open XY Data 

from ODB Field Output. Select Plastic dissipation as the variable that should be plotted and click 

Plot. This diagram will display a loss of energy due to plastic behavior. The maximum plastic 

dissipated energy is estimated to be around 40 kilojoules. 

To extract the strain energy curve, select the same dialog box to select the Strain energy option, 

and click on Plot. The maximum strain energy has increased to 2.7 kilojoules at first, in first. 

However, after the damping, it will decrease to about 1 kilojoule (Figure 6-22). 
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Figure 6-22: Strain energy for whole model 
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Chapter 7: The Impact Load on a Reinforced Concrete Beam 

 

7.1. Introduction 

The importance of analyzing impact is obvious as analysis of the strength of structures such as 

buildings, cars, and ships when obstacles and accidents impact them shows only part of a variety 

of mechanical impact subjects. The impact can be described as one of the most important factors 

which cause a breakdown due to the high loading rate in the impact phenomenon, which causes 

significant inertial forces to occur. Due to the high importance of this phenomenon in industrial 

topics, impact analysis is necessary for designing all structures. 

Reinforced concrete (RC) is a material that is extensively used in civil engineering structures due 

to the compressive strength, low cost, and availability of raw materials. The main purpose of using 

RC is to transfer the tensile forces produced in the concrete into the reinforcements (due to the 

tensile strength of the rebar), so that the tensile forces do not enter into the concrete, causing 

cracking and collapsed concrete. Concrete is often reinforced with steel rebar. 

 

7.2. Problem Description 

In this example, the simulation of the Impact load on a steel-reinforced concrete beam will be 

investigated. The concrete beam is reinforced by longitudinal and transverse bars. 

The concrete beam, as a 30x15 cm cross-section consists of a suitable arrangement of longitudinal 

and transverse bars, so that there is a roller support condition in one side and a hinge condition on 

the other side.A3-kilogram impactor falls on the middle of the beam from a height of two meters 

(Figure 7-1). 
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Figure 7-1:Steel- reinforced concrete beam 

 

The beam is made of 31MPa concrete, and all bars are made of steel, and the yield stress is 

240Mpa. 

 

7.3. Objectives 

1) To study impact simulation. 

2) To study plasticity and damage in concrete. 

3) To investigate progressive damage. 

4) To study reinforcement modelling. 

 

7.4. Modeling 

Run Abaqus/CAE from the start menu and close the Start Session dialog box (Figure 7-2). 
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Figure 7-2:Abaqus/CAE 

 

7.4.1. Part Module 

Geometry should initially be defined. In this problem, the geometry consists of: 

- A rectangular beam. 

 - Two compressive bars with size 8. 

- Two tensile bars with size 12. 

- Twenty-one shear bars with size 8. 
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- A cylinder impactor. 

These should be drawn as parts. As a 3D problem, all components will be deformed due to the 

impact of the impactor, which is assumed as a rigid body. In other words, deformations are small 

compared to the other parts. The beam is considered as solid, and all bars are considered as wire. 

Their variable gradients are more obvious in longitudinal rather than transverse, and this is why 

their lengths are larger than their widths. This means that the problem is cost effective and faster 

to run, with good precision. Cylinder impactor is considered as a rigid shell. 

 

Beam: 

Double click on Parts in the Model Tree to open Create Part dialog box. Name the part as Beam 

and set Approximate size 1. Leave other defaults unchanged and click Continue to enter Sketcher. 

Select Create Lines: [Rectangle]and draw a rectangle. 

Select Add Dimension and determine the plate dimensions as a 0.3x0.15 square. 

Click the middle mouse button twice to open Edit Base Extrusion and enter 2.5 for the Depth. 

Click Ok to apply and close the dialog box (Figure 7-3). 
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Figure 7-3: Creating the Beam 

 

Longitudinal rebar: 

Double click on Parts in the Model Tree to open the Create Part dialog box and name the part 

Rebar Top. Choose a Wire shape and set the approximate sizeto5. Then click on Continue to enter 

sketched 

Select Create Lines; Connected and draw a horizontal line. 
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Select Add dimension and set the length of the line to 2.5. Click the middle mouse button twice to 

extract the line (    
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Figure 7-4). 
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Figure 7-4:Creating an upper longitudinal rebar 

 

To define the lower rebar, there is no need to re-draw them, because the upper and lower bars are 

only different in terms of cross-section, and are the same length. 

Right-click on Rebar Top underneath Parts in the Model Tree and select the Copy, and name it 

Rebar Bottom, and then click Ok (Figure 7-5). 
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Figure 7-5: Creating a lower longitudinal rebar 

 

Shear bar 

For creating a Shear bar, it should be noted that the transverse concrete cover is 3 cm from each 

side of the shear bar. Also, for easier modeling, the arches were ignored on the corners, and an 

angle of 90 degrees will be plotted. This does not affect the solutions. 

Double click on Parts in the Model Tree to open the Create Part dialog box and name the part 

Shear bar. Choose a Wire shape and set the approximate size to 5. Then click on Continue to enter 

sketcher. 
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Select Create Lines; [Rectangle]and draw a rectangle. 

Select Add dimension and set the height and width as 0.24 and 0.09, respectively. Click the middle 

mouse button twice to extract the rectangle (    
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Figure 7-6). 
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Figure 7-6: Creating a Shear bar 

 

Impactor: 

The impactor is a stiffened cylinder that falls on the beam. With regards to the stiffness of the 

impactor, in comparison to the other parts, its deformations have been neglected. In other words, 

the concept of a rigid body can be used to define the impactor. 

A rigid body is a set of nodes and elements whose movement is controlled by the movement of a 

single node which is called the rigid body reference node. 

A rigid body can be defined as an "analytical surface" with a period or depth to a two-dimensional 

geometric cross-section, or as a "discrete rigid body" formed by the mesh of the object from the 

nodes and the elements. The rigid body movement can be determined by applying boundary 

conditions in the reference node of the rigid body. Loading on a rigid body is obtained from the 

load applied to the rigid body reference node. 

The major advantage of models that use a rigid body rather than a deformable finite element is 

computational. The motion of a rigid body is defined only by six degrees of freedom on the 
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reference body of the rigid body. Also, the concentrated loading is located on the reference node 

of the rigid body and loaded on rigid elements. Rigid bodies are used to model hard components 

that are fixed in motion or under the rigid body movement. It is also suitable for modeling tabs 

placed among the components that can be changed. For example, in forming processes, modeling 

tools (such as punches, molds, clamps, rollers, etc.) can be very rigid to solve the problem and 

reduce the volume of computations. 

 

Components of a rigid body: 

The movement of a rigid body is controlled by the movement of a unit node, called the rigid body 

reference node. The rigid body reference node has degrees of translational freedom and degrees of 

rotational freedom and must be defined for each rigid body separately. In each case, the reference 

node should be considered where it is placed on the proper axis of the object. In addition to the 

rigid body reference node, the "discrete rigid body" is composed of nodes formed by the allocation 

of elements and nodes to the rigid body. These nodes which are called Rigid Body Slave Nodes, 

connect to other elements. 

In this sample, a cylindrical impactor is assumed as a half-cylindrical discrete rigid body, that 

should be considered as the Shell, and a reference point should be defined on its center. 

Double click on Parts in the Model Tree to open the Create Part dialog box and name the part 

Impactor. It should be Discrete rigid, a Shell shape and Extrusion type. Set the approximate size 

to 5, and then click on Continue to enter the Sketcher. 

Select Create arc; Center and 2 Endpoints and draw a half-circle. 
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Select Add dimension and set the half-circle radius to0.1.  

Click the middle mouse button twice to open the Edit Base Extrusion dialog box and enter 0.2for 

the Depth and then click OK to apply and close the dialog box (Figure 7-7). 
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Figure 7-7: Creating the impactor 

 

For a rigid body, it needs a reference point defined. This point should be placed in the center of 

impactor’s center line. First, the location of the reference point should be determined by the datum 

point. Then a reference point should define it. 

Select Tools → Datum to open the dialog box and choose a datum Point defined Midway between 

two points. Select two centers of the half circles to determine the midpoint between two points. 
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Select Tools →Reference Point and click on the datum (     

 

      

Figure 7-8). 
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Figure 7-8: Defining the rigid body reference node 

 

7.4.1.1. Material Properties 

In this example, there are two materials used: concrete with a compressive strength of 31MPa and 

steel with a yield stress of 240MPa. Therefore, there are two different material models. Concrete 

is a brittle material in which the compressive and tensile behaviors are different, while steel is a 

ductile material, and its compressive and tensile behaviors are assumed the same.  

Abaqus software introduces different material models for defining concrete properties. The most 

accurate material model for the definition of concrete is Concrete Damaged Plasticity where it will 

be entered in the Plastic flow along with the behavior of pressure plastic, tensile plastic behavior, 



343 

 

and elastic behavior. Also, this model provides the ability to add tensile and compressive damage 

separately. To define this model, concrete compression and tensile behavior should be determined 

from the laboratory test results (or based on equations). The test results show the pressure and 

tensile test for concrete single-axle load (Figure 7-9). 

 

 

Figure 7-9: Tensile (a) and compressive (b) behavior of concrete 

 

The parameters shown in Table 7-1 represent the concrete parameters in the Concrete Damaged 

Plasticity model. 
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Table 7-1 Material constants for concrete 31MPa 

Sign Parameter 

𝜎𝑡 Tensile stress 

𝜎𝑡0 Tensile yield stress 

𝐸0 Young’s modulus 

𝑑𝑡 Damage parameter 

𝜀�̃�
𝑝𝑙

 Tensile equivalent plastic strain 

𝜀𝑡
𝑒𝑙 Tensile elastic strain 

𝜎𝑐 Compressive stress 

𝜎𝑐0 Compressive yield stress 

𝜎𝑐𝑢 Ultimate compressive stress 

𝜀�̃�
𝑝𝑙

 Compressive equivalent plastic strain 

𝜀𝑐
𝑒𝑙 Compressive elastic strain 

 

In this example, the material properties are extracted from the results of the compressive and tensile 

test with a compressive strength of 31MPa.The results consist of elasticity properties, tensile 

behavior, compressive behavior, and plastic flow represented in Table 7-2, Table 7-3 and Table 

7-4. 

 

Table 7-2 Elasticity properties for concrete 31MPa 

Density Poisson's Ratio Young’s modulus 

2400 Kg/m^3 0.2 25 GPa 
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Table 7-3 Plasticity properties for concrete 31MPa 

Tensile Behavior Compressive behavior 

Plastic Strain Yield stress (Pa) 
Damage 

Parameter 

Plastic 

Strain 

Yield stress 

(Pa) 

0 3507692 0 0 9300000 

0.00029 2336335 0.030122 9.38E-05 23003533 

0.00055 1917857 0.155963 0.000752 31000000 

0.000802 1681418 0.620767 0.003394 15791944 

0.001052 1523177 0.796765 0.004959 9632989 

 

Table 7-4 Plastic flow properties for concrete 31MPa 

Viscosity Parameter K Fb0/fc0 Eccentricity Dilation Angle 

0.001 0.667 1.16 0.1 32 

 

Then, mechanical properties for steel should be defined from the tensile test (Table 7-5 and Table 

7-6). 

 

Table 7-5 Elasticity properties for steel 

Density Poisson's Ratio Young’s modulus 

7800 Kg/m^3 0.3 200 GPa 

 

Table 7-6 Plasticity properties for steel 

Plastic Strain Yield stress (Pa) 

0 425000000 

0.21 600000000 

 



346 

 

Double click on Materials in the Model Tree and name it Concrete. Then enter the material data 

according to Figure 7-10. Finally, click Ok to define the material. 
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Figure 7-10: Defining concrete material properties 

 

Again, double-click on Materials in the Model Tree and name it Steel. Then enter the material data 

according to Figure 7-11. Finally, click Ok to define the material. 
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Figure 7-11: Defining steel material properties 

 

7.4.1.2. Section Properties 

It is necessary to introduce a section for each property. These sections include a solid section for 

the beam, a beam section for the shear bar and two truss sections for the longitudinal bars. 
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Double click on Sections in the Model Tree and open the Create Section dialog box. Name the 

section as Concrete_Beam and consider a solid and Homogenous type. Click Continue to open the 

Edit Section dialog box and in the Edit Section box, select Concrete as a Material and click Ok to 

define the section (Figure 7-12). 

 

    

Figure 7-12: Defining a solid section for a concrete beam 

 

Abaqus presents a family of elements under the name of a wire that considers the dispersion of 

nodes along just one dimension, thus reducing the volume of computations in elements will be 

included. It is necessary to note that by minimizing the size of matrices and the degree of freedom 

of the model resulting from the simplification of the model, the assumption of making a more 

precise model and reviewing the model completely in these situations should be considered. If 

these assumptions are not addressed, the response may be uncertain. 

Wire elements are only used in structural modeling, where the dimension of one direction is 

considerably longer compared to the other two. It is possible to ignore variations of the variables 

on the cross-section of the elements. The criterion for using beam elements in component modeling 

is that for ductile metals, where the length of a geometry dimension should be more than 10 times 
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the length of another two dimensions. However, with shell elements, this ratio should be used with 

caution. 

Therefore, in this example, to simulate longitudinal and transverse bars, wire elements can be used, 

and therefore, a smaller volume of computations will be made. Transverse bars will be considered 

as the Beam, and longitudinal bars will be the truss. 

Double click the Sections option and name it ShearBar. Then select Beam as the Category and 

Beam as the Type. This section provides the ability to define flexural, torsional, and shear 

behavior, along with compressive and tensile stress variations. Then click Continue to open the 

Edit Section dialog box. In the dialog box, select Steel as the Material name and click on the Create 

Beam Profile icon to open Create Profile dialog box to define the cross-section of the shear bar. 

Choose Circular as the Shape and click Continue to open Edit Profile. Enter the bar radius as0.004 

and click OK to define the profile. Then, click OK in the Edit Beam Section box to create the 

section (Figure 7-13). 
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Figure 7-13: Defining a beam section for the shear bar 

 

Double click on the Sections and name it as Rebar_Top and consider Beam as the Category and 

Truss as the Type and click Continue to open the Edit Section dialog box. Select Steel as the 

Material name and as shown in Figure 7-14, enter 5e-5 as the Cross-sectional area as given in 

Equation 1. 
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𝐴 = 𝜋(0.0042) = 5𝑒 − 5      (1) 

 

     

Figure 7-14: Defining a beam truss section for the top rebar 

 

Perform the same procedure as Rebar_Bottom for the lower longitudinal bars and enter 1.13e-4 as 

its Cross-sectional area (Figure 7-15). 

 

      

Figure 7-15: Defining a beam truss section for the top rebar 

 

For the impactor, due to the rigidity assumption, it is not necessary to define the section properties 

 

7.4.1.3. Section Assignment 

In the next step, the defined sections should be assigned to their corresponding parts. 



355 

 

Double click on Section Assignments underneath of Beam in the Model Tree, after selecting all 

geometry and click Done in the prompt area. Then select Concrete_Beam in the Edit Section 

Assignments dialog box and select Ok to assign the section (Figure 7-16). 

 

    

Figure 7-16: Assigning Concrete_Beam section 

 

Perform the same for other parts except for Impactor (Figure 7-17).  

It is necessary to note that regarding the non-deformation of Impactor, there is no need to define 

and assign a section for it. 
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Figure 7-17: Assigning section 

 

Assigning beam normal: 

Given that the beam type determines the section of the transverse bars, it is necessary to determine 

the norm of the beam in order to correctly calculate the moment of inertia and the cross-sectional 

orientation. 

In order to determine the angle and position of the beam profile along its length on each link, the 

Abaqus requires the definition of a three-axis coordinate system consisting of two perpendicular 
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vectors to the beam inside the section, as well as a tangent vector. The two normal vectors 

perpendicular to the beam are referred to as n1 and n2 local vectors, known as beam normals, and 

tangential vector on the beam with t, which follow the law of the right hand, as shown in Figure 

7-18. 

 

 

Figure 7-18: n1, n2, and the vectors that determine the position of the profile on a beam 

 

The user determines the direction for the vector n1. Determining the direction of the tangent vector 

t refers to the geometry, and the n2 vector is obtained by using the external multiplication of the 

two vectors in accordance with Equation 2. 

 

n2= t × n1      (2) 

 

It is not easy to determine the beam normal in some applications. Depending on the geometric 

condition of the problem, there are various methods to determine it, but in this example, given the 

exact coordinates are available, this direction can easily be introduced. 

Select the Assign → Beam Section Orientation option and then select the Shear bar entirely by 

dragging it and click the middle mouse button. Accept the default direction (0,0,-1) as the 
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orientation of the n1 vector and again click the middle mouse button to confirm. The red arrows 

shown in Figure 7-19 show the direction of the normal and tangent vectors. Click Ok on the prompt 

area to confirm. 

 

    
Figure 7-19: Determining n1 direction for the Shear bar 

 

7.4.2. Assembly Module 

It is necessary to assemble the model and combine all the parts together correctly. This is needed 

to create instances in the Assembly and to place them at the correct place. For convenience, put 

the steel parts together first, and then, the concrete beam to cover them. 

Double click the Instances under Assembly in the Model Tree to open the Create Instances dialog 

box. Select ShearBar from the box and click Ok.  

Select Instance → Rotate and choose the instance and click the middle button mouse button to 

confirm. 

Select point in the Y direction, as point, for the axis of rotation. 

Accept the angle of rotation as 90o and click the middle button mouse. 
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Select Instance → Linear Pattern and choose shear bar. Then click the middle mouse button to 

open the Linear Pattern dialog box. In Direction1 box, consider 21 and 0.12 for the Number and 

Offset, respectively. Also, set the Number in Direction2 to 1, where it will then produce a pattern 

in the direction disable. Finally, click Ok to apply and close the dialog box (Figure 7-20). 
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Figure 7-20: Creating and positioning the Shear bar instance 

 

Continue to add the Rebar_Top instance by selecting it in the Create Instance dialog box. 

To transfer the upper longitudinal bar to the appropriate location, it is necessary to create a datum 

point at a suitable distance from the longitudinal bar by selecting Tools → Datum and choosing 

Point as the Type and Offset from the point as the Method. 

Select the end of the Rebar_Top and click the middle mouse button and enter 0.05,0,0 as the offset 

and click the middle mouse button again. 

Select Instance → Translate and choose the bar and click the middle mouse button. Then select 

the datum point as the point of the beginning of translate, and select one of the upper corners of 

the first shear bar to fix the rebar to fit in place. 

Perform the same for another Rebar_Top (Figure 7-21). 
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Figure 7-21: Creating and positioning the upper longitudinal bar instances 

 

Perform the same for the two lower longitudinal bars (Figure 7-22). 
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Figure 7-22: Creating and positioning the longitudinal bar instances 

 

From the Create Instances dialog box, click on the Beam and OK to add it to the assembly. 

Rotate the beam as 90 degrees around one of the vertical axes by selecting two points in its 

direction. 

Create a Datum point using Offset from point method, and the upper corner of the beam as 0,-

0.05,-0.05. 
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Translate the beam from the datum point created to the appropriate vertex on the bar (Figure 7-23). 
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Figure 7-23: Creating and positioning the beam instance 

 

Select the Impactor from the Create Instances dialog box and click Ok to add it to the assembly. 

Translate the impactor from the lower point to the middle of the upper edge of the beam. The final 

assembly form is obtained (Figure 7-24). 

 

   



369 

 

       

 

Figure 7-24: Creating and positioning the impactor instance 

 

7.4.3. Step Module 

At this step, it is necessary to define the type of resolution. 

This case is an example of dynamic analysis because many variations in the status of the model 

are created in such a short time. Abaqus software can carry out dynamic solutions in two ways: 

 

Implicit dynamics: 
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In this method, as used in the Abaqus/Standard solver software, the Newton-Raphson process and 

simultaneous solving equations in each development are used to analyze the problem. Using this 

method, the response in each development is calculated based on the matrix method, and 

depending on the number of degrees of freedom, the required interfaces, etc., the computational 

volume is determined in each development. The precondition for solving the problem is to satisfy 

equilibrium equations in each development. Moreover, in this process, due to the nonlinear 

behavior of the structure, the applied load is shattered in the developmental process, so that in each 

process, one can consider the linear behavior of the structure. The equilibrium equation for each 

development and each degree of freedom is defined as given in Equation 3. 

 

𝐹 − 𝑓 = 𝑚�̈�       (3) 

 

Where F is the external force input to the node, f is the internal forces, m is the mass of the node 

and �̈�is the acceleration of the node. For example, for a model with 120 degrees of freedom (with 

20 nodes, and every6 degrees of freedom), the equation of equilibrium will be formed, which will 

necessarily include 120 unknowns. It is necessary to use matrix methods to solve these equations 

simultaneously and calculate the unknowns. Depending on the severity and weakness of nonlinear 

behaviors, the number of develops is considered to be both high and low.  

In complex nonlinear problems, many developments must be developed for a moderately rigorous 

solution, which, if developed in any development, will have a huge matrix for analysis, resulting 

in long and massive computations. The speed of the analysis of these calculations is highly 

dependent on hardware resources, although the exact solving of the equations involves 
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significantly high accuracy. The implicit method can also be used for static problems in which the 

second side of Equation3 is considered to be zero. Linear issues are solved in development using 

this method. Therefore, given the approach of the implicit solution method for solving equations 

simultaneously, this method has been introduced as a powerful method for analyzing a wide range 

of issues. 

 

Explicit Dynamic: 

In this method, as used in the Abaqus/Explicit solver software, the equations are solved 

sequentially based on the central difference process, in which the values of the variables in time 

𝑡 + 𝛥𝑡 are obtained based on the values at time t. In the explicit method of the operator, the central 

difference is conditionally stable, and this condition is the relative diminution of time; the 

sustainability time. Equations in this method form the matrices of the diagonal, due to the lack of 

coupling equations that need to solve them simultaneously.  

Therefore, the software is much more lenient with calculations. In this method, the small size of 

elements with lessen time stability can be more accurate calculations lead, but by calculations 

compact in growth, its dependence on hardware resources is very low, and the behavior of non-

linear as well as models of complex geometric can process Implicitly more effective. Explosion 

issues in Abaqus software can only be carried out via Abaqus/Explicit solver. 

As the example portrays high-velocity impact, as well as material nonlinearities, solving it in 

implicit dynamics is very expensive and time-consuming. Whereas explicit dynamics is the best 

alternative to solve such analysis. Also, since the greatest effects of the falling are noted in the first 

few moments, the solution time is assumed to be 0.2 seconds. 
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Double click on the Steps in the Model Tree and open the Create Step dialog box. Selecta Dynamic, 

Explicit from the box and click Continue to open the Edit Step dialog box. 

Set the Time period to 0.2 seconds and click Ok to close the dialog box (Figure 7-25). 

 

     

 

Figure 7-25: Defining the analysis step 
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7.4.4. Required Output 

All outputs requested by Abaqus are appropriate for the analysis, but compressive damage should 

be added to its list. Also, the output is preferred to be recorded using many time intervals in order 

to produce results. 

Double click on the F-Output-1underneath of Filed Output Requests in the Model Tree to open the 

Edit Field Output Request and enable DAMAGEC from the list of variables. Then, change the 

interval of outputs from 20 to200. This will result in more quality charts (Figure 7-26). 

 

 

Figure 7-26: Editing field output 
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7.4.5. Interaction Module 

In this example, two types of constraints should be used. The first is the Embedded Region type to 

embed the steel bars by concrete. To define the constraint, first, concrete should be hidden, and 

the second is, the Coupling type to couple some nodes of surface/surfaces to a control point. 

To define the embedded region constraint, the beam should be hidden at the beginning. Then, all 

steel bars should be selected as an embedded and re-display beam, and select as the host region. 

To define the coupling constraint in the supports, areas corresponding to the boundary conditions 

should be defined in the Part Module. This is performed by partitioning in this module. Then 

midpoints of each of these surfaces are selected as their control point. Finally, the boundary 

conditions of the hinge and the roller are determined on these points. 

 

Embedded Region: 

Right click on the Beam underneath Instances in the Model Tree and select Hide. 

Double click on Constraints in the Model Tree to open the Create Constraint dialog box and select 

Embedded Region as the Type. Then click Continue. 

Select all the steel bars by dragging them as parts that are embedded in concrete and click the 

middle mouse button to confirm the selection. 

Select the Select Region option from the prompt area as the type of host region. 

Right click on Beam underneath of Instances in the Model Tree and select Show to re-display it. 
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Select Beam as the host region part and click the middle mouse button to open the Edit Constraint 

dialog box. Accept all defaults and click Ok to define the constraint (Figure 7-27). 
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Figure 7-27: Defining the embedded region constraint 

 

Coupling:  

Double click on Beam underneath of Parts in the Model Tree to make it current. Select Tools → 

Partition and choose Face as the Type and Sketch as the Method. Then rotate the beam so that the 

lower face is displayed. Select the face as a sketcher face, and one of the end edges as the sketch 

axis to enter sketcher. 

Draw two rectangles by Create Lines; Rectangle on the face. 

Select Add dimension and determine the width of the rectangles as 0.1 and the distance to the end 

edges as 0.1. 

Click the middle mouse button twice and exit sketcher (Figure 7-28). 
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Figure 7-28: Beam partitioning to make boundary conditions surfaces 
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Select Tools → Datum to define a datum point midway between the two points Method. Click the 

points in the middle of the edges that are created by the partitions. 

Perform the same for another surface (Figure 7-29). 
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Figure 7-29: Defining the datum point in the middle of the surfaces created by partitioning 

 

Select Interaction as the current Module. 

Select Tools → Reference Point and choose both datum points created recently (Figure 7-30). 

 



381 

 

       

   

Figure 7-30: Converting datum points to reference points 

 

Double click on Constraints in the Model Tree and select Coupling in the Create Constraint dialog 

box. Then click Continue. 

Select one of the reference points as a control point and click the middle mouse button.  

Select the Surface as the surface type in the prompt area and click on the corresponding surface. 

Then click the middle mouse button to open the Edit Constraint dialog box. Accept all setting and 

click Ok to define the coupling constraint. 
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Perform the same for another reference point (Figure 7-31). 
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Figure 7-31: Defining the coupling constraint 
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7.4.5.1. Contacts 

Contact will be established when nodes of a surface penetrate the areas between the nodes of 

another surface. The first surface should be stiffened material rather than the second. 

In this example, the contact between the impactor and the concrete beam is evident. However, the 

slip or contact between the internal sections of the beam is almost zero and can be ignored (the 

embedded region constraint removes the possibility of slipping between the reinforcement bars 

and concrete). Contact between the impactor surface and the upper surface of the beam with a 

variable friction coefficient in terms of slip rate and friction coefficients in stationary and moving 

states is given in Equation4.  

   

𝜇 = 𝜇𝑘 + (𝜇𝑠 − 𝜇𝑘)𝑒
−𝑑𝑐̇𝑒𝑞      (4) 

 

Contact will be established when nodes of a surface penetrate the areas between the nodes of 

another surface. The first surface should be stiffened material rather than the second. 

In this example, the contact between the impactor and the concrete beam is evident. However, the 

slip or contact between the internal sections of the beam is almost zero and can be ignored (the 

embedded region constraint removes the possibility of slipping between the reinforcement bars 

and concrete). Contact between the impactor surface and the upper surface of the beam with a 

variable friction coefficient in terms of slip rate and friction coefficients in stationary and moving 

states is given in Equation 5.  
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𝜇 = 𝜇𝑘 + (𝜇𝑠 − 𝜇𝑘)𝑒−𝑑𝑐̇𝑒𝑞 (5) 

Where; 

μ is the equivalent coefficient of friction. 

μk is the friction coefficient of motion. 

μs is the static friction coefficient. 

dc is the coefficient of descent. 

�̇�𝑒𝑞 is the slip rate of the surfaces at each moment of analysis. 

In the example, the surface to surface contact will be applied between the impactor and the upper 

face of the beam so that the outer surface is considered master, given the rigidity and upper beam 

face are considered slave. 

Double click on the Interaction in the Model Tree to open the Create Interaction dialog box. Select 

Surface-to-Surface as a contact type, and then click Continue. 

Select impactor as the first surface and click the middle mouse button. Then from the prompt area, 

choose a color that is related to the outer side (i.e., Brown). 

Select Surface as the type of the second surface and choose the upper face of the beam and click 

the middle mouse button to open the Edit Interaction dialog box. 

Click the Create Interaction Property icon to open its dialog box and choose Contact as the type 

and click Continue to open the Edit Contact Property dialog box. 
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Select Mechanical → Tangential behavior and choose Static-Kinetic Exponential Decay as 

Friction formulation. Enter the formulation parameters, as shown in Table 7-7, and then click Ok 

to close the dialog box. 

Click Ok to close Edit Interaction Property dialog box (Figure 7-32). 

 

Table 7-7 Parameters of Static-Kinetic Exponential Decay formulation 

𝑑𝑐 𝜇𝑘 𝜇𝑠 

4 0.2 0.4 
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Figure 7-32: Defining contact 
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Point mass: 

As this example is a dynamic analysis, the mass of all components must be determined. However, 

due to the definition of density of all of the variable parts, it is not necessary to define an additional 

item for them, except in the impactor. Due to the assumption of rigidity and the impossibility of 

defining the properties of materials for it, the mass must be directly determined for the impactor. 

In this example, the mass of the impactor is 3kg, and the fall height is 5 meters. 

Select Special → Inertia → Create to open the Create Inertia dialog box. Choose Point Mass/Inertia 

and select the reference point of the impactor. Then click the middle mouse button to open the Edit 

Inertia dialog box. Enter 3 for isotropic mass and click Ok to apply and close the dialog box (Figure 

7-33). 
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Figure 7-33: Defining point mass for impactor 

 

7.4.6. Boundary Condition Module 

The beam supports are considered to be roller and hinged. The impactor should be controlled to 

lateral displacement and constraint in translating just in the Y direction and with no rotations. 

 

Hinge boundary condition: 

Double click on the BCs in the Model Tree to open the Create Boundary Condition. Consider 

Displacement/Rotation as the type, and then click Continue. 

Select the reference point on the left side of the beam and click the middle mouse button to open 

the Edit Boundary Condition box. Disable all degrees of freedom by checking them except UR3, 

and then click Ok (Figure 7-34). 
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Figure 7-34: Defining the hinge boundary condition 

 

Roller boundary condition: 

Define the second boundary condition as a Displacement/Rotation type for another reference point 

and disable all degrees of freedoms by checking all components except U1 and UR3 (Figure 7-35). 

 

   

Figure 7-35: Defining the roller boundary condition 

 

Perform the same for displacement/rotation boundary condition for the reference point of the 

impactor and restrain all degrees of freedom except U2 (Figure 7-36). 
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Figure 7-36: Defining the impactor boundary condition 

 

7.4.7. Predefined field 

It is assumed that the impactor has fallen from a height of 5 meters. The impactor's velocity at the 

moment of fall is given by Equation 5. 

 

𝑉 = 2 √5 × 9.81 ≅ 14 𝑚/𝑠      (5) 
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Double click the Predefined Fields in the Model Tree to open the Create Predefined Field dialog 

box and select Velocity as the Type and click Continue. 

Choose the impactor’s reference point and click the middle mouse button to confirm and open the 

Edit Predefined Field. 

Consider -14 for V2 and click OK to apply and close the dialog box (Figure 7-37). 

 

    

Figure 7-37: Defining the predefined field for impactor’s velocity 

 

7.4.8. Mesh Module 

In finite element models, make sure that the meshing size is the same (or approximate) in all 

sectors. In the model, four types of elements are used as: 

- The solid element for Beam. 

- The rigid element for Impactor. 

- Truss element for longitudinal bars. 

- Beam element Shear bar. 
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However, the element size is considered the same. Note: that all the elements used are defined in 

the Abaqus/Explicit solver library. 

 

Beam: 

Double click on the Mesh (Empty)underneath of Beam to activate the Mesh Module and then 

select Seed → Part to open Global Seeds. Set the Approximate Global Size as 0.02 and click Apply 

to display nodes almost positions. 

Select the Mesh→Part and click Yes in the prompt area to mesh the part by using 15,000 elements 

(Figure 7-38). 
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Figure 7-38: Meshing Beam 

 

Impactor: 

Double click on Mesh (Empty) underneath of Impactor in the Model Tree to enter the Mesh 

Module, and set the approximate size to 0.02 and mesh the part (Figure 7-39). 
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Figure 7-39: Meshing Impactor 
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Double click on the Mesh (Empty) underneath of Rebar_Botom and do the same for the Beam, set 

the size to 0.02 

Select Mesh→ Element Type and select the part and click the middle mouse button to open the 

Element Type dialog box. Choose Truss as the Family and as the T3D2element type. Click Ok to 

apply and close the dialog box (Figure 7-40). 
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Figure 7-40: Meshing Rebar_Bottom 

 

Double click on Mesh (Empty)underneath of Rebar_Top and set the mesh size as the same as the 

other components, 0.02 and consider the T3D2 element for it as the Type (Figure 7-41). 
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Figure 7-41: Meshing Rebar_Top 

 



401 

 

Double click on Mesh (Empty)underneath of Shear Bar and set the mesh size the same as the other 

components, 0.02 and consider B31 as the element type in the Beam Family element for it (Figure 

7-42). 
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Figure 7-42: Meshing Shear Bar 

 

7.5. Analysis: Job Module 

In the next step, a job must be defined to solve the problem and then submitted to obtain the results. 

Double click on Jobs in the Model Tree to open the Create Job dialog box and name it as Impact 

and then click Continue to open the Edit Job dialog box. Click Ok to accept all the settings and 

close the dialog box. 

Right click on the job and select Submit to begin the analysis (Figure 7-43).  
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Figure 7-43: Define and submit the job 

 

7.6. Analysis Results 

In this example, the stresses and damage on concrete and stress on longitudinal bars, and the 

displacement time history at the beam’s middle point to the contour of the equivalent plastic strain 

have been requested. Note that all contours included the results at the end of the analysis (at t=0.2 

seconds). 

Right click on the Impact (Completed)underneath Jobs in the Model Tree and click on Results to 

enter the Visualization module.  
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To extract the stress values on the concrete, Right click on the Beam underneath of Instances in 

the Results Tree and select the Replace option to display only the part. 

Then click on the Contours Deformed Shape button to display Von Mises stress distribution on 

the beam, which is at most 18.7MPa (Figure 7-44 ).  

 

    

     

Figure 7-44: Von Mises stress on Beam 

 

Replace four longitudinal bars: 

Because the longitudinal bars only provide the axial stress component, from the list of variables, 

SelectS11. As shown in the legend, the longitudinal stress in the bars is equal to 94 MPa. 

To better display longitudinal bars and their stress along with section sizes, respectively, select 

View → ODB Display Options and check the Render Beam Profile. Then click Ok to display the 

overview with the bar sections (Figure 7-45). 
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Figure 7-45: S11 stress on longitudinal bars 

 

To display all instances, click Replace all (Figure 7-46). 
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Figure 7-46: Replace all components 

 

In the sample, an area of concrete is damaged by the impact on the impactor. As only compressive 

damages were considered, the region could be displayed by the DAMAGEC variable. The 

compressive damage could be up to 0.96, as input material properties. 

Select DAMAGEC from the list of variables (Figure 7-47). 

 

 

Figure 7-47: DAMAGEC on concrete 

 

To plot the beam midpoint displacements during the time, Double click on the XYData in the 

Results Tree and select ODB Field Output from the Create XY Data box and click Continue to 

open XY Data from ODB Field Output. In the Variable tabbed page, select Unique Nodal from 

the Position since the displacements are recorded at nodes. Select U2for displacement in the Y 

direction. Select the Elements/Notes tabbed page and click Edit Selection, and then choose the 
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node placed in the middle of the upper beam face and click Done in the prompt area to accept the 

selection. To draw a plot, click the Plot button. As shown in  

       

 

Figure 7-48, the maximum displacement is about1.2mm. 
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Figure 7-48: Displacement time history 

 

Select the PEEQ from the list of variables to extract the equivalent plaster strain contour (Figure 

7-49). 
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Figure 7-49: PEEQ contour plot 

 

The highest strain of plastic is in the middle of the beam at the point of impact of the impactor, 

which is measured at 0.012. 
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Chapter 8: Eulerian Buckling of Column Under Axial Load 

 

8.1. Introduction 

Buckling can be described as the behavior that normally occurs for pressured members of a 

structure before the maximum compressive strength and before the failure under the influence of 

compression stress. If the column is tall and slender, it will soon be yielded due to the buckling 

phenomenon. The scientific definition of buckling is a type of instability leading to failure. 

For instance, when the structure is under pressure, there is a risk of buckling, which is defined as 

a sudden lateral deflection in a member of the instrument. When the force applied to the structure 

increases like a column, it may be large enough to make the member unstable and is said that the 

structure is under the influence of buckling. The loading will cause much deformation and is 

somewhat unpredictable, which may result in the complete loss of the bearing capacity of the 

member.  

When the load reaches Euler's load, occasionally called the critical load, the column is in instability 

or is unstable. In these conditions, by applying the smallest load, the column suddenly jumps to a 

new state and is buckled. The formula given by Euler is as given in Equation 1: 

 

Pcr =
π2×EI

(Leq)
2      (1) 

 

Where F is the most load or critical load (vertical load in the column), E is Young’s modulus, I is 

representative of the moment of inertia of the column cross-section, and Leq is the equivalent 

length of the column.  
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A short column under axial force may be broken due to maximum stress, plasticity, etc., before 

buckling, but in a long column under the same load, a sudden jump (buckling) to flexion will fail. 

The buckling usually occurs before the axial compressive yield stress. 

 

8.2. Problem Description 

In this example, buckling of a two-ended clamped column under an axial compression will be 

examined, and its result will be checked by Relation 1. Note, that 𝐿𝑒𝑞 for the tow-ended clamped 

column problems such as this column is defined as𝐿𝑒𝑞 = 0.5 * L. The column’s dimensions are 

shown in Figure 8-1. 

 

 

Figure 8-1: Problem dimensions 

 

In this example, Eulerian buckling is considered, and the bar is considered as steel. However, as 

the procedure is linear, all parameters should be stated linearly. Therefore, material properties must 
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be linear in this kind of analysis. So, the material properties limited to Young’s modulus and 

Poisson's ratio are 200GPa and 0.3, respectively. 

 

8.3. Objectives 

1) To study Eulerian buckling. 

2) To investigate buckling eigen solvers. 

 

8.4. Modeling 

Run Abaqus/CAE from the start menu and close the Start Session dialog box (Figure 8-2). 
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Figure 8-2: Abaqus/CAE 

 

8.4.1. Part Module 

At first, geometry should be defined. Considering that the cross-section of the column is less than 

its length, the assumption of Beam elements is valid. So, they should be drawn as Wire. 

Double click on Parts in the Model Tree to open the Create Part dialog box. Name the part as 

Column and choose Wire as the Shape and consider the Approximate size as 10 and click Continue 

to enter Sketcher. 

Select Create Lines: Connected and draw a vertical line. 

Select Add Dimension and determine the line length as 0.2. 

Click the middle mouse button twice to exit the Sketcher, as shown in Figure 8-3. 
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Figure 8-3: Creating a part 

 

8.4.1.1. Material Properties 

The properties of the material, which in this example simply consists of Young’s modulus and 

Poisson’s ratio, need to be entered in the program. 

Double-click on Materials to open the Edit Material dialog box and enter the properties, as shown 

in Figure 8-4. 

 

   

Figure 8-4: Defining the material properties 
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8.4.1.2. Section Properties 

In the next step, it is necessary to define the section. Material properties and profile play a role in 

the stiffness matrix and should be defined at this point. 

As the column is considered as a wire shape, it is necessary to define the beam section. Beam 

sections are provided as two types: Truss and Beam. Here, the truss can just support the axial 

forces, while the beam can support all kinds of forces. As in the example, the column is clamped 

in two ends, and as such, bending moments will occur, So, the section should be Beam/Beam. On 

the other hand, a circular profile must be defined and oriented so that the software can calculate 

inertia.  

Double click on Sections again and name the section as Column. Select its Category as Beam and 

its Type as Beam. Then click Continue to open the Edit Section dialog box. 

To create the profile, click Create Beam Profile to open its dialog box. Select Circular as the Shape 

and click Continue. Then enter 0.01 for Radius and click Ok to define the profile and close the 

dialog box. Circular will be shown in the beam shape box in the Edit Section dialog box. 

Click Ok to define the section and close the dialog box (Figure 8-5). 
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Figure 8-5: Defining the section 

 

Orientation: 

Beam Normals: The theory of beam sections is to calculate the exact stiffness of each element 

that must calculate the moment of inertia. 
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To determine the angle and position of the beam section profile along its length on each link, the 

software requires the definition of a three-axis coordinate system consisting of two vertical vectors 

and a tangent vector on the link. The two vectors are perpendicular to the links and are referred to 

as n1 and n2 local vectors, known as beam section normal, and tangential vector on the link with 

t, which follow the law of the right hand, according to Figure 8-6. 

 

 

Figure 8-6: n1, n2, and t vectors that determine the orientation of the profile on a beam element 

 

Among other things, the direction of vector n1 is determined by the user. Abaqus will determine 

the t vector, and the n2 vector is obtained by the right-hand law as expressed in Relation 2. 

n2=t × n1      (2)  

It is not easy to determine the normal values of the beam elements in general conditions, and 

depending on the geometric condition of the problem, there are various methods. However, in this 

case, the column is completely vertical, so the direction can easily be introduced. 

To determine the normal of the column, select Assign→ Beam Section Orientation, and then 

choose the column and click Done in the prompt area. By doing this, there is a possibility to define 

the approximate direction of vector n1, which can be used as the default vector (0,0,-1). The red 

colored arrows 1 and 2, t represents the normals and tangent vectors. Finally, click Ok in the 
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prompt area to assign the beam section orientation (  

 

 

Figure 8-7). 
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Figure 8-7: Assigning an orientation 

 

8.4.1.3. Sections Assignment 

It is necessary to assign the section for the column. 

Double-click on Section Assignments underneath of the Column and select all the geometry. Then, 

click Done in the prompt area to open the Edit Section Assignment box and click Ok to assign the 
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section to the part and close the dialog box (   

 

Figure 8-8). 

 

   

Figure 8-8: Assigning the section 
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8.4.2. Assembly Module 

In the next step, the assembly should be defined. Although there is one part, the assembly should 

be defined, why all degrees of freedom defined in the module. 

Double-click on Instances underneath of Assembly to open the Create Instance dialog box. Select 

Column and click Ok to add it into the assembly and close the dialog box (Figure 8-9). 

 

 

Figure 8-9: Creating a column instance 

 

8.4.3. Step Module 

In the next step, the procedure type should be defined. Abaqus offers two methods for eigenvalue 

extraction in buckling analysis: Lanczos and Subspace. 

The Lanczos method is more suitable and cost-effective when a large number of buckling 

eigenmodes is requested, especially for a system having many degrees of freedom. However, the 

Subspace method is faster and more efficient for extracting a few buckling eigenmodes.  
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For both methods, the user should determine the number of eigenvalues requested. Abaqus will 

choose a suitable number of vectors for the subspace method or suitable block size for the Lanczos 

method. 

Note that the most important eigenvalue and its corresponding mode shape is the first one. This is 

the minimum critical force and most unstable mode shape, which is more likely to occur. However, 

for the goals of this tutorial, extracting 10 eigenvalues are intended. So, both methods can be used. 

However, the subspace method will be chosen. In the method, after specifying 10 for the number 

of eigenvalues, Abaqus will consider 18 vectors in extracting the number of eigenvalues and the 

corresponding mode shape. 

Double click on Steps in the Model Tree to open the Create Step dialog box. From the Linear 

Perturbation procedure, select Buckle and then click Continue 

Chose Subspace as the Eigen solver and consider 10 for the Number of eigenvalues requested. The 

Vectors used per iteration will be updated to 18 that is sufficient for the problem. Leave the other 

parameters unchanged and click Ok to define the analysis step (Figure 8-10). 
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Figure 8-10: Defining the analysis step 

 

8.4.4. Boundary Condition Module 

In this example, the column is clamped in two ends, while carrying an axial force that caused 

buckling. 

Double click on BCs to open the Create Boundary Conditions dialog box. Then select 

Displacement/Rotation as the Type and click Continue. 

Select the vertex located at the lower end and then click Done in the prompt area to open the Edit 

Boundary Condition dialog box. Check all degrees of freedom. This means the end cannot translate 

or rotate, the means clamped. Finally, click Ok to define the boundary condition. 

Perform the same step for the vertex located at the upper end and check all degrees of freedom 

except U2, and the axial force will be applied to the end and in the y-direction (Figure 8-11). 
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Figure 8-11: Defining boundary conditions 

 

8.4.5. Load Module 

In the next step, a concentrated force at the upper end should be defined. Note that the force cannot 

be caused due to buckling. However, the critical force is a multiplier of this load, which means 

that the eigenvalues obtained by the analysis are multiplied by this value. Therefore, for ease, the 
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force value will be considered as 1, and the direction must be y in any other direction so that no 

buckling will occur. 

Double click on Loads in the Model Tree to open the Create Load dialog box. Chose Concentrated 

force as the Type and click Continue. 

Select the vertex at the upper end and click Done in the prompt area to open the Edit Load dialog 

box.  

Enter -1 for CF2 as the multiplier for the eigenvalues that will be obtained. This relates to the force 

that is compressive in the y-direction. Finally, click Ok to accept the changes and close the dialog 

box (Figure 8-12). 
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Figure 8-12: Defining load 

 

8.4.6. Mesh Module 

It is important to discretize the model with a small enough element size, while the element size 

should not be less than the profile dimension of 20mm. This seems enough to consider 20 mm as 

the element size. In that way, 10 elements will be generated.  

Double click on Mesh (Empty) underneath of Column in the Model Tree to enter the Mesh module. 



429 

 

Select Seed → Part to open the Global Seeds dialog box and enter 0.02 for Approximate Global 

Size and click Ok to define the seed and close the dialog box. 

Select Mesh → Part and click Yes in the prompt area to mesh the part by 10 elements (Figure 

8-13).  
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Figure 8-13: Meshing 

 

8.5. Analysis: Job Module 

In the next section, a job should be defined and submitted.  

Double click on Jobs in the Model Tree to open the Create Job dialog box. Name the job as 

EulerianBuckling, and then click Continue to open the Edit Job dialog box.  

Leave the parameters unchanged and click Ok to define the job and close the dialog box. 

Right click on EulerianBuckling underneath of Jobs in the Model Tree and select Submit to begin 

the analysis (Figure 8-14). 
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Figure 8-14: Defining and submitting the job 

 

8.6. Analysis Results 

In buckling analysis, the main goal is the critical load and mode shape determination. Fortunately, 

in the example, the first eigenvalue (first critical force) could be compared easily with the theory 

of Eulerian buckling, as mentioned in Relation 1.  

Right click on EulerianBuckling (Completed) underneath of Jobs to enter the Visualization 

module.  

Select Result → Step/Frame to open its box. The 10 eigenvalues ascending are extracted. The 

eigenvalues show the critical buckling force, and the first one is 1.55064e6. Select this eigenvalue 

and click Ok to close the box. 

Click Plot Contours on the Deformed Shape icon to display the corresponding buckling mode 

shape (Figure 8-15).  
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Figure 8-15: The first buckling eigenvalue and the corresponding mode shape 

 

At this stage, the eigenvalue should be checked with the value obtained by Relation 1. The buckling 

critical force for the example according to Relation 1 is obtained as shown below, that is matched 

with the one obtained by Abaqus (1550640). 

𝑷𝒄𝒓 = (𝜋2 ∗ 200 ∗ 109 ∗
𝜋

4
∗ 0.014)/ (

1

2
∗ 0.2)

2

= 1550314 𝑁  

Usually, when the loading is applied gradually, the structure will fail at the first buckling 

eigenvalue. However, other eigenvalues will arise when the force is increased suddenly or when 

large forces are applied to the structure instantaneous. This means that if the applied load exceeds 
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the first eigenvalue, it may be safe until it reaches the next critical buckling force. However, other 

eigenvalues and corresponding mode shapes should be checked. 

Select Result → Step/Frame to open its box again and chose the second eigenvalue and click Apply 

to display the mode shape. This is similar to the first eigenvalue but in the yz plane (Figure 8-16). 

 

 

Figure 8-16: The second eigenvalue and its mode shape 

 

Perform the same for the third and fourth, and then the fifth and sixth eigenvalues. As can be seen, 

the eigenvalues are the same two by two. This is because of the same boundary conditions and 

loading in the xy and yz planes (Figure 8-17). 
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435 

 

 

Figure 8-17: Third, fourth, fifth and sixth eigenvalues and their mode shapes 

 

This figure shows that the more buckling critical forces, the more folds in the column. This is also 

true for most sections, such as boxes and pipes.  
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Chapter 9: Post Buckling analysis Of Steel plate shear wall 

 

9.1. Introduction 

Buckling is a bifurcation problem. Structure behavior after buckling is known as Post Buckling. 

Post Buckling analysis, known as the analysis of deformation after buckling, helps to simulate 

what will occur if the structure load gets too high. This is a kind of nonlinear analysis that is 

unstable and occurs in a very short amount of time, while the amount of deformation is high. Figure 

9-1 shows three possible post-buckling solutions. 

 

 

Figure 9-1: Post-buckling solutions 

 

With linear buckling, just the critical load will be defined. In many cases, ensuring safety against 

reaching the critical buckling load is sufficient. In this case, linear buckling study may be 

sufficient, but sometimes, full deformation history of a structure under physical loading is needed. 

The analysis includes deformation after buckling called Post Buckling analysis. 

To perform a post-buckling analysis, the structure should be loaded incrementally after the 

structure has buckled. 
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9.2. Problem Description 

The problem consists of a simple two-story frame that contained a steel plate shear wall, as shown 

in Figure 9-2, in any level and sections are shown in Figure 9-3. The frame is exposed to a uniform 

and incrementally load produced by a hydraulic actuator in the left end of the top beam. Due to 

opening the actuator, the frame is deflected, and the steel plate shear wall will be buckled. In the 

sample, the main goal is investigating buckling and post-buckling. 

 

 

Figure 9-2: Steel Plate shear wall dimensions 
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Figure 9-3: W310x60 (a) and W310x118 (b) in mm 

 

All components are welded together, and the lower edges of the columns and the lower edge of 

the lower plate are cantilevered. Also, the beams are restricted to move in the plane, and the top 

beam is prevented from moving vertically. The components are made of structural steel, in which 

their mechanical properties are displayed in Table 9-1. 

 

Table 9-1 Structural steel mechanical properties 

7800𝑘𝑔/𝑚3 Density 

200GPa Young’s modulus 

0.3 Poisson’s Ratio 

Plastic Strain Yield Stress 

Plasticity 0 275MPa 

0.1 370MPa 

 

In the sample, post-buckling analysis of the shear wall is considered. Therefore, this needs to be 

defined in two analysis steps. 
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In performing the first analysis, an eigenvalue buckling analysis should be performed with 

Abaqus/Standard on the “perfect” structure to establish probable collapse modes and write the 

eigenmodes in the default global system to the results file as nodal data. 

In performing the second analysis, run Abaqus/Standard to introduce an imperfection in the 

geometry by adding buckling mode to the “perfect” geometry. The lowest buckling modes are 

often assumed to provide the most critical imperfections. Usually, these are scaled and added to 

the perfect geometry to create the perturbed mesh. 

These steps should be defined in separate models. Therefore, the sample should be simulated in 

two models. 

 

9.3. Objectives 

1) To study the implementation of buckling modes to subsequent analysis. 

2) To investigating post-buckling analysis. 

3) To study imperfection modelling. 

 

9.4. Modeling 

9.4.1. Part Module 

Run Abaqus/CAE from the start menu and close the Start Session dialog box (Figure 9-4). 
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Figure 9-4: Abaqus/CAE 

 

For simplicity, it is assumed that all components are welded and considered as one part. On the 

other hand, given that the thicknesses of all components are much less than the other dimensions, 

shell elements are more efficient to use as they provide nodes just in one layer and are more suitable 

to calculate buckling mode shapes. 

First, the columns should be drawn, then beams will be added to the structure, and finally shear 

walls should be defined. 

Double click on parts in the Model Tree and open the Create Part dialog box. Name the part as 

Shear Wall and select Shell as the Shape and Extrusion as the Type. 
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Set the Approximate size as 10 and click Continue to enter Sketcher. 

Select Create Lines: Connected and draw arbitrary an “I” section. Try this with 5 lines. 

Choose Add Constraint and make the flanges of Equal length. 

Click Add Dimension and set the flanges and web length, as illustrated in Figure 3(b). 

Select Horizontal Construction Line and draw a horizontal line in the bottom of the sketch. Set the 

distance between the lower flange and the line to 1.368 using Add Dimension. 

Click Mirror and select Copy from the prompt area. Then choose the horizontal line as a mirror 

line and then, select all 5 lines as mirror entities. Finally, click on the middle mouse button to 

perform the mirror. 

Consider 3.66 as the Depth in the Edit Base Extrusion dialog box and click Ok to create the part 

and close the dialog box (Figure 9-5). 
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Figure 9-5: Design columns 
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To define the upper beam, select Shape → Shell → Extrude, and choose one of the outer column 

flanges as the sketch plane and one of the right column edges as the sketch reference edge to enter 

sketcher once again. 

Using Create Lines: Connected draw the I section and set the flanges and web length using Add 

Dimension. Note that the upper flange of the beam should be aligned on the top edge of the column. 

Perform the same for the lower beam and draw a section, and then set the dimensions. 

Double click the middle mouse button to open the Edit Extrusion dialog box. Consider 3.364 as 

the Depth. Note the red arrow; it shows the extrusion direction. Use Flip if the opposite direction 

is needed. Finally, click Ok to close the dialog box (   
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Figure 9-6). 
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Figure 9-6:Design beam 

 

To define plates, select Shape → Shell → Planar, and choose one of the column webs as the sketch 

plane and one of the upper horizontal edges as the sketch reference edge to enter sketcher again. 
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Using Create Lines: [Rectangle] draw a rectangle so that its two corners are aligned on two inner 

corners of the frame.Double click on the middle mouse button to finalize the part definition (
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Figure 9-7). Note that the shear wall will be rotated by 90 degrees in the assembly module. 
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Figure 9-7: Defining plates 

 

9.4.2. Material Properties 

In the next step, material data should be defined. Mechanical properties are already determined, as 

shown in Table 1. 

Double click on Materials in the Model Tree and Select General → Density and enter 7800 for 

Mass Density. 
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Select Mechanical → Elasticity → Elastic, and enter 200e9 for Young’s Modulus and 0.3 for 

Poisson's Ratio. 

Select Mechanical → Plasticity → Plastic, and enter Yield Stresses and corresponding Plastic 

Strains, as shown in Figure 9-8. 
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Figure 9-8: Defining mechanical properties 

 

9.4.3. Section Properties 

The shear wall is assumed to be homogenous, meaning that material properties are the same in all 

regions, but the thickness is different in components. This means that different sections should be 

defined for different components, according to Figure 9-2 and Figure 9-3. 

Double click on Sections in the Model Three to open the Create Section dialog box. 

Name the section Column_Web and select Shell, Homogenous, and click Continue. Enter 0.0119 

as the Shell thickness and click Ok to define the section. 

Perform the same for other sections and name them Column_Flange, Beam_Web, Beam_Flange, 

and Plate and set their corresponding Shell thickness as 0.0187, 0.0075, 0.0131, and 0.0045, 

respectively. Accept the default setting, as shown in Figure 9-9. 
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Figure 9-9: Defining sections 

 

9.4.4. Section Assignment 

At this point, the defined sections should be assigned to the geometry. In shell elements, nodes are 

placed on a surface called the reference surface. This surface is by default the middle of the shell's 

thickness. In other words, what is plotted on the shell geometry in the Abaqus/CAE software is the 

reference surface, by placing half thickness on each side of the surface. This process of extending 

thickness on geometry is appropriate in most cases, but in some cases, it is possible to change the 

surface of the surface according to the location. Figure 9-10 shows a schematic of the positions of 

the reference surface. 



455 

 

 

 

Figure 9-10: Reference surface positions 

 

In the sample, for section assignments in the column web, beam web, and shear wall, the moving 

reference surface is not required. However, for flanges, according to the element normal, the 

reference surface should be moved. So, before assigning sections to them and the moving reference 

surface, it is necessary to determine element normal on the flanges and then assign the section. 

Double click on Section Assignments under Shear Wall in the Model Tree. Then, hold down the 

shift key on the keyboard and select two column webs and click the middle mouse button to open 

the Edit Section Assignment dialog box. Choose Column_Web and click Ok to assign the section 

to the component and close the dialog box. 

Perform the same for assigning Beam_Web and the Plate section to the associated components 

(Figure 9-11).  
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Figure 9-11: Assigning section to column, beam web and plate 

 

In the next step, Element normal should be determined and known. This is necessary for normal 

directions that are similar in every flange. For the convenience of modeling, flip sides so that the 

opposite sides of the flanges have the same color(normal) and the sides of the internal flange are 

brown. 

Select Assign → Element Normal to Abaqus and determine shell element normal direction by 

colors. Sides that are normal and outward are shown by the color brown and sides that are normal 
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and inward are shown by the color purple. Flip normal for the sides, as shown in 
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Figure 9-12 by holding down the shift key on the keyboard and selecting them. Then click Done 

in prompt area. 

    

   

Figure 9-12: Changing element normal 
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Finally, flange sections will be assigned. Reference surfaces should be moved according to the 

flange normals. 

Double click on Section Assignments under Shear Wall in the Model Tree. Then hold down the 

shift key on the keyboard and select four column flanges and click the middle mouse button to 

open the Edit Section Assignment dialog box. Choose Column_Flange as the section name and 

Bottom surface as the Shell offset definition. Finally, click Ok to assign the section to the 

component and close the dialog box. 

Perform the same for the beam flanges by assigning a Beam_Flange section (Figure 9-13). 
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Figure 9-13: Assigning section to column and beam flange 

 

9.4.5. Assembly Module 

At this point, the model should be defined in the computational space defined in the assembly. 

First, an instance of Shear Wall should be created, and then for the convenience of further 

modeling, it is needed to rotate as a column vertically located. 

Double click on Instances under Assembly to open the Create Instance dialog box. Click Ok to 

add Shear Wall instance in the assembly and close the dialog box (Figure 9-14). 
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Figure 9-14: Defining Shear Wall instance in the assembly 

 

Select Instance → Rotate, choose Shear Wall instance and click Done in the Prompt area. In the 

next step, two points that define the axis of rotation should be chosen. Select two points as shown 

in Figure 9-15, respectively and accept 90 as the Angle of rotation by clicking the middle mouse 

button. 
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Figure 9-15: Rotating the Shear Wall 
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9.4.6. Step Module 

In the next step, the lowest buckling mode as the critical mode should be determined. There are 

two eigenvalue extraction methods: 

 

Lanczos and Subspace: 

The Lanczos method is generally faster when a large number of eigenmodes is required for a 

system with many degrees of freedom. The subspace iteration method may be faster when only a 

few (less than 20) eigenmodes are required. 

In some structures, the first, lowest buckling mode, corresponding to the minimum buckling force, 

is needed to run post-buckling analyses. However, in the current sample, as the structure consists 

of 2 stories, the eigenmodes are separated for every story. This is important to extract the main 

buckling mode in every story. As 4 eigenmodes are enough to export buckling modes, the 

Subspace eigen solver is the cost-effective and better choice. 

Double click on Steps in the Model Tree and select Linear Perturbation as the Procedure type and 

choose Buckle as the step type, then click Continue. 

Consider 4 as the Number of eigenvalues requested, while Subspace chosen as the Eigen solver. 

Enter 20 as the Vectors used per iteration and click Ok to apply and close the dialog box (Figure 

9-16). 
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Figure 9-16: Defining the analysis step 

 

Coupling constrain: 

This is necessary to define a point as the actuator support. The point should control the behavior 

of the corresponding part of the left column. Therefore, the left flange of the column must be 

partitioned, and then a reference point should be defined as the coupling control point of the flange. 

Activate Part from the Module list. Select Tools → Partition to open the Create Partition dialog 

box. 

Choose Face as Type and Sketch as a Method of partitioning. 

Hold the shift key and select the lower flange as faces to partition and then click the middle mouse 

button. 

Choose the lower edge as a vertical edge in the sketch to enter sketcher. 
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Select Create Lines: Connected and draw 2 lines and connect the vertices to the right and left 

edges. 

Double click on the middle mouse button to exit sketcher (Figure 9-17). 
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Figure 9-17: Defining a partition face 

 

In the next step, a reference point as a coupling control point should be defined 

Activate Interaction from the Module list. Select Tools → Reference Point and choose the point 

shown in Figure 9-18. 
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Figure 9-18: Defining a reference point as a coupling control point 

 

In the next step, the coupling constraint should be defined through following steps: 

Double click on Constraints in the Model Tree to open the Create Constraint dialog. Select 

Coupling from the list and click Continue. 

Select the reference point as the constraint control point and select Done in the prompt area. 



469 

 

Choose Surface as the constraint region type and hold down the shift key on the keyboard and 

select the corresponding faces that were generated by recent partitioning. Then, click Done in the 

prompt area. 

Click Flip a face in the prompt area, then select the brown flange to flip it. Finally, click Purple in 

the prompt area to choose the faces as the constraint region and open the Edit Constraint dialog 

box. Keep all default settings and click Ok to apply the constraint and close the dialog box (Figure 

9-19). 
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Figure 9-19: Defining coupling constraint 

 

9.4.7. Boundary Conditions Module 

In the sample, there are three boundary conditions. The first is about the clamping lower edges. 

The second is the enforced displacement at the top of the left column, and the third is about the 

restraint top beam and the lower beam web into the out of plan direction. 

For defining the clamping boundary condition, all degrees of freedom must be eliminated from the 

region. 
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Double click on BCs in the Model Tree to open the corresponding dialog box and select 

Symmetry/Antisymmetry/Encastre as a type and click Continue.  

Hold the shift key on the keyboard and select all lower edges. Then click the middle mouse button 

to open the Edit Boundary Condition dialog box. Constrain all DOF by toggling on ENCASTRE 

and click Ok to apply and close (Figure 9-20). 

 

 



472 

 

 

Figure 9-20: Defining clamped boundary condition 

 

For defining the enforced displacement boundary condition, translation along X and Z, and rotation 

around Y and Z should be restrained. Consider -1 as an enforced displacement in the opposite 

direction of Z. The critical buckling displacement will be calculated as a multiplier of this value. 

Double click on BCs in the Model Tree to open the Boundary Condition dialog box and select 

Displacement/Rotation as a type of boundary condition and click Continue.  

Select the reference point and click the middle mouse button to open the Edit Boundary Condition 

dialog box, and then fill out the box, as shown in Figure 9-21. Finally, click Ok to apply the 

boundary condition and close the box. 
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Figure 9-21: Defining the enforced displacement boundary condition 

 

For defining the third boundary condition, note that all beam webs are restricted to movement in 

the y-z plane. On the other hand, the top flange of the top beam was tied up to a strong structure 

to limit its movements in the y-z plane. For defining he boundary condition: 

Double click on BCs in the Model Tree and select Displacement/Rotation as a type of boundary 

condition in the corresponding dialog box, then click Continue. 
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Select the beam webs and upper flange of the top beam and click the middle mouse button to open 

the Edit Boundary Condition dialog box. Then check U1 and click Ok to apply and close the dialog 

box (Figure 9-22). 

 

     

Figure 9-22: Defining the third boundary condition 

 

The fourth boundary is about restraining the top flange of the upper beam in the plane. So vertical 

movement for the top beam should be removed: 

Double click on BCs in the Model Tree and select Displacement/Rotation as a type of boundary 

condition in the corresponding dialog box, then click Continue. 

Select the upper flange of the top beam by holding the shift key on the keyboard and click all 

portions. Finally, click the middle mouse button to open the Edit Boundary Condition dialog box, 

and then check U2. Click Ok to apply and close the dialog box (Figure 9-23). 
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Figure 9-23: Defining the boundary condition for the top flange 

 

In the next step, meshing should be defined. This is very important to choose a suitable element 

size in finite element simulations. For shells, the element size cannot be considered as small as 

desired. The length of the shell elements is not recommended to be less than their thickness. On 

the other hand, each shell should have at least two elements in any direction (except thickness). 

Therefore, in the sample, the mesh size is suggested as 5 cm for all components. 

Double click on Mesh(empty) underneath of Shear Wall in the Model Tree to enter the Mesh 

module.  
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To specify the element size, select Seed → Part, and open the Global Seeds dialog box. Enter 0.05 

as the approximate global size and click apply to see nodes locations. Click Ok to close the dialog 

box (Figure 9-24). 

 

   

 

Figure 9-24: Seeding 
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Select Mesh → Part and click Yes in the prompt area to mesh generation (Figure 9-25). 
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Figure 9-25: Generating mesh 

 

Writing Keywords: 

As eigenmodes are requested in buckling analysis, these will be used for further post-buckling 

analysis, which is needed to write the eigenmode in the default global system to the result file as 

nodal data. This could be performed by *NODE FIL keyword. The keyword will create a *.fil 

file that contains the results of the eigenmodes in the global system as nodal data. 

Right click on Model-1 and select Edit Keywords from the menu that appears. The Edit 

Keywords dialog box appears containing the input file that has been generated for the model. 

In the Keywords Editor, each keyword is displayed in its own block. Only text blocks with a white 

background can be edited. Select the text block that appears just before the *End Step option at 

the last line. Click Add After to add an empty block of text. 

In the block of text that appears, enter the following: 

*Node fil 

U 

Click Ok to close the keyword box (Figure 9-26). 
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Figure 9-26: Adding a keyword 

 

9.5. Analysis: Job Module 

This is the last step of the Part1. In this step, a job should be defined to analyze the problem and 

extracting the buckling mode. 
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Double click on Jobs in the Model Tree and name the job as Buckling. Then click Continue to 

open the Edit Job dialog box and then click Ok to create the job and close the dialog box. 

Right click on Buckle underneath of Jobs in the Model tree and select Submit to begin the analysis 

(Figure 9-27). 

 

   

    

Figure 9-27: Creating and submitting a job 
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9.6. Analysis Results 

The main results of the buckling analysis are the mode shape and corresponding eigenvalue. The 

eigenvalue in buckling analysis is acritical value that excites the problem. In the sample, the model 

was excited by enforced displacement, so eigenvalue refers to the critical displacement that the 

actuator can have in order to buckle. 

Right click on Buckle to complete the job and select Result from the menu that appears. The 

Visualization module will then be activated. 

Select Result → Step/Frame to open its dialog box (Figure 9-28). 

The calculated eigenvalue is 6.412e-4. Therefore, the critical enforce displacement could be 

obtained by 6.412e-4 ×1 m.  
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Figure 9-28: Extracting eigenvalue 

 

9.7. Display buckling for the first buckling mode shape 

Click Contour plot on the deformed shape, as shown in Figure 9-29. The Legend depicts 

deformations relative in terms from 1. 
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Figure 9-29: Extracting buckling mode 

 

Note that this was the first mode shape that occurred in the top story.  

 

9.8. Extract remaining mode shapes 

9.8.1. Part1 

Click the Next button from the context bar. The second buckling mode shape will be shown. Click 

the button again to view the third and fourth mode shapes, as shown in 
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Figure 9-30. 
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Figure 9-30: The first 4 buckling mode shapes 

 

This is sufficient to choose the first, and the third mode shapes as they are effective in the top and 

bottom stories, respectively. 

 

9.8.2. Part2 

In the next step, the second analysis should be modeled, which consists of implementing the 

buckling mode shape into the whole complete geometry. Here, an enforced displacement should 

be defined to act as the hydraulic actuator and push the buckled shear wall. Finally, a load-

displacement diagram will be created to study how the structure stiffness decreases according to 

nonlinearities. The enforce displacement due to the hydraulic actuator opening, is considered as 

5cm. Note that it is assumed that imperfection is equal to the plate thickness that should be 

considered as a factor of the buckling mode.  

To simulate Part2, it is necessary to define a new model, but as many definitions are the same as 

the buckling one, it could be made by copying and modifying it. Then, the buckle analysis step 

should be replaced by static, general. The enforced displacement analysis is nonlinear, and 

enforced displacement boundary condition should be modified as 0.05 in the z-direction. Finally, 

Imperfection keyword should be used for implementing the buckling mode into the complete 

geometry. 

The imperfection is defined as given in Equation 1: 

 

∆x𝑖 = ∑ 𝑤𝑖𝜑𝑖
𝑚
𝑖=1       (1) 
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where φi is the ith mode shape and wi is the associated scale factor. 

The user must choose the scale factors of the various modes. Usually (if the structure is not 

imperfection sensitive) the lowest buckling mode should have the largest factor. The magnitudes 

of the perturbations used are typically a percentage of a relative structural dimension such as a 

beam cross-section or shell thickness. In the sample, the imperfection scale factor for the first 

buckling mode is assumed to 100 percent of the plate thickness for the upper story and 50 percent 

of the plate thickness for the lower plate. 

To create a new model: 

Right click on Model-1 and select Copy Model from the list that appears. Copy the model as 

PushOver (Figure 9-31). 

 

     

Figure 9-31: Creating a new model by copying Model-1 

 

For replacing the analysis step to nonlinear static instead of buckling: 
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Right click on Step-1 underneath of Steps in the Model tree and select Replace in the list that 

appears. Then choose Static, General from General procedure, and then press Continue. 

In the Basic tabbed page change Nlgeom to include nonlinear geometry in the model. 

In the Incrementation tabbed page, set the initial increment size to 0.01. The value can ensure most 

nonlinear problems to converge incrementally. Then, click Ok to define the analysis step and close 

the dialog box (Figure 9-32). 

   

    

Figure 9-32: Replacing the analysis step 
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9.9. Modify enforced displacement 

Double click on BC-2 and modify the enforce displacement as-0.05, and then click Ok to apply 

the boundary condition (Figure 9-33). 

 

Figure 9-33: Modifying the enforced displacement 

 

9.10. Implement the buckling mode as an imperfection 

Right click on PushOver model and select Edit Keywords and enter keyword editor. 

Select *End Part text box and click Add After, then input the following keyword: 

*Imperfection, File name=Buckle, Step=1 

1,0.0045 

3,0.00225 

 

Finally, click Ok to close the dialog box (Figure 9-34). 
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Figure 9-34: Adding imperfection keyword 

 

Finally, a new job should be defined to simulate the recent model. 
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Double click on Jobs in the Model tree to open the Create Job dialog box. Name the job as 

PushOver and click Continue to open the Edit job dialog box. Click Ok to define the job. 

Right click on PushOver underneath of Jobs and select Submit from the list that appears to begin 

analysis (Figure 9-35). 

 

    

 

Figure 9-35: Define and submit a job 
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9.11. Result of Part 1 

The main result is for checking plasticity regions and stress concentration, as well as a force-

displacement diagram to check how structural stiffness decreases. All output can be achieved in 

the Visualization module. 

To enter the Visualization module, right click on the PushOver completed the job, and select Result 

from the list that appears (Figure 9-36). 

 

   

Figure 9-36: Entering the visualization module 

 

9.11.1. Plot plastic strain contour 

Select PEEQ in the variable combo box. This implies equivalent plastic strain and is good criteria 

to check plasticity. As can be seen, the maximum plastic strain is about 0.0454 that occurred near 

the actuator, which is too, somewhere buckled (Figure 9-37).  
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Figure 9-37: Plotting plastic strain 
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9.11.2. Plot stress concentration 

Select S in the variable combo box and keep Mises as the default invariant. This implies Von Mises 

stress and is good criteria for checking stress in ductile metals. As shown, many areas are yielded 

due to the enforce displacement, especially plated that was buckled (Figure 9-38).  
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Figure 9-38: Plotting Von Mises stress contour 

 

Next, the force-displacement diagram will be created. Note that force-time and displacement-time 

diagrams should be extracted separately for the reference point, and then they are combined to 

create a force-displacement diagram. 
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To create the reaction force and displacement diagrams: 

Double click on XY-Data in the Results tree to open the dialog box, then select ODB field output 

as the Source and click Continue to open its dialog box. 

In the Variable tabbed page, select Unique Nodal as Position, then select RF3 and U3, which refers 

to the reaction force and displacement in the z-direction. 

To determine the reference point, as the output position, in the Elements/Notes tabbed page, select 

Node sets as the Method and Assembly Constraint-1as a set. Then click Save and Ok in the Save 

XYData dialog box which implies the plot names. Finally, click Dismiss to close the dialog box 

(Figure 9-39).  
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Figure 9-39: Creating the reaction force and displacement diagrams 

 

9.12. Combine the reaction force and displacement diagrams 

Double click on XY-Data in the Results tree and select Operate on XY data as a Source, then click 

Continue to open its dialog box. 

Choose Combine as Operator and then double click on U:U3 PI and RF:RF3 PI data respectively 

to copy their data in combine operator. 

Consider minus for both diagrams. This is because the loading on the structure given it moves in 

the opposite direction of the Z-axis and has produced negative values. By the minus, this means 

the values will be positive. 

Finally, click Plot Expression to create a force-displacement diagram and click Cancel to close the 

dialog box (Figure 9-40). 
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Figure 9-40: Plotting the force-displacement diagram 

 

It can be seen that stiffness decreases incrementally, especially after 1cm movement.  


